Autor Thema: Thunar als root  (Gelesen 1487 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline guelu

  • Neuling
  • *
  • Beiträge: 27
  • Desktop: xfce
  • Grafikkarte: intel HD Graphics 4600
  • Grafikkartentreiber: open
  • Kernel: 4.11.3-1
  • Prozessor: i5-4460
  • Skill: Durchschnitt
  • Zweig: stable
Thunar als root
« am: 02. Juni 2017, 21:28:06 »
Hallo,
ich starte hin und wieder thunar als root. Dabei stört mich, dass er die Einstellungen verliert.
Ich hätte gerne, dass er beim Start als root versteckte Dateien anzeigt und die Kompaktansicht verwendet.

Hat jemand eine Idee woran es liegen kann, dass er die Einstellungen immer wieder zurücksetzt?
Gibt es evtl. Startoptionen für mein Problem, die ich noch nicht gefunden habe?

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1554
  • Dankeschön: 303 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #1 am: 02. Juni 2017, 23:09:38 »
Hallo guelu,
ich starte hin und wieder thunar als root. Dabei stört mich, dass er die Einstellungen verliert.
Ich hätte gerne, dass er beim Start als root versteckte Dateien anzeigt und die Kompaktansicht verwendet.
Ich hoffe mal, daß Du in dem Fall thunar mit gksu startest, also
gksu thunar &Zumindest bei mir klappt es dabei mit den normalen Einstellungen, also
Bearbeiten -> Einstellungen -> Anzeige -> usw. ...
Dann öffnet thunar beim nächsten gksu thunar & auch wieder brav so seine Einstellungen wie gewünscht.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline guelu

  • Neuling
  • *
  • Beiträge: 27
  • Desktop: xfce
  • Grafikkarte: intel HD Graphics 4600
  • Grafikkartentreiber: open
  • Kernel: 4.11.3-1
  • Prozessor: i5-4460
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #2 am: 03. Juni 2017, 00:07:25 »
Hallo gosia,

normalerweise starte ich mit sudo thunar
Mit gksu thunar & kommt folgendes:

[1] 7306

Dann nach geraumer Zeit die Frage nach dem Passwort und etwas später

Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Thunar: Failed to initialize Xfconf: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead


Dann nach einiger Zeit das thunar-Fenster aber wie gehabt nicht mit den gewünschten Einstellungen.

Viele Grüße
guelu

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1554
  • Dankeschön: 303 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #3 am: 03. Juni 2017, 11:43:58 »
Hallo guelu,
das sieht nicht gut aus  :( Das einzige, was mir im Moment dazu einfällt, ist gnome-keyring installiert und gestartet? Was sagt
gnome-keyring-daemon
Und kurz zum Unterschied von sudo und gksu/gksudo:
sudo startet mit root-Privilegien aber mit der Konfiguration des User, gksu/gksudo startet ebenfalls mit Root-Rechten und der Konfiguration von root.
http://www.psychocats.net/ubuntu/graphicalsudo

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline guelu

  • Neuling
  • *
  • Beiträge: 27
  • Desktop: xfce
  • Grafikkarte: intel HD Graphics 4600
  • Grafikkartentreiber: open
  • Kernel: 4.11.3-1
  • Prozessor: i5-4460
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #4 am: 03. Juni 2017, 13:03:13 »
Hallo gosia,

danke für die Info, den Unterschied wusste ich bisher nicht.
Die Eingabe von gnome-keyring-daemon ergibt:
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

Viele Grüße
guelu
g


Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1554
  • Dankeschön: 303 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #5 am: 03. Juni 2017, 16:47:14 »
Hallo guelo,
Die Eingabe von gnome-keyring-daemon ergibt:
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Das sieht gut aus. Im Moment keine Ahnung, warum es bei dir nicht funktioniert, habe aber einen alten Link gefunden, bei dem schon jemand dein Problem hatte.
https://classicforum.manjaro.org/index.php?topic=15464.0
Den dort vorgeschlagenen workaround mit Privilege Granting Preferences kann ich zwar nicht bestätigen, aber vielleicht hilft es ja bei dir.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline guelu

  • Neuling
  • *
  • Beiträge: 27
  • Desktop: xfce
  • Grafikkarte: intel HD Graphics 4600
  • Grafikkartentreiber: open
  • Kernel: 4.11.3-1
  • Prozessor: i5-4460
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #6 am: 03. Juni 2017, 22:07:31 »
Hallo gosia,

der workaround hat zwar die Wartezeiten beseitigt aber die fehlende Merkbereitschaft von thunar als root für die Einstellungen ist geblieben.

Ich habe sogar schon versucht mit einem script thunar als root zu starten und dann mit xdotool die Tasteneingaben zu simulieren.
Erfolg = 0. thunar kam zwar als root aber stur ohne die gewünschten Einstellungen.

Ich überlege schon ob ich nicht zu nautilus wechsele aber das muss doch irgendwie zu knacken sein.

Kann es sein, dass irgendwo die Rechte nicht stimmen?

Viele Grüße
guelu

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1554
  • Dankeschön: 303 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #7 am: 03. Juni 2017, 23:45:47 »
Hallo guelu,
der workaround hat zwar die Wartezeiten beseitigt aber die fehlende Merkbereitschaft von thunar als root für die Einstellungen ist geblieben.
das mit den Wartezeiten ist ja schon mal was, aber warum er sich bei dir nicht die Einstellungen merkt, verstehe ich nicht. Bei mir funktioniert das, habe ich gerade nochmals ausprobiert.
Ich habe sogar schon versucht mit einem script thunar als root zu starten und dann mit xdotool die Tasteneingaben zu simulieren.
Erfolg = 0. thunar kam zwar als root aber stur ohne die gewünschten Einstellungen.
Das nenne ich doch mal Kampfgeist ;) Aber da die Einstellungen für root in /root/.config/Thunar/accels.scm gespeichert werden liesse sich vielleicht durch Manipulation dieser Datei etwas ausrichten. Allerdings habe ich mich mit dem Format der Datei nicht weiter auseinandergesetzt. Steht aber bestimmt irgendwo was in den Weiten des Internets.
Kann es sein, dass irgendwo die Rechte nicht stimmen?
Unwahrscheinlich. Das wäre ja nur der Fall, wenn die Konfigurationsdatei in /root/.config/Thunar/ selbst für root nicht schreibbar wären.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: guelu

Offline guelu

  • Neuling
  • *
  • Beiträge: 27
  • Desktop: xfce
  • Grafikkarte: intel HD Graphics 4600
  • Grafikkartentreiber: open
  • Kernel: 4.11.3-1
  • Prozessor: i5-4460
  • Skill: Durchschnitt
  • Zweig: stable
Re: Thunar als root
« Antwort #8 am: 04. Juni 2017, 16:51:06 »
Hallo gosia,

jetzt hat mich die kalte Wut gepackt, Ergebnis
eine Datei namens starte_thunar_als_root.sh
xdotool exec sudo thunar / # Thunar starten als root
xdotool sleep 0.1                         # warten, bis Thunar aufgebaut ist (kann auf anderen Rechnern andere Zeit sein)
xdotool key "ctrl+h"                  # verborgene Dateien anzeigen
xdotool key "ctrl+3"                  # Kompaktansicht aktivieren

Datei ausführbar machen, Starter anlegen, klappt.

Ich lasse mich doch nicht von einem widerborstigen Programm an der Nase herumführen  ;)

Viele Grüße
guelu