Autor Thema: NVIDIA Aktualisierung klappt nicht  (Gelesen 1286 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
NVIDIA Aktualisierung klappt nicht
« am: 21. Oktober 2017, 10:31:53 »
Bei der Aktualisierung bekomme ich immer folgende Meldung :

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: linux410-nvidia-340xx: das Installieren von nvidia-340xx-utils (340.104-1) verletzt Abhängigkeit von 'nvidia-340xx-utils=340.102'

Wie bekomme ich es wieder zum laufen ?

MfG R.Lehmeier

Offline Nostradamus

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 153
  • Dankeschön: 4 mal
  • Desktop: KDE Manjaro
  • Grafikkarte: intel nvidia bumblebee / Intel Baytrail / Nvidia GT 820M
  • Grafikkartentreiber: nvidia-375 nvidia-prime Eigenbau
  • Kernel: 4.18
  • Prozessor: Intel Corporation Atom Processor E3800 Series Quad 2,2
  • Skill: Durchschnitt
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #1 am: 21. Oktober 2017, 11:20:50 »
die packete mit abhängigkeit deinstallieren......

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #2 am: 21. Oktober 2017, 11:22:19 »
Der 4.10'er Kernel ist eh EOL. Hast du sonst noch einen Kernel installiert?

4.9. oder 4.13 würde ich probieren. Dann den 4.10'er deinstallieren, reboot und die Updates einspielen.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #3 am: 21. Oktober 2017, 12:23:16 »
Ich habe für den 4.10 die NVIDIA Treiber deinstalliert und wollte folgendes installieren :

Linux 413
und Linux 414 jeweils mit headers, Grafiktreiberund Virtualbox modulen


aber ich bekomme immer folgende Fehlermeldung:

resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)

Befehl endete mit FEHLERN !


Dieses Abhängigkeitsproblem blockiert im Moment alles.

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #4 am: 21. Oktober 2017, 12:27:37 »
Gib uns mal in einem Code Block die Ausgabe von:

sudo pacman -Syyuu
Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #5 am: 21. Oktober 2017, 13:32:04 »
Dabei kommt eine Fehlermeldung :

Fehler: udiskie: signature from "Ambrevar <ambrevar@gmail.com>" is unknown trust
:: Datei /var/cache/pacman/pkg/udiskie-1.7.1-1-any.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Irgendwie klemmt hier noch was.

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #6 am: 21. Oktober 2017, 17:49:05 »
OK, dann zuerst:

sudo pacman-key --refresh-keys
gefolgt von:

sudo pacman-key --populate archlinux manjaro
danach dann:

sudo pacman -Syyu
Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #7 am: 21. Oktober 2017, 18:15:11 »
Immer noch dasselbe Problem. :-(

Wenn ich deine Schritte abarbeite bekomme ich :

:: Installation fortsetzen? [J/n] j
(253/253) Prüfe Schlüssel im Schlüsselring                                                                    [##################################################################] 100%
(253/253) Überprüfe Paket-Integrität                                                                          [##################################################################] 100%
Fehler: zstd: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: blosc: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Nachdem ich die defekten Pakete habe löschen lasse bekomme ich :

:: Installation fortsetzen? [J/n] j
:: Empfange Pakete...
 zstd-1.3.1-1-x86_64                                                                 266,3 KiB   888K/s 00:00 [##################################################################] 100%
 blosc-1.12.1-1-x86_64                                                               255,3 KiB  1009K/s 00:00 [##################################################################] 100%
(253/253) Prüfe Schlüssel im Schlüsselring                                                                    [##################################################################] 100%
(253/253) Überprüfe Paket-Integrität                                                                          [##################################################################] 100%
Fehler: zstd: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: blosc: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Sehe ich es richtig das die beiden Pakete von Haus aus beschädigt sind ?

Da ich nicht weiß wo sie zugehören weiß ich auch nicht wie ob und wie ich sie einfach löschen kann.

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #8 am: 21. Oktober 2017, 18:18:14 »
Du kannst ja per pacman nachsehen wozu die beiden Pakete gehören oder im Paketmanager.

Anhand der zu aktualisierenden Paketanzahl hast du länger kein Update mehr eingespielt?

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #9 am: 21. Oktober 2017, 19:22:50 »
Ich nutze Manjaro nicht täglich aber ca 250 Pakete erscheinen mir auich nicht zuviel.

Wwenn ich pacman  -Fs zstd-1.3.1-1-x86_64 oder pacman  -Fs blosc-1.12.1-1-x86_64.pkg.tar.xz
eingebe um das Paket zu finden in dem die Datei ist, bekomme ich folgende Meldung:

Warnung: database file for 'core' does not exist
Warnung: database file for 'extra' does not exist
Warnung: database file for 'community' does not exist
Warnung: database file for 'multilib' does not exist

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #10 am: 21. Oktober 2017, 19:29:02 »
Nächster Versuch: bitte beide Befehle nacheinander machen

sudo pacman -Syy

sudo pacman -Syu

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #11 am: 21. Oktober 2017, 19:46:41 »
Immer noch dasselbe Resultat :

:: Empfange Pakete...
 zstd-1.3.1-1-x86_64                                                                 266,3 KiB   888K/s 00:00 [##################################################################] 100%
 blosc-1.12.1-1-x86_64                                                               255,3 KiB   993K/s 00:00 [##################################################################] 100%
(253/253) Prüfe Schlüssel im Schlüsselring                                                                    [##################################################################] 100%
(253/253) Überprüfe Paket-Integrität                                                                          [##################################################################] 100%
Fehler: zstd: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: blosc: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #12 am: 21. Oktober 2017, 22:00:25 »
Da immer wieder die 2 Pakete als defekt gemeldet wurden habe ich Sie mit
"sudo pacman -Rdd blosc" und
"sudo pacman -Rdd zstd" entfernt.

Diese Befehle habe ich von : https://wiki.archlinux.de/title/Pacman

Da es mit dem Update immer noch nicht klappte habe ich versucht die Schlüssel zu erneuern indem ich
"sudo pacman-key --refresh-keys",
"sudo pacman-key --populate archlinux manjaro" und
"sudo pacman -Syyu" ausführte.

Leider ohne Erfolg. Es kommt die Ausgabe:

:: Empfange Pakete...
 zstd-1.3.1-1-x86_64                                                                 266,3 KiB   879K/s 00:00 [##################################################################] 100%
 blosc-1.12.1-1-x86_64                                                               255,3 KiB  1021K/s 00:00 [##################################################################] 100%
(253/253) Prüfe Schlüssel im Schlüsselring                                                                    [##################################################################] 100%
(253/253) Überprüfe Paket-Integrität                                                                          [##################################################################] 100%
Fehler: zstd: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: blosc: signature from "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" is marginal trust
:: Datei /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Ich versuchte es auch mit Octopi aber leider bekam ich dort auch nur :

checking keys in keyring
checking package integrity
error: zstd: signature from "Andrzej Giniewicz (giniu) " is marginal trust

:: File /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: blosc: signature from "Andrzej Giniewicz (giniu) " is marginal trust

:: File /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Befehl endete mit FEHLERN !

Bin mal gespannt ob das noch zum laufen kommt.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #13 am: 21. Oktober 2017, 22:58:06 »
Seitdem ich mit pacman -Scc den Cache geleert habe läuft es durch.
Hoffen wir das es so bleibt.

Danke für eure Hilfe.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 159
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: NVIDIA Aktualisierung klappt nicht
« Antwort #14 am: 21. Oktober 2017, 23:44:54 »
Das war wohl nichts: Da ist sie wieder:

error: zstd: signature from "Andrzej Giniewicz (giniu) " is marginal trust

:: File /var/cache/pacman/pkg/zstd-1.3.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: blosc: signature from "Andrzej Giniewicz (giniu) " is marginal trust

:: File /var/cache/pacman/pkg/blosc-1.12.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Befehl endete mit FEHLERN !

Wie kann ein defektes Paket im Cache sein wenn er vorher geleert wurde?