Autor Thema: bootfehler: Failed to activate swap  (Gelesen 187 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline zwiloe

  • Neuling
  • *
  • Beiträge: 28
  • Desktop: Deepin
  • Grafikkarte: NVIDIA GeForce GT710
  • Grafikkartentreiber: video-nvidia-390xx
  • Kernel: 4.17
  • Prozessor: Intel Core2Duo E8500
  • Skill: Anfänger
  • Zweig: stable
bootfehler: Failed to activate swap
« am: 05. Juni 2018, 22:44:12 »
hi zusammen.
ich bin sehr neu und frisch in sachen linux und habe nach der mint-langeweile auf manjaro xfce gewechselt. mein lapi geht ohne fehler durch aber mein pc is da was eigen. da ich noch win 10 nutze konnte ich keine swappartition einrichten (4 aktive partitionen). hab ein swapfile eingerichtet, nach den anleitungen, wie ich es im netz fand. aber irgendwie komm ich hier nicht weiter, da ich echt keine ahnung habe.
so wie hier z.b.:
https://wiki.ubuntuusers.de/Swap/

in der fstab steht das hier drin:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=3745f788-f78a-4e4b-a5ab-58e151d1e79b /              ext4    defaults,noatime,discard 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/var/cache/swap/swap0    none    swap    sw      0 0

fehlermeldung ist dann folgende:

systemd[1]: Failed to activate swap /var/cache/swap/swap0.



vllt habt ihr eine idee, wie ich es lösen kann.
danke sehr!!!

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1289
  • Dankeschön: 243 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.9 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: bootfehler: Failed to activate swap
« Antwort #1 am: 05. Juni 2018, 23:26:16 »
Hallo zwiloe,
willkommen im Forum  :)
Prüfe mal nach, ob Du dein Swap-File so wie in dieser Anleitung angelegt hast
https://wiki.archlinux.org/index.php/Swap#Swap_file
Vielleicht ist die dort beschriebene automatisierte Methode mit systemd-swap einfacher.

Viele Grüße gosia

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1289
  • Dankeschön: 243 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.9 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: bootfehler: Failed to activate swap
« Antwort #2 am: 06. Juni 2018, 13:21:34 »
Hallo zwiloe,
habe das jetzt mal durchgespielt, sowohl nach der Ubuntu-Anleitung als auch nach Manjaro-Anleitung (unterscheiden sich ja eigentlich nicht). Wenn Du das genau so gemacht hast, müsste es eigentlich funktionieren. Könnte vielleicht irgendwo ein Tipp-Fehler passiert sein, z.B. statt swap0 (mit Null) ein swapO (mit großem O)? Soll ja manchmal passieren.
Kannst ja mal die Ausgabe von
ls -l /var/cache/swap/
free -h
systemctl --failed
posten. Vielleicht sieht man da ja was besser.
Und noch nebenbei, wieso eigentlich 4 primäre Partitionen? Ist ja auch mit Windows nicht unbedingt notwendig. Gingen nicht auch drei primäre und eine erweiterte?

Viele Grüße gosia

Offline zwiloe

  • Neuling
  • *
  • Beiträge: 28
  • Desktop: Deepin
  • Grafikkarte: NVIDIA GeForce GT710
  • Grafikkartentreiber: video-nvidia-390xx
  • Kernel: 4.17
  • Prozessor: Intel Core2Duo E8500
  • Skill: Anfänger
  • Zweig: stable
Re: bootfehler: Failed to activate swap
« Antwort #3 am: 06. Juni 2018, 23:14:22 »
hi und danke erst mal.

habe die befehle ja mit copy&past eingefügt. denke da ist es richtig. hab sowas in nem txt-file, damit ich die einträge nicht mehr suchen muss, wenn ich das neu mache, dort seh ich, dass es ne 0 ist ;-)

hier die ausgabe aus dem terminal:

ls -l /var/cache/swap/
insgesamt 9437188
-rw------- 1 root root 9663676416  5. Jun 01:24 swap0


free -h
              gesamt       benutzt     frei      gemns.  Puffer/Cache verfügbar
Speicher:       7,8Gi       1,1Gi       5,7Gi       102Mi       1,1Gi       6,5Gi
Swap:            0B          0B          0B


systemctl --failed
0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.



swap ist ja inaktiv. habe den eintrag erstmal aus fstab gelöscht. geht ja eh erst mal nicht ;-)

von win sind es einmal die 100 MB sys-partition, dann die win-partition, dann gibt es die wiederherstellungs-partition von win und dann die von xfce.
ich könnte bei gefallen, die wiederherstellungs-part. vllt löschen. das seh ich dann aber. umd wenn es das swap-file auch macht, dann brauch ich keine partition.
« Letzte Änderung: 06. Juni 2018, 23:20:59 von zwiloe »

Offline zwiloe

  • Neuling
  • *
  • Beiträge: 28
  • Desktop: Deepin
  • Grafikkarte: NVIDIA GeForce GT710
  • Grafikkartentreiber: video-nvidia-390xx
  • Kernel: 4.17
  • Prozessor: Intel Core2Duo E8500
  • Skill: Anfänger
  • Zweig: stable
Re: bootfehler: Failed to activate swap
« Antwort #4 am: 07. Juni 2018, 07:32:18 »
also, wenn ich gparted oder ein win partitionsprogramm nehme, dann ist es die letzte partition. ich hatte von der win partition nachdem ich xcfe schon drauf hatte, extra was weggenommen, um damit die swap-part. einzurichten, dann kam die meldung, dass es nicht geht. ich hab dann den bereich ganz nach hinten geschoben, dann ging grub nicht mehr. hab dann im netz gesucht und super-grub2 gefunden, damit konnte ich den booloader wieder herstellen und alles ging wieder. dann hab ich das mit dem swapfile gemacht. komischerweise kann ich unter gparted die linux-partition nicht wieder kleiner machen. das is echt seltsam. gibt es da ne erklärung für?

fdisk -l
Festplatte /dev/sda: 232,9 GiB, 250059350016 Bytes, 488397168 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: dos
Festplattenbezeichner: 0xb1b15f5a

Gerät      Boot    Anfang      Ende  Sektoren  Größe Kn Typ
/dev/sda1  *         2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2          206848 347406250 347199403 165,6G  7 HPFS/NTFS/exFAT
/dev/sda3       348498045 488396799 139898755  66,7G 83 Linux
/dev/sda4       347421697 348385589    963893 470,7M  f W95 Erw. (LBA)
/dev/sda5       347421760 348385589    963830 470,6M 27 Verst. NTFS WinRE

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.


die anderen platten hab ich gelöscht, da unwichtig.
die OS-platte ist eine ssd, also eher schneller ;-)

Offline zwiloe

  • Neuling
  • *
  • Beiträge: 28
  • Desktop: Deepin
  • Grafikkarte: NVIDIA GeForce GT710
  • Grafikkartentreiber: video-nvidia-390xx
  • Kernel: 4.17
  • Prozessor: Intel Core2Duo E8500
  • Skill: Anfänger
  • Zweig: stable
Re: bootfehler: Failed to activate swap
« Antwort #5 am: 07. Juni 2018, 07:41:24 »
so... jetzt hab ich den fehler gefunden. heute morgen im bett erinnerte ich mich, dass ich da beim erstellen eine fehlermeldung hatte, aber aus unwissenheit ignorierte.

bei sudo mkswap /var/cache/swap/swap0 hatte ich sudo nicht mit eingegeben. auf irgendeiner seite stand das nicht dabei, bis ich den ubuntu-link hatte. das wars. keine fehlermeldung mehr in dem zusammenhang. blöde sache.

immer diese anfängerfehler ;-)

danke sehr für eure hilfe...... !!!!!!!!!!!!!!