Autor Thema: Systemklänge erhöhen immer die Lautstärke  (Gelesen 2287 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline gnampf

  • Neuling
  • *
  • Beiträge: 9
  • Desktop: Xfce
  • Grafikkarte: Nvidia GTX660
  • Grafikkartentreiber: nonfree
  • Kernel: 3.14.32
  • Prozessor: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
  • Skill: Durchschnitt
Systemklänge erhöhen immer die Lautstärke
« am: 02. März 2014, 11:06:33 »
Hallo Zusammen,
ich habe die aktuelle XFCE-Edition neu installiert, weil ich vom KDE genug hatte. Das Home habe ich nicht angerührt. Das Backend ist das Phono-VLC.
Das Problem: Immer wenn ein Systemklang abgespielt wird, z.B. beim Löschen einer Datei dreht es mir den "Playback:Internes Audio Analog Stereo (Pulse Audio Mixer)" immer auf volle Lautstärke.

Könnte das auch was mit dem Pulse Audio zu tun haben? Den hier beschriebenen Effekt habe ich auch.
http://wiki.manjaro.org/index.php?title=Volume_Stuck_on_Mute_%28XFCE_Desktop%29

Da ich nicht ohne Plan da herumpfuschen will, wäre ich für ein paar Tipps dankbar.

Offline DrMartinus

  • Jr. Mitglied
  • **
  • Beiträge: 74
  • Desktop: KDE 5.8.2
  • Grafikkarte: Radeon HD 6790
  • Grafikkartentreiber: free
  • Kernel: 4.4.28-2-MANJARO 64-bit
  • Prozessor: AMD FX-6100
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #1 am: 26. August 2014, 06:33:21 »
Hallo,
hast Du das Problem gelöst? Bei mir tritt nahezu das gleiche Phänomen auf, allerdings unter KDE. Dort gibt es im Mixer einen eigenen Regler für Ereignistöne, der wird auf volle Lautstärke gedreht, obwohl ich ihn immer wieder runterdrehe. Ich habe Manjaro KDE erst vorgestern installiert.

Offline bero

  • Sr. Mitglied
  • ****
  • Beiträge: 309
  • Dankeschön: 5 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #2 am: 26. August 2014, 07:46:14 »
Hi,

ich kann das Problem bestätigen, habe ich aber bisher noch nicht mit einer Lösung beschäftigt (außer ärgern und wieder runter drehen  :) )
Wenn ich dazu komme, werde ich mich im Verlauf der Woche mal eingehender damit beschäftigen.

Gruß bero

Offline caho

  • Held Mitglied
  • *****
  • Beiträge: 660
  • Dankeschön: 18 mal
  • Desktop: Plasma 5.x
  • Kernel: 4.19
  • Prozessor: Intel Quad Core i7-2600
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #3 am: 26. August 2014, 08:46:32 »
Hi All,

bei mir unter KDE tritt das Problem auch auf.

Gruß
caho
Ein Freund klassischer Gitarre

Offline bero

  • Sr. Mitglied
  • ****
  • Beiträge: 309
  • Dankeschön: 5 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #4 am: 28. August 2014, 07:42:53 »
habe mal ein bisschen gestöbert, hier:
http://wiki.ubuntuusers.de/Sound_Problembehebung#Loesungen unter Lautstärke speichern wird ein Lösungsansatz beschrieben, den ich aber erst heute abend an der Linuxkiste testen kann.
Vielleicht hat ja jemand vorher Lust........

Offline DrMartinus

  • Jr. Mitglied
  • **
  • Beiträge: 74
  • Desktop: KDE 5.8.2
  • Grafikkarte: Radeon HD 6790
  • Grafikkartentreiber: free
  • Kernel: 4.4.28-2-MANJARO 64-bit
  • Prozessor: AMD FX-6100
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #5 am: 08. Januar 2015, 19:50:52 »
ich habe das Problem noch immer, und im KMix ist der Systemsound inzwischen permanent auf "Aus" gestellt. Dennoch kommen die System-Töne (Alarm bei neuem Termin u.ä.) mit voller Lautstärke, was schon recht extrem ist und durchs ganze Haus hallt sowie mir regelmäßig einen mächtigen Schrecken einjagt. :-X Daher nochmal meine Frage, ob jemand eine Lösung gefunden hat. Die von bero vorgeschlagene Webseite schlägt alsamixer vor, nur der ist nur als gnome-Variante verfügbar und zeigt keine Auffälligkeiten, außerdem wird auf der Webseite eher vom Gegenteil (kein Ton) ausgegangen und nicht von dem spezifischen Problem, dass ausschließlich System-Sounds mit der extremen Voll-Lautstärke wiedergegeben werden, während Musik usw. sich alles im moderaten Rahmen bewegt.

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Systemklänge erhöhen immer die Lautstärke
« Antwort #6 am: 08. Januar 2015, 20:28:32 »
Ich habe mich erinnert an ähnliche Klagen im SolydK-Forum und habe mal etwas gesucht.

Möglicherweise hilft dir diese Vorgehensweise:
http://forums.solydxk.com/viewtopic.php?f=13&t=2637&hilit=sound+to+loud#p25171

Es ist übrigens ein bekanntes KDE-Problem - über Linux-Distributionen hinweg. Siehe hier:
https://wiki.archlinux.org/index.php/PulseAudio#Clients_alter_master_output_volume_.28aka_volume_jumps_to_100.25_after_running_application.29

Das steht zum Beispiel beim genannten Link im Arch-WIKI zu lesen:
Zitat
flat-volumes
If yes (default), all input sources have their volume relative to the maximum volume of the entire sound card. This allows each application to individually adjust their volume so for example, raising your VoIP call volume will raise the hardware volume and adjust your music player volume so it stays where it was, avoiding confusion by having to lower manually the music player then raise the global volume.
Warning: Sometimes this can be more confusing than what it solves and some applications unaware of this feature can set their volume at 100% at startup, potentially blowing your speakers or your ears. If unsure, prefer to set this to no so pulse will use the classic ALSA behavior instead.

Edit:
Da du scheinbar munter hin- und heristalliert hast, kann es gut sein, dass dein Pulse-Verzeichnis noch alte Überreste hat und mal gereinigt gehört:
Das habe ich dazu gefunden:
Zitat
killall kmix
rm -rf .pulse/
rm -rf .pulse-cookie
rm -rf .config/pulse/
kmix
Gefunden hier: https://userbase.kde.org/Sound_Problems#After_an_update.2C_PulseAudio_gives_you_very_low_volume
« Letzte Änderung: 08. Januar 2015, 20:32:29 von Hubsi_Gberg »