Autor Thema: Error: "file /root/.Xauthority does not exist"  (Gelesen 4215 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1470
  • Dankeschön: 282 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #15 am: 30. Juli 2018, 20:40:16 »
Hallo Jürgen,
also doch gdm?
Ist mir zu hoch. Müsste da nicht auch das Paket gdm installiert sein?
Ne, ich weiss es nicht. Da ich weder Gnome noch systemd benutze gebe ich den Stab lieber weiter. vetzki oder andere werden das Wirrwarr bestimmt auflösen, ich bin jetzt ratlos.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #16 am: 31. Juli 2018, 08:55:47 »
wiegesagt
- mal das startx versuchen mit passender session
- schaun ob gdm überhaupt noch installiert ist

bzw. evtl. mal die betroffenen pakete aus dem pacman.log vom update zeigen
egrep '\[2018-07-28.*\]' /var/log/pacman.log # datum anpassen

Offline Jurgen_K

  • Neuling
  • *
  • Beiträge: 19
  • Dankeschön: 1 mal
  • Desktop: Gnome
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: free?
  • Kernel: 4.9.68-1-Manjaro x64
  • Prozessor: Intel Core i5-4200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #17 am: 31. Juli 2018, 11:16:17 »
@vetzki
Vielen Dank soweit für die Unterstützung.

wiegesagt
- mal das startx versuchen mit passender session

Nochmal knapp alle Informationen zusammengetragen:
Nach dem Rechnerstart befinde mich im tty1 User Interface, habe mich in diese Text Console eingeloggt und kann mit dem Befehl startx nicht in die xsession wechseln. Wie bereits geposted spuckt startx nach angepasster session (in der ~/.xinitrc Datei) folgende Meldung aus:
X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.17.0-1-MANJARO x86_64
Current Operating System: Linux xxx-pc 4.14.57-1-MANJARO #1 SMP PREEMPT Sun Jul 22 19:25:51 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.14-x86_64 root=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx rw quiet resume=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
Build Date: 20 May 2018  06:17:37PM
 
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/xxx/.local/share/xorg/Xorg.0.log", Time: Mon Jul 30 19:01:05 2018
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
> Internal error:   Could not resolve keysym XF86WWAN
> Internal error:   Could not resolve keysym XF86RFKill
> Internal error:   Could not resolve keysym XF86Keyboard
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
> Internal error:   Could not resolve keysym XF86WWAN
> Internal error:   Could not resolve keysym XF86RFKill
> Internal error:   Could not resolve keysym XF86Keyboard
Errors from xkbcomp are not fatal to the X server
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

- schaun ob gdm überhaupt noch installiert ist
Wie gesagt, ich bekommen für pacman -Qs gdm folgende Ausgabe:
local/libgdm 3.28.2+19+g161f3462-1
   GDM support library


bzw. evtl. mal die betroffenen pakete aus dem pacman.log vom update zeigen
egrep '\[2018-07-28.*]\' /var/log/pacman.log # datum anpassen
Welcher Teil der Log-Datei ist hier von Interesse? Der vom Zeitpunkt des "Crashes"? Oder das letzte gezogene Update? Ich liefere Gewünschtes gerne nach.

Liebe Grüße
Jurgen

EDIT:
Falls hilfreich hier schon mal der log des letzen updates:
[2018-07-30 12:13] [PACMAN] Running 'pacman -Syu'
[2018-07-30 12:13] [PACMAN] synchronizing package lists
[2018-07-30 12:14] [ALPM] transaction started
[2018-07-30 12:14] [ALPM] upgraded manjaro-system (20180702-1 -> 20180716-1)
[2018-07-30 12:14] [ALPM] transaction completed
[2018-07-30 12:14] [ALPM] running 'systemd-update.hook'...
[2018-07-30 12:14] [PACMAN] starting full system upgrade
[2018-07-30 12:18] [ALPM] running '70-dkms-remove.hook'...
[2018-07-30 12:18] [ALPM] transaction started
[2018-07-30 12:18] [ALPM] upgraded libgpg-error (1.31-1 -> 1.32-1)
[2018-07-30 12:18] [ALPM] upgraded gdbm (1.14.1-1 -> 1.16-1)
[2018-07-30 12:18] [ALPM] upgraded perl (5.26.2-1 -> 5.26.2-2)
[2018-07-30 12:18] [ALPM] upgraded e2fsprogs (1.44.2-1 -> 1.44.3-1)
[2018-07-30 12:18] [ALPM] upgraded libsasl (2.1.26-12 -> 2.1.26-13)
[2018-07-30 12:18] [ALPM] upgraded device-mapper (2.02.177-5 -> 2.02.180-1)
[2018-07-30 12:18] [ALPM] upgraded libnftnl (1.1.0-1 -> 1.1.1-1)
[2018-07-30 12:18] [ALPM] upgraded accountsservice (0.6.49-1 -> 0.6.50-1)
[2018-07-30 12:18] [ALPM] upgraded adapta-maia-theme (3.93.1.28-1 -> 3.94.0.20-1)
[2018-07-30 12:18] [ALPM] upgraded android-udev (20180112-1 -> 20180715-1)
[2018-07-30 12:18] [ALPM] upgraded apr-util (1.6.1-2 -> 1.6.1-3)
[2018-07-30 12:18] [ALPM] upgraded apache (2.4.33-3 -> 2.4.34-1)
[2018-07-30 12:18] [ALPM] upgraded llvm-libs (6.0.0-4 -> 6.0.1-1)
[2018-07-30 12:18] [ALPM] upgraded mesa (18.1.3-1 -> 18.1.4-1)
[2018-07-30 12:18] [ALPM] upgraded harfbuzz (1.8.2-1 -> 1.8.4-1)
[2018-07-30 12:18] [ALPM] upgraded pango (1.42.1-1 -> 1.42.2-1)
[2018-07-30 12:18] [ALPM] upgraded libxinerama (1.1.3-3 -> 1.1.4-1)
[2018-07-30 12:18] [ALPM] upgraded libxkbcommon (0.8.0-1 -> 0.8.0-2)
[2018-07-30 12:18] [ALPM] upgraded avahi (0.7+4+gd8d8c67-1 -> 0.7+16+g1cc2b8e-1)
[2018-07-30 12:18] [ALPM] upgraded gnutls (3.5.18-1 -> 3.5.19-1)
[2018-07-30 12:18] [ALPM] upgraded libtiff (4.0.9-1 -> 4.0.9-2)
[2018-07-30 12:18] [ALPM] upgraded curl (7.60.0-1 -> 7.61.0-1)
[2018-07-30 12:18] [ALPM] upgraded python (3.6.5-3 -> 3.6.6-1)
[2018-07-30 12:18] [ALPM] upgraded pacman-mirrors (4.11.2-1 -> 4.11.5-1)
[2018-07-30 12:18] [ALPM] upgraded npth (1.5-1 -> 1.6-1)
[2018-07-30 12:18] [ALPM] upgraded gnupg (2.2.8-1 -> 2.2.9-1)
[2018-07-30 12:18] [ALPM] upgraded appstream-glib (0.7.7-2 -> 0.7.10-1)
[2018-07-30 12:18] [ALPM] upgraded arc-themes-maia (20180114-1 -> 20180715-1)
[2018-07-30 12:18] [ALPM] upgraded archlinux-appstream-data (20180617-1 -> 20180712-1)
[2018-07-30 12:18] [ALPM] upgraded libinput (1.11.1-2 -> 1.11.2-1)
[2018-07-30 12:18] [ALPM] upgraded libxkbcommon-x11 (0.8.0-1 -> 0.8.0-2)
[2018-07-30 12:18] [ALPM] upgraded attica (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded avr-binutils (2.30-1 -> 2.31-1)
[2018-07-30 12:18] [ALPM] upgraded babl (0.1.50+5+g7af0e8c-1 -> 0.1.52-1)
[2018-07-30 12:18] [ALPM] upgraded boost-libs (1.67.0-4 -> 1.67.0-5)
[2018-07-30 12:18] [ALPM] upgraded brotli (1.0.4-1 -> 1.0.5-1)
[2018-07-30 12:18] [ALPM] upgraded zstd (1.3.4-1 -> 1.3.5-1)
[2018-07-30 12:18] [ALPM] upgraded btrfs-progs (4.16.1-2 -> 4.17-1)
[2018-07-30 12:18] [ALPM] upgraded compiler-rt (6.0.0-1 -> 6.0.1-2)
[2018-07-30 12:18] [ALPM] upgraded clang (6.0.0-1 -> 6.0.1-1)
[2018-07-30 12:18] [ALPM] upgraded libuv (1.21.0-1 -> 1.22.0-1)
[2018-07-30 12:18] [ALPM] upgraded cmake (3.11.4-1 -> 3.11.4-2)
[2018-07-30 12:18] [ALPM] upgraded libmagick (7.0.8.4-1 -> 7.0.8.7-1)
[2018-07-30 12:18] [ALPM] upgraded imagemagick (7.0.8.4-1 -> 7.0.8.7-1)
[2018-07-30 12:18] [ALPM] upgraded cups-filters (1.20.3-2 -> 1.20.4-1)
[2018-07-30 12:18] [ALPM] upgraded dhcpcd (7.0.4-1 -> 7.0.5b-1)
[2018-07-30 12:18] [ALPM] upgraded gstreamer (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded gst-plugins-base-libs (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded geoclue2 (2.4.7-1 -> 2.4.10-1.2)
[2018-07-30 12:18] [ALPM] upgraded harfbuzz-icu (1.8.2-1 -> 1.8.4-1)
[2018-07-30 12:18] [ALPM] upgraded evolution-data-server (3.28.3-1 -> 3.28.4-1)
[2018-07-30 12:18] [ALPM] upgraded evolution (3.28.3-1 -> 3.28.4-1)
[2018-07-30 12:18] [ALPM] upgraded f2fs-tools (1.10.0-1 -> 1.11.0-2)
[2018-07-30 12:18] [ALPM] upgraded fakeroot (1.22-1 -> 1.23-1)
[2018-07-30 12:18] [ALPM] upgraded libpulse (12.0-1.1 -> 12.2-1)
[2018-07-30 12:18] [ALPM] upgraded sdl2 (2.0.8-8 -> 2.0.8-9)
[2018-07-30 12:18] [ALPM] upgraded libva (2.1.0-1 -> 2.2.0-2)
[2018-07-30 12:18] [ALPM] upgraded ffmpeg (1:4.0.1-2 -> 1:4.0.2-1)
[2018-07-30 12:18] [ALPM] upgraded file-roller (3.28.0-1 -> 3.28.1-1)
[2018-07-30 12:18] [ALPM] upgraded gst-plugins-base (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded pipewire (0.1.9-3 -> 0.2.0-1)
[2018-07-30 12:18] [ALPM] upgraded xdg-desktop-portal (0.11-1 -> 0.11-2)
[2018-07-30 12:18] [ALPM] upgraded flatpak (0.99.2-1 -> 0.99.3-1)
[2018-07-30 12:18] [ALPM] upgraded lua (5.3.4-2 -> 5.3.5-1)
[2018-07-30 12:18] [ALPM] upgraded suitesparse (5.2.0-1 -> 5.3.0-1)
[2018-07-30 12:18] [ALPM] upgraded gegl (0.4.2+14+g190a81b4a-1 -> 0.4.4-1)
[2018-07-30 12:18] [ALPM] upgraded python2 (2.7.15-1 -> 2.7.15-2)
[2018-07-30 12:18] [ALPM] upgraded gimp (2.10.2-3 -> 2.10.4-2)
[2018-07-30 12:18] [ALPM] upgraded pulseaudio (12.0-1.1 -> 12.2-1)
[2018-07-30 12:18] [ALPM] upgraded pulseaudio-bluetooth (12.0-1.1 -> 12.2-1)
[2018-07-30 12:18] [ALPM] upgraded gnome-bluetooth (3.28.0-1 -> 3.28.1-1)
[2018-07-30 12:18] [ALPM] upgraded gptfdisk (1.0.3-1 -> 1.0.4-1)
[2018-07-30 12:18] [ALPM] upgraded grilo (0.3.4+7+gb144fe0-1 -> 0.3.5-1)
[2018-07-30 12:18] [ALPM] upgraded gst-libav (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded gst-plugins-good (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded gst-plugins-ugly (1.14.1-1 -> 1.14.2-1)
[2018-07-30 12:18] [ALPM] upgraded lvm2 (2.02.177-5 -> 2.02.180-1)
[2018-07-30 12:18] [ALPM] upgraded ndctl (61.1-1 -> 61.2-1)
[2018-07-30 12:18] [ALPM] upgraded xfsprogs (4.16.1-1 -> 4.17.0-1)
[2018-07-30 12:18] [ALPM] upgraded gvfs (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded gvfs-afc (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded gvfs-goa (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded gvfs-google (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded gvfs-mtp (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded libwbclient (4.8.3-1 -> 4.8.3-2)
[2018-07-30 12:18] [ALPM] upgraded ldb (1.4.0-1 -> 1:1.3.4-2)
[2018-07-30 12:18] [ALPM] upgraded smbclient (4.8.3-1 -> 4.8.3-2)
[2018-07-30 12:18] [ALPM] upgraded gvfs-smb (1.36.2-2 -> 1.36.2-3)
[2018-07-30 12:18] [ALPM] upgraded pciutils (3.5.6-1 -> 3.6.1-1)
[2018-07-30 12:18] [ALPM] upgraded hexchat (2.14.1-2 -> 2.14.1-4)
[2018-07-30 12:18] [ALPM] upgraded intel-ucode (20180425-1 -> 20180703-1)
[2018-07-30 12:18] [ALPM] upgraded inxi (3.0.12-1 -> 3.0.18-1)
[2018-07-30 12:18] [ALPM] upgraded jansson (2.10-3 -> 2.11-1)
[2018-07-30 12:18] [ALPM] upgraded karchive (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kcoreaddons (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kauth (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kdbusaddons (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kconfig (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kwindowsystem (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kcrash (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kglobalaccel (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kwidgetsaddons (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kcompletion (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded ki18n (5.47.0-1 -> 5.48.1-2)
[2018-07-30 12:18] [ALPM] upgraded kservice (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kcodecs (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kguiaddons (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kconfigwidgets (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kitemviews (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kiconthemes (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded sonnet (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded ktextwidgets (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kxmlgui (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded kbookmarks (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded solid (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kjobwidgets (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded knotifications (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kwallet (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kio (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kpackage (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kdeclarative (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kcmutils (5.47.0-1 -> 5.48.0-1)
[2018-07-30 12:18] [ALPM] upgraded kitemmodels (5.47.0-1 -> 5.48.0-2)
[2018-07-30 12:18] [ALPM] upgraded lib32-harfbuzz (1.8.2-1 -> 1.8.4-1)
[2018-07-30 12:18] [ALPM] upgraded lib32-libgcrypt (1.8.2-1 -> 1.8.3-1)
[2018-07-30 12:18] [ALPM] upgraded lib32-libpulse (12.0-1 -> 12.2-1)
[2018-07-30 12:19] [ALPM] upgraded lib32-llvm-libs (6.0.0-1 -> 6.0.1-1)
[2018-07-30 12:19] [ALPM] upgraded lib32-mesa (18.1.3-1 -> 18.1.4-1)
[2018-07-30 12:19] [ALPM] upgraded lib32-vulkan-intel (18.1.3-1 -> 18.1.4-1)
[2018-07-30 12:19] [ALPM] upgraded libgdm (3.28.2-1 -> 3.28.2+19+g161f3462-1)
[2018-07-30 12:19] [ALPM] upgraded libmagick6 (6.9.10.4-1 -> 6.9.10.7-1)
[2018-07-30 12:19] [ALPM] upgraded libnm (1.10.10-1 -> 1.12.1dev+12+g7e8425de5-1)
[2018-07-30 12:19] [ALPM] upgraded libnm-glib (1.10.10-1 -> 1.12.1dev+12+g7e8425de5-1)
[2018-07-30 12:19] [ALPM] upgraded libva-mesa-driver (18.1.3-1 -> 18.1.4-1)
[2018-07-30 12:19] [ALPM] upgraded linux414 (4.14.53-1 -> 4.14.57-1)
[2018-07-30 12:19] [ALPM] upgraded linux414-r8168 (8.045.08-34 -> 8.045.08-38)
[2018-07-30 12:19] [ALPM] upgraded linux414-virtualbox-guest-modules (5.2.14-1 -> 5.2.16-2)
[2018-07-30 12:19] [ALPM] upgraded linux414-virtualbox-host-modules (5.2.14-1 -> 5.2.16-2)
[2018-07-30 12:19] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2018-07-30 12:19] [ALPM] upgraded linux44 (4.4.139-1 -> 4.4.143-1)
[2018-07-30 12:19] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2018-07-30 12:19] [ALPM] upgraded linux44-r8168 (8.045.08-21 -> 8.045.08-22)
[2018-07-30 12:19] [ALPM] upgraded linux44-virtualbox-guest-modules (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:19] [ALPM] upgraded linux44-virtualbox-host-modules (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:19] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2018-07-30 12:19] [ALPM] upgraded linux49 (4.9.111-1 -> 4.9.114-1)
[2018-07-30 12:19] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2018-07-30 12:19] [ALPM] upgraded linux49-r8168 (8.045.08-25 -> 8.045.08-27)
[2018-07-30 12:19] [ALPM] upgraded linux49-virtualbox-guest-modules (5.2.14-1 -> 5.2.16-2)
[2018-07-30 12:19] [ALPM] upgraded linux49-virtualbox-host-modules (5.2.14-1 -> 5.2.16-2)
[2018-07-30 12:19] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2018-07-30 12:19] [ALPM] upgraded man-db (2.8.3-1 -> 2.8.3-2)
[2018-07-30 12:19] [ALPM] upgraded manjaro-browser-settings (20180523-1 -> 20180707-1)
[2018-07-30 12:19] [ALPM] upgraded mhwd-nvidia (1:396.24-1 -> 1:396.45-1)
[2018-07-30 12:19] [ALPM] upgraded mhwd-nvidia-390xx (390.67-1 -> 390.77-1)
[2018-07-30 12:19] [ALPM] upgraded mkvtoolnix-cli (24.0.0-1 -> 25.0.0-1)
[2018-07-30 12:19] [ALPM] upgraded mkvtoolnix-gui (24.0.0-1 -> 25.0.0-1)
[2018-07-30 12:19] [ALPM] upgraded zeromq (4.2.2-2 -> 4.2.5-1)
[2018-07-30 12:19] [ALPM] upgraded networkmanager (1.10.10-1 -> 1.12.1dev+12+g7e8425de5-1)
[2018-07-30 12:19] [ALPM] upgraded networkmanager-vpnc (1.2.4-3 -> 1.2.6-1)
[2018-07-30 12:19] [ALPM] upgraded pacui (1.10.3-1 -> 1.11-1)
[2018-07-30 12:19] [ALPM] upgraded pamac (6.4.0-3 -> 6.4.0-6)
[2018-07-30 12:19] [ALPM] upgraded wine (3.11-1 -> 3.12-1)
[2018-07-30 12:19] [ALPM] upgraded playonlinux (4.2.12-1 -> 4.2.12-2)
[2018-07-30 12:19] [ALPM] upgraded polari (3.28.0+1+g76863ad-1 -> 3.28.1-1)
[2018-07-30 12:19] [ALPM] upgraded print-manager (18.04.2-1 -> 18.04.3-1)
[2018-07-30 12:19] [ALPM] upgraded pulseaudio-zeroconf (12.0-1.1 -> 12.2-1)
[2018-07-30 12:19] [ALPM] upgraded pyqt5-common (5.10.1-6 -> 5.11.2-1)
[2018-07-30 12:19] [ALPM] installed python-typed-ast (1.1.0-2)
[2018-07-30 12:19] [ALPM] upgraded python-astroid (1.6.5-1 -> 2.0-3)
[2018-07-30 12:19] [ALPM] upgraded python-parso (0.3.0-1 -> 0.3.1-1)
[2018-07-30 12:19] [ALPM] upgraded python-ptyprocess (0.5.2-1 -> 0.6.0-1)
[2018-07-30 12:19] [ALPM] upgraded python-pylint (1.9.2-1 -> 2.0-1)
[2018-07-30 12:19] [ALPM] installed python-sip-pyqt5 (4.19.12-4)
[2018-07-30 12:19] [ALPM] upgraded python-pyqt5 (5.10.1-6 -> 5.11.2-1)
[2018-07-30 12:19] [ALPM] upgraded python-sip (4.19.8-1 -> 4.19.12-4)
[2018-07-30 12:19] [ALPM] upgraded python-sphinx (1.7.5-1 -> 1.7.6-1)
[2018-07-30 12:19] [ALPM] upgraded python-yaml (3.12-3 -> 3.13-1)
[2018-07-30 12:19] [ALPM] upgraded re2 (20180401-1 -> 20180701-1)
[2018-07-30 12:19] [ALPM] upgraded ruby (2.5.1-1 -> 2.5.1-2)
[2018-07-30 12:19] [ALPM] upgraded sip (4.19.8-1 -> 4.19.12-4)
[2018-07-30 12:20] [ALPM] upgraded stellarium (0.18.0-1 -> 0.18.1-1)
[2018-07-30 12:20] [ALPM] upgraded virtualbox-host-dkms (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:20] [ALPM] upgraded virtualbox (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:20] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2018-07-30 12:20] [ALPM] upgraded virtualbox-ext-vnc (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:20] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2018-07-30 12:20] [ALPM] upgraded virtualbox-guest-iso (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:20] [ALPM] upgraded virtualbox-guest-utils (5.2.14-1 -> 5.2.16-1)
[2018-07-30 12:20] [ALPM] upgraded vulkan-icd-loader (1.1.73.0-1 -> 1.1.80+2940+da58202e9-1)
[2018-07-30 12:20] [ALPM] upgraded vulkan-intel (18.1.3-1 -> 18.1.4-1)
[2018-07-30 12:20] [ALPM] upgraded wireless-regdb (2018.05.31-1 -> 2018.05.31-2)
[2018-07-30 12:20] [ALPM] upgraded xf86-input-libinput (0.27.1-1 -> 0.28.0-1)
[2018-07-30 12:20] [ALPM] upgraded xorg-mkfontdir (1.0.7-8 -> 1.0.7-9)
[2018-07-30 12:20] [ALPM] upgraded zsh (5.5.1-1 -> 5.5.1-2)
[2018-07-30 12:20] [ALPM] transaction completed
[2018-07-30 12:20] [ALPM] running '60-linux414.hook'...
[2018-07-30 12:20] [ALPM] running '70-dkms-install.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Unable to install module vboxhost/5.2.16_OSE for kernel 4.9.114-1-MANJARO: Missing kernel headers.
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Unable to install module vboxhost/5.2.16_OSE for kernel 4.14.57-1-MANJARO: Missing kernel headers.
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Unable to install module vboxhost/5.2.16_OSE for kernel 4.4.143-1-MANJARO: Missing kernel headers.
[2018-07-30 12:20] [ALPM] running '90-linux414.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.14.57-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64-fallback.img -S autodetect
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.14.57-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM] running '90-linux44.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux44.preset: 'default'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.4-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.4.143-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.4-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux44.preset: 'fallback'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.4-x86_64-fallback.img -S autodetect
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.4.143-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.4-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM] running '90-linux49.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'default'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.9.114-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux49.preset: 'fallback'
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.9-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.9-x86_64-fallback.img -S autodetect
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Starting build: 4.9.114-1-MANJARO
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-07-30 12:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.9-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-07-30 12:20] [ALPM] running '99-grub.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] GRUB-Konfigurationsdatei wird erstellt …
[2018-07-30 12:20] [ALPM-SCRIPTLET] Hintergrund gefunden: /usr/share/grub/background.png
[2018-07-30 12:20] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.14-x86_64
[2018-07-30 12:20] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.9-x86_64
[2018-07-30 12:20] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.9-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.4-x86_64
[2018-07-30 12:20] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.4-x86_64-fallback.img
[2018-07-30 12:20] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2018-07-30 12:20] [ALPM-SCRIPTLET] erledigt
[2018-07-30 12:20] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-07-30 12:20] [ALPM] running 'gio-querymodules.hook'...
[2018-07-30 12:20] [ALPM] running 'glib-compile-schemas.hook'...
[2018-07-30 12:20] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-07-30 12:20] [ALPM] running 'gvfsd.hook'...
[2018-07-30 12:20] [ALPM] running 'pacman-mirrors-upgrade.hook'...
[2018-07-30 12:20] [ALPM-SCRIPTLET] .: INFO Downloading mirrors from repo.manjaro.org
[2018-07-30 12:20] [ALPM-SCRIPTLET] hint: use `pacman-mirrors` to generate and update your pacman mirrorlist.
[2018-07-30 12:20] [ALPM] running 'systemd-binfmt.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-hwdb.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-sysusers.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-udev-reload.hook'...
[2018-07-30 12:20] [ALPM] running 'systemd-update.hook'...
[2018-07-30 12:20] [ALPM] running 'texinfo-install.hook'...
[2018-07-30 12:20] [ALPM] running 'update-desktop-database.hook'...
[2018-07-30 12:20] [ALPM] running 'update-mime-database.hook'...
[2018-07-30 13:56] [PACMAN] Running 'pacman -Sy'
[2018-07-30 13:56] [PACMAN] synchronizing package lists
« Letzte Änderung: 31. Juli 2018, 11:21:50 von Jurgen_K »

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #18 am: 31. Juli 2018, 12:56:18 »
was hast du denn für eine grafikkarte?

kannst du mal schaun ob startx /usr/bin/xterm funktioniert oder auch nicht startet

(wenn du xterm installiert hast sonst nimm einen anderen)

Offline Jurgen_K

  • Neuling
  • *
  • Beiträge: 19
  • Dankeschön: 1 mal
  • Desktop: Gnome
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: free?
  • Kernel: 4.9.68-1-Manjaro x64
  • Prozessor: Intel Core i5-4200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #19 am: 31. Juli 2018, 19:32:10 »
was hast du denn für eine grafikkarte?
Hardware Hersteller Angaben:
Prozessor: Intel Core i5-4200U Processor(dual core 1.6 GHz, up to 2.6 Ghz)
Grafikkarte: Intel HD Graphics 4400

bzw hier die Ausgabe für lspci -nnk | grep -A3 "\[03..\]:"
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
DeviceName:  Onboard IGD
Subsystem: ZOTAC International (MCO) Ltd. Haswell-ULT Integrated Graphics Controller [19da:b229]
Kernel driver in use: i915

kannst du mal schaun ob startx /usr/bin/xterm funktioniert oder auch nicht startet

(wenn du xterm installiert hast sonst nimm einen anderen)
startx /usr/bin/xtermxterm ist installiert, der Befehl funktioniert dennoch nicht und freezed (in diesem Fall die tty1 Console) mit folgender Meldung:
X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.17.0-1-MANJARO x86_64
Current Operating System: Linux xxx-pc 4.14.57-1-MANJARO #1 SMP PREEMPT Sun Jul 22 19:25:51 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.14-x86_64 root=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx rw quiet resume=UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
Build Date: 20 May 2018  06:17:37PM
 
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/xxx/.local/share/xorg/Xorg.1.log", Time: Tue Jul 31 19:19:49 2018
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
> Internal error:   Could not resolve keysym XF86WWAN
> Internal error:   Could not resolve keysym XF86RFKill
> Internal error:   Could not resolve keysym XF86Keyboard
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Unsupported high keycode 372 for name <I372> ignored
>                   X11 cannot support keycodes above 255.
>                   This warning only shows for the first high keycode.
> Internal error:   Could not resolve keysym XF86WWAN
> Internal error:   Could not resolve keysym XF86RFKill
> Internal error:   Could not resolve keysym XF86Keyboard
Errors from xkbcomp are not fatal to the X server
(II) AIGLX: Suspending AIGLX clients for VT switch
xinit: connection to X server lost

waiting for X server to shut down /usr/bin/xterm: fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) or KillClient on X server ":1"

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #20 am: 01. August 2018, 19:35:02 »
kann es sein das gdm das wayland zeugs nutzt ?

kannst du mal die geladenen und ggf. "geblacklisteten" module zeigen?
(also das zeug aus /etc/modules-load.d und /etc/modprobe.d)

und evtl. die kernel cmdline?

und das zeug in /etc/X11?
(python -c '
import os
for dirpath, dirnames, filenames in os.walk("/etc/X11"):
     for filename in filenames:
         path = dirpath+"/"+filename
         if os.path.islink(path):
             real_file = os.path.realpath(path)
             print("%s = symlink, realpath = %s" %(path,real_file))
             with open(real_file) as f:
                 print("-------> %s:\n\n%s" %(real_file,f.read()))
         elif os.path.isfile(path):
             with open(path) as f:
                 print("-------> %s:\n\n%s" %(path,f.read()))
'
)


weil eigentlich sollte bei einer intel karte der x server eigentlich relativ problemlos starten
« Letzte Änderung: 01. August 2018, 19:36:56 von vetzki »

Offline Jurgen_K

  • Neuling
  • *
  • Beiträge: 19
  • Dankeschön: 1 mal
  • Desktop: Gnome
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: free?
  • Kernel: 4.9.68-1-Manjaro x64
  • Prozessor: Intel Core i5-4200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #21 am: 03. August 2018, 00:15:45 »
kann es sein das gdm das wayland zeugs nutzt ?
Kann schon sein, ich bin da völlig überfragt. Wikipedia sagt: Wayland wird als Ersatz für den X.Org-Server betrachtet, besitzt aber andere potentielle Anwendungsmöglichkeiten, beispielsweise das Bereitstellen von X-Servern und GDM-Anmeldungen.
[...] Gnome:
Im März 2013 kündigten GNOME-Entwickler Pläne für eine vollständige Portierung innerhalb eines Jahres an.[24] Gnome 3.10, welches im September 2013 erschien, enthielt bereits eine experimentelle Wayland-Unterstützung.
Ab Version 3.20 gilt die Wayland-Unterstützung als alltagstauglich.
Und im Arch Wiki heißt es:
Wayland sessions
Note:
An X server—provided by the xorg-server-xwayland package—is still necessary to run applications that have not yet been ported to Wayland.


kannst du mal die geladenen und ggf. "geblacklisteten" module zeigen?
(also das zeug aus /etc/modules-load.d und /etc/modprobe.d)
/etc/modules-load.d:
    linux414-virtualbox-guest-modules.conf
    linux414-virtualbox-host-modules.conf
    linux44-virtualbox-guest-modules.conf
    linux44-virtualbox-host-modules.conf
    linux49-virtualbox-guest-modules.conf
    linux49-virtualbox-host-modules.conf
/etc/modprobe.d:
    r8169_blacklist

und das zeug in /etc/X11?
hier liegen folgende Dateien:
  • ./mhwd.d
  • ./xinit/xinitrc
  • ./xinit/xinitrc.d/40-libcanberra-gtk.module.sh
  • ./xinit/xinitrc.d/50-systemd-user.sh
  • ./xinit/xserverrc
  • ./xorg.conf.d/00-keyboard.conf

Bevor ich hier alles "zu spamme": ist etwas davon von Interesse?



und evtl. die kernel cmdline?
Was ist hiermit gemeint, bzw. wie mache ich das?


(python -c '
import os
for dirpath, dirnames, filenames in os.walk("/etc/X11"):
     for filename in filenames:
         path = dirpath+"/"+filename
         if os.path.islink(path):
             real_file = os.path.realpath(path)
             print("%s = symlink, realpath = %s" %(path,real_file))
             with open(real_file) as f:
                 print("-------> %s:\n\n%s" %(real_file,f.read()))
         elif os.path.isfile(path):
             with open(path) as f:
                 print("-------> %s:\n\n%s" %(path,f.read()))
'
)
weil eigentlich sollte bei einer intel karte der x server eigentlich relativ problemlos starten

Leider habe ich (noch) keine Python Erfahrung. Wie führe ich dieses Skript aus? Hier brauche ich leider ein bisschen Führung.

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #22 am: 03. August 2018, 09:50:32 »
die kernel cmdline findest du entweder in /etc/default/grub (GRUB_CMDLINE_LINUX_DEFAULT) oder in /proc/cmdline

die von dir gelisteten dateien in /etc/X11 sind alle oder? (also nichts in mhwd.d)

das python skript hättest du einfach nur so eingeben/kopieren müssen (python -c startet die nachfolgenden befehle innerhalb der ' '), aber wenn das alle dateien in /etc/X11 sind muss das eigentlich nicht sein.

kannst du mal schaun ob das paket xf86-video-intel installiert?

Du könntest mal das versuchen (allerdings wird glaub ich nichts nützen da ja der x server mit startx auch nicht startet)

Zitat
Successful run of GDM after disabling Wayland in /etc/gdm/custom.conf

This is for the 32-bit machine.

This issue is almost certainly a wayland regression with either GDM or gnome-shell. If I disable wayland in /etc/gdm/custom.conf then GDM starts correctly by falling back to X11. Only I can only run X11-based sessions, so I cannot check whether a gnome-shell session as an user desktop works correctly.

achja, was zeigt den eigentlich systemctl status gdm.service für fehler an?

und kannst du mal die komplette xorg log datei einstellen nachdem startx fehlschlägt (und schau vorher ob der zeitstempel der datei passt um sicherzustellen das es die richtige datei ist)
Folgende Mitglieder bedankten sich: Jurgen_K

Offline Jurgen_K

  • Neuling
  • *
  • Beiträge: 19
  • Dankeschön: 1 mal
  • Desktop: Gnome
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: free?
  • Kernel: 4.9.68-1-Manjaro x64
  • Prozessor: Intel Core i5-4200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #23 am: 04. August 2018, 16:22:34 »
@vetzki,

Kurze Zwischenfrage: Wie sehr tappen wir hier eigentlich im Dunkeln? Ich überlege ein Backup zu ziehen und das System neu aufzusetzten.
Hier ein erste Antwort, die restlichen Dinge liefere ich nach!


die von dir gelisteten dateien in /etc/X11 sind alle oder? (also nichts in mhwd.d)
Nichts in mhwd.d.


was zeigt denn eigentlich systemctl status gdm.service für fehler an?
Unit gdm.service could not be found.

kannst du mal schaun ob das paket xf86-video-intel installiert?
local/xf86-video-intel 1:2.99.917+829+gd7dfab62-1 (xorg-drivers)
   X.org Intel i810/i830/i915/945G/G965+ video drivers


Danke für die Unterstützung soweit!

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1470
  • Dankeschön: 282 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #24 am: 04. August 2018, 16:38:18 »
Hallo Jürgen,
ich hänge mich hier nochmal kurz rein.
Unit gdm.service could not be found.
Das bestärkt mich in der Annahme, daß überhaupt kein gdm installiert ist (warum auch immer). Wie von vetzki schon vorgeschlagen würde ich mal versuchen, gdm zu installieren und zu starten, vielleicht reicht das schon.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Jurgen_K

Offline Jurgen_K

  • Neuling
  • *
  • Beiträge: 19
  • Dankeschön: 1 mal
  • Desktop: Gnome
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: free?
  • Kernel: 4.9.68-1-Manjaro x64
  • Prozessor: Intel Core i5-4200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: "file /root/.Xauthority does not exist"
« Antwort #25 am: 05. August 2018, 13:06:55 »
@gosia
@vetzki

! PROBLEM SOLVED !

Hallo Jürgen,
ich hänge mich hier nochmal kurz rein.Das bestärkt mich in der Annahme, daß überhaupt kein gdm installiert ist (warum auch immer). Wie von vetzki schon vorgeschlagen würde ich mal versuchen, gdm zu installieren und zu starten, vielleicht reicht das schon.

Viele Grüße gosia

Die Lösung des Problems lag tatsächlich darin, dass gdm erneut installiert werden musste, warum auch immer... Jetzt scheint alles wieder in gewohnten Bahnen zu laufen. Musste zwar noch ein paar Gnome Pakete nachinstallieren, aber das eingangs geschilderte Problem ist hiermit gelößt.

Ich danke euch ganz herzlich für Eure Unterstützung!



Thema kann geschlossen werden.



Folgende Mitglieder bedankten sich: vetzki