Autor Thema: Kein Bluetooth-Adapter gefunden obwohl vorhanden  (Gelesen 2581 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Kein Bluetooth-Adapter gefunden obwohl vorhanden
« am: 10. August 2018, 12:35:01 »
Hallo zusammen,
seit dieser Woche habe ich von Mint KDE auf Manjaro KDE gewechselt. Jetzt wird mein definitiv vorhandenes Bluetooth im Sony Vaio nicht mehr gefunden. Ich habe noch Win10 installiert, auch dort funktioniert Bluetooth einwandfrei.
Wäre dankbar für hilfreiche Tipps wie ich Bluetooth zum laufen bringe ...  :)

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #1 am: 10. August 2018, 13:00:53 »
Hast du folgende Pakete installiert bzw. sind die vorhanden:
bluez
bluez-utils ?

ist bluetooth.service gestartet bzw. enabled?
(systemctl enable --now bluetooth.service)

was zeigt ?
lsmod | grep bt


Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #2 am: 10. August 2018, 13:22:55 »
Hallo und danke für die schnelle reaktion ...
also,
bluetooth.service ist enabled

für die anderen beiden Fragen bräuchte ich eine Anleitung  :o

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #3 am: 10. August 2018, 13:53:22 »
vaio ~]$ lsmod | grep bluetooth
bluetooth                 630784  12 btrtl,btintel,btbcm,bnep,ath3k,btusb
ecdh_generic           24576  1 bluetooth
rfkill                        28672  9 bluetooth,cfg80211,sony_laptop
crc16                      16384  2 bluetooth,ext4

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #4 am: 10. August 2018, 15:26:45 »
ok,
was zeigt denn systemctl status bluetooth.service an?
und evtl. journalctl --no-pager -b -r | grep -i blue
Folgende Mitglieder bedankten sich: PitFid

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #5 am: 10. August 2018, 16:57:37 »
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Fri 2018-08-10 15:00:30 CEST; 1h 49min ago
           └─ ConditionPathIsDirectory=/sys/class/bluetooth was not met
     Docs: man:bluetoothd( 8)

und

[xxxxx@xxxx-pc ~]$ journalctl --no-pager -b -r | grep -i blue
Aug 10 15:00:55 xxxxx-pc kdeinit5[706]: org.kde.bluez: PendingCall Error: "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
Aug 10 15:00:55 xxxxx-pc pulseaudio[811]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Aug 10 15:00:55 -pc dbus-daemon[350]: [system] Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexAgent registered
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexManager operational changed true
Aug 10 15:00:32 -pc systemd[659]: Started Bluetooth OBEX service.
Aug 10 15:00:32 -pc dbus-daemon[674]: [session uid=1000 pid=674] Successfully activated service 'org.bluez.obex'
Aug 10 15:00:32 -pc systemd[659]: Starting Bluetooth OBEX service...
Aug 10 15:00:32 -pc dbus-daemon[674]: [session uid=1000 pid=674] Activating via systemd: service name='org.bluez.obex' unit='dbus-org.bluez.obex.service' requested by ':1.5' (uid=1000 pid=706 comm="kded5 [kdeinit5]                                  ")
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexManager operational changed false
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: Bluetooth operational changed false
Aug 10 15:00:31 -pc kdeinit5[706]: bluedevil: Created
Aug 10 15:00:30 -pc dbus-daemon[350]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service' requested by ':1.50' (uid=1000 pid=811 comm="/usr/bin/pulseaudio --daemonize=no ")
Aug 10 15:00:29 -pc kdeinit5[706]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib/qt/plugins/kf5/kded/bluedevil.so"
Aug 10 15:00:24 -pc NetworkManager[354]: <info>  [1533906024.4992] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.12.2-1/libnm-device-plugin-bluetooth.so)
[xxxxx@xxxxx-pc ~]$

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 437
  • Dankeschön: 67 mal
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #6 am: 10. August 2018, 17:04:39 »
das könnte der fehler sein
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=806302

kannst du mal schaun ob rfkill list unter bluetooth was geblocktes anzeigt?

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #7 am: 10. August 2018, 22:30:21 »
Hallo vetzki,
hier die Ausgabe:

[xxx-vaio ~]$ rfkill list
0: sony-wifi: Wireless LAN
                  Soft blocked:  no
                  Hard blocked: no
1: sony-bluetooth: Bluetooth
                 Soft blocked:  no
                 Hard blocked: no
2: phy0: Wireless LAN
                Soft blocked:  no
                Hard blocked: no

Mit dem Bugreport kann ich leider nichts anfangen. Meine Englisch- und Linuxkenntisse sind sind nicht so besonders  :-\

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #8 am: 10. August 2018, 22:50:11 »
Ich habe jetzt auch gesehen dass beim booten schon auf einen Fehler mit Bluetooth hingewiesen wird...
"Can't change to load configuration err" oder so ähnlich.
« Letzte Änderung: 10. August 2018, 22:55:49 von PitFid »

Offline Die Kleene

  • Neuling
  • *
  • Beiträge: 29
  • Dankeschön: 1 mal
  • Desktop: Xfce
  • Grafikkarte: MSI Radeon R9 R380 4 Gb
  • Grafikkartentreiber: Free
  • Kernel: 4.14
  • Prozessor: AMD Rhyzen 2700
  • Skill: Durchschnitt
  • Zweig: Stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #9 am: 16. August 2018, 18:52:31 »
Schon einmal neueren Kernel ausprobiert?
Folgende Mitglieder bedankten sich: PitFid

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #10 am: 20. August 2018, 12:17:53 »
Schon einmal neueren Kernel ausprobiert?
Danke für die Antwort,
ich habe jetzt außer den empfohlenen Kernel 4.14.65-1 auch den 4.16.18-1 und den 4.18.3-1 (jetzt aktuell) ausprobiert. Bei keinem wird der Bluetooth Adapter gestartet ...  :-\

Offline jeckus

  • Neuling
  • *
  • Beiträge: 18
  • Dankeschön: 3 mal
  • Skill: Anfänger
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #11 am: 21. August 2018, 10:49:41 »
hi,

vorab, habe kein Bluetooth am Rechner, kann deshalb das Prozedere nicht am Rechner nachvollziehen.

Hast du die Installation gemäß dem Arch-Wiki durchgeführt?

Bei deiner Ausgabe von " journalctl --no-pager -b -r | grep -i blue" tauchen einige Fehlermeldungen auf:

- "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
- Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexManager operational changed false
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: Bluetooth operational changed false
- Aug 10 15:00:30 -pc dbus-daemon[350]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service' requested by ':1.50' (uid=1000 pid=811 comm="/usr/bin/pulseaudio --daemonize=no ")
Aug 10 15:00:29 -pc kdeinit5[706]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib/qt/plugins/kf5/kded/bluedevil.so"

Leider sagen mir diese Fehlermeldungen auch nicht so viel. Aber ich denke einer vielen Forumsmitglieder kann mit diesen hinweisen etwas anfangen und führt dich auf die richtige Spur.

Linux - the windows to the world
Folgende Mitglieder bedankten sich: PitFid

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1372
  • Dankeschön: 259 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.18 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #12 am: 21. August 2018, 14:13:03 »
Hallo PitFid,
bluetooth.service ist enabled
enabled schon, läuft aber nicht :(
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Fri 2018-08-10 15:00:30 CEST; 1h 49min ago
           └─ ConditionPathIsDirectory=/sys/class/bluetooth was not met
ConditionPathIsDirectory=/sys/class/bluetoothdas sieht so aus, als ob /sys/class/bluetooth nicht existiert und deshalb bluetooth.service nicht startet. Das ist meist der Fall, wenn Bluetooth vom Kernel nicht initialisiert wird, warum auch immer. Da wäre die genaue Ausgabe von
"Can't change to load configuration err" oder so ähnlich.
interessant. "oder so ähnlich" ist da leider etwas ungenau ;)
In dem Zusammenhang kannst Du auch mal den Inhalt von /etc/bluetooth/main.conf posten.
Du kannst ja versuchen, nach dieser Anleitung bluetooth mit bluetoothctl von Hand zu konfigurieren
https://kofler.info/bluetooth-konfiguration-im-terminal-mit-bluetoothctl/
oder zumindest schreiben, wie weit Du damit kommst.

Viele Grüße gosia

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #13 am: 27. August 2018, 19:36:15 »
In dem Zusammenhang kannst Du auch mal den Inhalt von /etc/bluetooth/main.conf posten.
# Default adapter name
# Defaults to 'BlueZ X.YZ'
#Name = BlueZ

# Default device class. Only the major and minor device class bits are
# considered. Defaults to '0x000000'.
#Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
#DiscoverableTimeout = 0

# How long to stay in pairable mode before going back to non-discoverable
# The value is in seconds. Default is 0.
# 0 = disable timer, i.e. stay pairable forever
#PairableTimeout = 0

# Use vendor id source (assigner), vendor, product and version information for
# DID profile support. The values are separated by ":" and assigner, VID, PID
# and version.
# Possible vendor id source values: bluetooth, usb (defaults to usb)
#DeviceID = bluetooth:1234:5678:abcd

# Do reverse service discovery for previously unknown devices that connect to
# us. This option is really only needed for qualification since the BITE tester
# doesn't like us doing reverse SDP for some test cases (though there could in
# theory be other useful purposes for this too). Defaults to 'true'.
#ReverseServiceDiscovery = true

# Enable name resolving after inquiry. Set it to 'false' if you don't need
# remote devices name and want shorter discovery cycle. Defaults to 'true'.
#NameResolving = true

# Enable runtime persistency of debug link keys. Default is false which
# makes debug link keys valid only for the duration of the connection
# that they were created for.
#DebugKeys = false

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
#ControllerMode = dual

# Enables Multi Profile Specification support. This allows to specify if
# system supports only Multiple Profiles Single Device (MPSD) configuration
# or both Multiple Profiles Single Device (MPSD) and Multiple Profiles Multiple
# Devices (MPMD) configurations.
# Possible values: "off", "single", "multiple"
#MultiProfile = off

# Permanently enables the Fast Connectable setting for adapters that
# support it. When enabled other devices can connect faster to us,
# however the tradeoff is increased power consumptions. This feature
# will fully work only on kernel version 4.1 and newer. Defaults to
# 'false'.
#FastConnectable = false

# Default privacy setting.
# Enables use of private address.
# Possible values: "off", "device", "network"
# "network" option not supported currently
# Defaults to "off"
# Privacy = off

[GATT]
# GATT attribute cache.
# Possible values:
# always: Always cache attributes even for devices not paired, this is
# recommended as it is best for interoperability, with more consistent
# reconnection times and enables proper tracking of notifications for all
# devices.
# yes: Only cache attributes of paired devices.
# no: Never cache attributes
# Default: always
#Cache = always

# Minimum required Encryption Key Size for accessing secured characteristics.
# Possible values: 0 and 7-16. 0 means don't care.
# Defaults to 0
# MinEncKeySize = 0

[Policy]
#
# The ReconnectUUIDs defines the set of remote services that should try
# to be reconnected to in case of a link loss (link supervision
# timeout). The policy plugin should contain a sane set of values by
# default, but this list can be overridden here. By setting the list to
# empty the reconnection feature gets disabled.
#ReconnectUUIDs=00001112-0000-1000-8000-00805f9b34fb,0000111f-0000-1000-8000-00805f9b34fb,0000110a-0000-1000-8000-00805f9b34fb

# ReconnectAttempts define the number of attempts to reconnect after a link
# lost. Setting the value to 0 disables reconnecting feature.
#ReconnectAttempts=7

# ReconnectIntervals define the set of intervals in seconds to use in between
# attempts.
# If the number of attempts defined in ReconnectAttempts is bigger than the
# set of intervals the last interval is repeated until the last attempt.
#ReconnectIntervals=1,2,4,8,16,32,64

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'false'.
#AutoEnable=false

Offline PitFid

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #14 am: 27. August 2018, 19:56:39 »
Du kannst ja versuchen, nach dieser Anleitung bluetooth mit bluetoothctl von Hand zu konfigurieren
https://kofler.info/bluetooth-konfiguration-im-terminal-mit-bluetoothctl/
oder zumindest schreiben, wie weit Du damit kommst.
Mit bluethoothctl kommt immer wieder die Ausgabe "No default controller available" :(