Autor Thema: Kein Bluetooth-Adapter gefunden obwohl vorhanden  (Gelesen 75 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Kein Bluetooth-Adapter gefunden obwohl vorhanden
« am: 10. August 2018, 12:35:01 »
Hallo zusammen,
seit dieser Woche habe ich von Mint KDE auf Manjaro KDE gewechselt. Jetzt wird mein definitiv vorhandenes Bluetooth im Sony Vaio nicht mehr gefunden. Ich habe noch Win10 installiert, auch dort funktioniert Bluetooth einwandfrei.
Wäre dankbar für hilfreiche Tipps wie ich Bluetooth zum laufen bringe ...  :)

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 436
  • Dankeschön: 65 mal
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Prozessor: i5-2450
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #1 am: 10. August 2018, 13:00:53 »
Hast du folgende Pakete installiert bzw. sind die vorhanden:
bluez
bluez-utils ?

ist bluetooth.service gestartet bzw. enabled?
(systemctl enable --now bluetooth.service)

was zeigt ?
lsmod | grep bt


Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #2 am: 10. August 2018, 13:22:55 »
Hallo und danke für die schnelle reaktion ...
also,
bluetooth.service ist enabled

für die anderen beiden Fragen bräuchte ich eine Anleitung  :o

Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #3 am: 10. August 2018, 13:53:22 »
vaio ~]$ lsmod | grep bluetooth
bluetooth                 630784  12 btrtl,btintel,btbcm,bnep,ath3k,btusb
ecdh_generic           24576  1 bluetooth
rfkill                        28672  9 bluetooth,cfg80211,sony_laptop
crc16                      16384  2 bluetooth,ext4

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 436
  • Dankeschön: 65 mal
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Prozessor: i5-2450
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #4 am: 10. August 2018, 15:26:45 »
ok,
was zeigt denn systemctl status bluetooth.service an?
und evtl. journalctl --no-pager -b -r | grep -i blue
Folgende Mitglieder bedankten sich: PitFid

Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #5 am: 10. August 2018, 16:57:37 »
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Fri 2018-08-10 15:00:30 CEST; 1h 49min ago
           └─ ConditionPathIsDirectory=/sys/class/bluetooth was not met
     Docs: man:bluetoothd( 8)

und

[xxxxx@xxxx-pc ~]$ journalctl --no-pager -b -r | grep -i blue
Aug 10 15:00:55 xxxxx-pc kdeinit5[706]: org.kde.bluez: PendingCall Error: "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
Aug 10 15:00:55 xxxxx-pc pulseaudio[811]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Aug 10 15:00:55 -pc dbus-daemon[350]: [system] Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexAgent registered
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexManager operational changed true
Aug 10 15:00:32 -pc systemd[659]: Started Bluetooth OBEX service.
Aug 10 15:00:32 -pc dbus-daemon[674]: [session uid=1000 pid=674] Successfully activated service 'org.bluez.obex'
Aug 10 15:00:32 -pc systemd[659]: Starting Bluetooth OBEX service...
Aug 10 15:00:32 -pc dbus-daemon[674]: [session uid=1000 pid=674] Activating via systemd: service name='org.bluez.obex' unit='dbus-org.bluez.obex.service' requested by ':1.5' (uid=1000 pid=706 comm="kded5 [kdeinit5]                                  ")
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: ObexManager operational changed false
Aug 10 15:00:32 -pc kdeinit5[706]: bluedevil: Bluetooth operational changed false
Aug 10 15:00:31 -pc kdeinit5[706]: bluedevil: Created
Aug 10 15:00:30 -pc dbus-daemon[350]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service' requested by ':1.50' (uid=1000 pid=811 comm="/usr/bin/pulseaudio --daemonize=no ")
Aug 10 15:00:29 -pc kdeinit5[706]: kf5.kded: No X-KDE-DBus-ServiceName found in "/usr/lib/qt/plugins/kf5/kded/bluedevil.so"
Aug 10 15:00:24 -pc NetworkManager[354]: <info>  [1533906024.4992] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.12.2-1/libnm-device-plugin-bluetooth.so)
[xxxxx@xxxxx-pc ~]$

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 436
  • Dankeschön: 65 mal
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Prozessor: i5-2450
  • Skill: Durchschnitt
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #6 am: 10. August 2018, 17:04:39 »
das könnte der fehler sein
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=806302

kannst du mal schaun ob rfkill list unter bluetooth was geblocktes anzeigt?

Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #7 am: 10. August 2018, 22:30:21 »
Hallo vetzki,
hier die Ausgabe:

[xxx-vaio ~]$ rfkill list
0: sony-wifi: Wireless LAN
                  Soft blocked:  no
                  Hard blocked: no
1: sony-bluetooth: Bluetooth
                 Soft blocked:  no
                 Hard blocked: no
2: phy0: Wireless LAN
                Soft blocked:  no
                Hard blocked: no

Mit dem Bugreport kann ich leider nichts anfangen. Meine Englisch- und Linuxkenntisse sind sind nicht so besonders  :-\

Offline PitFid

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: KDE-Plasma 5.13.4
  • Grafikkarte: GeForce GT540M
  • Grafikkartentreiber: nonfree
  • Kernel: 4.14.60-Manjaro
  • Prozessor: Intel Core i7
  • Skill: Anfänger
  • Zweig: stable
Re: Kein Bluetooth-Adapter gefunden obwohl vorhanden
« Antwort #8 am: 10. August 2018, 22:50:11 »
Ich habe jetzt auch gesehen dass beim booten schon auf einen Fehler mit Bluetooth hingewiesen wird...
"Can't change to load configuration err" oder so ähnlich.
« Letzte Änderung: 10. August 2018, 22:55:49 von PitFid »