Autor Thema: xf86-video-intel  (Gelesen 1747 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline aga_peter

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE 17.1.12
  • Grafikkarte: Intel i915 integrated
  • Grafikkartentreiber: free
  • Kernel: 4.14.71-1-MANJARO (linux414)
  • Prozessor: i5 M520
  • Skill: Anfänger
  • Zweig: stable
xf86-video-intel
« am: 22. September 2018, 11:14:42 »
Hallo zusammen,

ich versuche auf meinem Computer den Intel Grafiktreiber zu installieren/aktivieren - es klapp aber leider nicht.
Im Moment ist das Scrollen, zB im Internetbrowser nicht ganz flüssig ist.

Das System verwendet aktuell den video-linux treiber.
Das Paket xf86-video-intel ist installiert, ich schaffe es aber nicht den Intel Treiber zu aktivieren.

Bin Linux Anfänger und daher mit der Materie überfordert.
Bin für jede Hilfe sehr dankbar.

Gruss
Peter

Mein System:
Computer: AEC-6635
Prozessor: i5 M520
Grafikprozessor: integriert i915

Einige Abfragen:

inxi -Fx
System:    Host: peter-pc Kernel: 4.14.71-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: N/A
           Distro: Manjaro Linux
Machine:   Type: Desktop Mobo: N/A model: N/A serial: <root required> UEFI: American Megatrends v: 4.6.3
           date: 04/16/2012
CPU:       Topology: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP arch: Nehalem rev: 5
           L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19157
           Speed: 1463 MHz min/max: 1197/2395 MHz Core speeds (MHz): 1: 1463 2: 1463 3: 1462 4: 1463
Graphics:  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: N/A driver: intel unloaded: modesetting resolution: <xdpyinfo missing>
           OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 18.2.1 direct render: Yes
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0
           Sound Server: ALSA v: k4.14.71-1-MANJARO
Network:   Device-1: Intel 82577LM Gigabit Network driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 00:07:32:1e:9a:3b
           Device-2: Intel 82574L Gigabit Network driver: e1000e v: 3.2.6-k port: e000 bus ID: 02:00
           IF: enp2s0 state: down mac: 00:07:32:1e:9a:3c
Drives:    Local Storage: total: 178.02 GiB used: 28.03 GiB (15.7%)
           ID-1: /dev/sda vendor: Intel model: SSDSA2M160G2HP size: 149.05 GiB
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Ultra Fit size: 28.97 GiB
Partition: ID-1: / size: 42.04 GiB used: 5.94 GiB (14.1%) fs: ext4 dev: /dev/sda4
           ID-2: /home size: 95.69 GiB used: 4.60 GiB (4.8%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 8.06 GiB used: 6.2 MiB (0.1%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 168 Uptime: 28m Memory: 3.66 GiB used: 1.14 GiB (31.1%) Init: systemd Compilers:
           gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.21


mhwd -l -d --pci
--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:02.0 (0300:8086:0046)
  Display controller Intel Corporation Core Processor Integrated Graphics Controller
--------------------------------------------------------------------------------
  > INSTALLED:

   NAME: video-linux
   ATTACHED: PCI
   VERSION: 2018.05.04
   INFO: Standard open source drivers.
   PRIORITY: 2
   FREEDRIVER: true
   DEPENDS: -
   CONFLICTS: -
   CLASSIDS: 0300 0380 0302
   VENDORIDS: 1002 8086 10de



  > AVAILABLE:

   NAME: video-linux
   ATTACHED: PCI
   VERSION: 2018.05.04
   INFO: Standard open source drivers.
   PRIORITY: 2
   FREEDRIVER: true
   DEPENDS: -
   CONFLICTS: -
   CLASSIDS: 0300 0380 0302
   VENDORIDS: 1002 8086 10de

   NAME: video-vesa
   ATTACHED: PCI
   VERSION: 2017.03.12
   INFO: X.org vesa video driver.
   PRIORITY: 0
   FREEDRIVER: true
   DEPENDS: -
   CONFLICTS: -
   CLASSIDS: 0300
   VENDORIDS: *

Einige Versuche den Treiber manuell zu installieren scheitern:

sudo mhwd -i pci video-intel
Error: config 'video-intel' does not exist!


sudo mhwd-gpu --check
sudo mhwd-gpu --status
:: status
warning: could not find '/etc/X11/xorg.conf.d/90-mhwd.conf'!


glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
OpenGL version string: 2.1 Mesa 18.2.1
OpenGL shading language version string: 1.20
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 18.2.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:



« Letzte Änderung: 22. September 2018, 12:38:02 von Linu74 »

Offline aga_peter

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE 17.1.12
  • Grafikkarte: Intel i915 integrated
  • Grafikkartentreiber: free
  • Kernel: 4.14.71-1-MANJARO (linux414)
  • Prozessor: i5 M520
  • Skill: Anfänger
  • Zweig: stable
Re: xf86-video-intel
« Antwort #1 am: 22. September 2018, 14:20:55 »
Nachtrag:

ich denke nicht, dass es damit etwas zu tun hat, ich möchte es aber trotzdem erwähnen, dass in meinem Computer zwei display Adapter aktiv sind, und zwar LVDS1 und DP2.
Bei mir läuft im Moment alles via DisplayPort (DP2), ursprünglich war aber der interne Adapter aktiv. Letztendlich ist der Grafikchip gleich für alle Displayadapter.

Details zum Computer:
https://www.aaeon.com/en/p/fanless-embedded-computers-aec-6635

xrandr -q
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
LVDS1 connected (normal left inverted right x axis y axis)
   1024x768      60.00 +
   1024x576      59.90    59.82 
   960x540       59.63    59.82 
   800x600       60.32    56.25 
   864x486       59.92    59.57 
   640x480       59.94 
   720x405       59.51    58.99 
   640x360       59.84    59.32 
   512x384       60.00 
DP1 disconnected (normal left inverted right x axis y axis)
DP2 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00*+
   1680x1050     59.95 
   1600x900      60.00 
   1280x1024     60.02 
   1440x900      59.89 
   1280x800      59.81 
   1280x720      60.00 
   1024x768      60.00 
   800x600       60.32 
   640x480       59.94 
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)




Offline aga_peter

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE 17.1.12
  • Grafikkarte: Intel i915 integrated
  • Grafikkartentreiber: free
  • Kernel: 4.14.71-1-MANJARO (linux414)
  • Prozessor: i5 M520
  • Skill: Anfänger
  • Zweig: stable
Re: xf86-video-intel
« Antwort #2 am: 22. September 2018, 14:43:56 »
hier noch ein Screenshot von der Hardwarekonfiguration

Offline aga_peter

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE 17.1.12
  • Grafikkarte: Intel i915 integrated
  • Grafikkartentreiber: free
  • Kernel: 4.14.71-1-MANJARO (linux414)
  • Prozessor: i5 M520
  • Skill: Anfänger
  • Zweig: stable
Re: xf86-video-intel
« Antwort #3 am: 28. September 2018, 21:24:48 »
ok, hat sich erledigt, bin letztendlich bei Debian gelandet, kämpfe auch dort mit Problemen, es sind aber weniger und kleinere.
gruss

Offline Keruskerfuerst

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 220
  • Dankeschön: 6 mal
  • Desktop: KDE
  • Grafikkarte: Nvidia GTX 970
  • Kernel: stable LTS
  • Prozessor: Intel Core I 7 5820 K
  • Skill: Anfänger
  • Zweig: stable
Re: xf86-video-intel
« Antwort #4 am: 29. September 2018, 13:03:59 »
Ich hatte Debian schon mal auf dem Rechner.
Nicht lange.

Offline aga_peter

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE 17.1.12
  • Grafikkarte: Intel i915 integrated
  • Grafikkartentreiber: free
  • Kernel: 4.14.71-1-MANJARO (linux414)
  • Prozessor: i5 M520
  • Skill: Anfänger
  • Zweig: stable
Re: xf86-video-intel
« Antwort #5 am: 29. September 2018, 15:51:46 »
@Keruskerfuerst

Hallo Keruskerfuerst,
ich bin ein Anfänger wenn es um Linux geht, war aber mit Windows recht fit. Wollte eben zu Linux wechseln, für mich gab es ein paar must haves:
1. Unterstützung für meinen Drucker Epson EcoTank ET-2500
2. Fotos vom iPhone 4 und 6S downloaden
3. Fotos von einem Samsung Galaxy downloaden
4. Standby modus muss funktionieren

Ich sage nicht, dass Debian das non-plus-ultra ist.
Da ich meinen Kids bereits Lubuntu auf ihren Laptops installiert habe, habe ich es auf meinem PC mit Lubuntu versucht, hat aber nicht so gut funktioniert, dann Xubuntu, ging aber auch nicht so gut, dann Manjaro, es hat mir recht gut gefallen, doch um den Drucker und dei beiden Smartphones zum Laufen zu bringen war nicht so einfach und der Standby Modus hat nie richtig funktioniert. Bin im Moment bei Debian XFCE, alle Anforderungen sind erfüllt, was mir aber nicht ganz recht gefällt sind die Schriften, da bin ich noch dran. Ich sage nicht, dass ich bei Debian für immer bleibe, aber im Moment stimmt es für mich.
Gruss