Autor Thema: Teamviewer - GUI startet nicht nach Dist-Upgrade  (Gelesen 4960 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Doc

  • Neuling
  • *
  • Beiträge: 10
  • Dankeschön: 1 mal
    • Praxis Dr. Ganthaler
  • Desktop: Cinnamon
  • Grafikkarte: nVidia GK107M [GeForce GT 755M Mac Edition]
  • Grafikkartentreiber: Driver: "nvidia"
  • Kernel: 4.4.19-1-MANJARO
  • Prozessor: Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
  • Skill: Durchschnitt
  • Zweig: stable
Teamviewer - GUI startet nicht nach Dist-Upgrade
« am: 24. September 2018, 10:04:33 »
Problem: Teamviewer - GUI startet nicht nach Dist-Upgrade

Bereits versuchte Lösungsansätze nach Durchforsten der Foren:

1) lib32-freetype2-2.8-2-x86_64.pkg.tar.xz nachinstallieren
sudo pacman -U lib32-freetype2-2.8-2-x86_64.pkg.tar.xz
[sudo] Passwort für user:
Lade Pakete...
Warnung: Downgrade des Paketes lib32-freetype2 (2.9.1-1 => 2.8-2)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (1) lib32-freetype2-2.8-2

Gesamtgröße der installierten Pakete:   0,80 MiB
Größendifferenz der Aktualisierung:  -0,01 MiB

:: Installation fortsetzen? [J/n] j
(1/1) Prüfe Schlüssel im Schlüsselring             [######################] 100%
(1/1) Überprüfe Paket-Integrität                   [######################] 100%
(1/1) Lade Paket-Dateien                           [######################] 100%
(1/1) Prüfe auf Dateikonflikte                     [######################] 100%
:: Verarbeite Paketänderungen...
(1/1) Downgrading lib32-freetype2                  [######################] 100%
:: Starte post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

2) Dienst starten
sudo systemctl enable teamviewerd
sudo systemctl start teamviewerd

3) Teamviewer Daemon starten

sudo teamviewer -daemon start
[sudo] Passwort für user:

systemctl start teamviewerd.service

***********************************

teamviewer
Init...
CheckCPU: SSE2 support: yes
XRandRWait: No value set. Using default.
XRandRWait: Started by user.
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

***********************************

Teamviewer wird vom Terminal aus gestartet.
Nach einer kurzen Pause passiert nichts.
Das System ist auf neustem Stand.

***********************************

Systeminformation:
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=17.1.12
DISTRIB_CODENAME=Hakoila
DISTRIB_DESCRIPTION="Manjaro Linux"
Kernel 4.14.66-1-MANJARO

Ich wäre dankbar für jede Hilfe, die den Teamviewer wieder zur Mitarbeit bewegen könnte.

Gruß, Doc




Offline Doc

  • Neuling
  • *
  • Beiträge: 10
  • Dankeschön: 1 mal
    • Praxis Dr. Ganthaler
  • Desktop: Cinnamon
  • Grafikkarte: nVidia GK107M [GeForce GT 755M Mac Edition]
  • Grafikkartentreiber: Driver: "nvidia"
  • Kernel: 4.4.19-1-MANJARO
  • Prozessor: Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
  • Skill: Durchschnitt
  • Zweig: stable
(SOLVED) Teamviewer - GUI startet nicht nach Dist-Upgrade
« Antwort #1 am: 24. September 2018, 12:59:25 »
LÖSUNG / SOLUTION:

1) Teamviewer und Konfiguration deinstallieren:
yaourt -Rsn teamviewer
[sudo] Passwort für user:
Prüfe Abhängigkeiten...
:: lib32-qt4 benötigt optional lib32-libxinerama: Xinerama support

Pakete (4) lib32-libjpeg6-turbo-1.5.3-1  lib32-libpng12-1.2.59-1
           lib32-libxinerama-1.1.3-2  teamviewer-12.0.76279-6

Gesamtgröße der entfernten Pakete:  144,32 MiB

:: Möchten Sie diese Pakete entfernen? [J/n] j
:: Verarbeite Paketänderungen...
(1/4) Entferne teamviewer                          [######################] 100%
(2/4) Entferne lib32-libxinerama                   [######################] 100%
(3/4) Entferne lib32-libpng12                      [######################] 100%
(4/4) Entferne lib32-libjpeg6-turbo                [######################] 100%
:: Starte post-transaction hooks...
(1/4) Updating icon theme caches...
(2/4) Reloading system manager configuration...
(3/4) Arming ConditionNeedsUpdate...
(4/4) Updating the desktop file MIME type cache...
Es wurden keine Datenbankfehler gefunden!

2) Teamviewer erneut installieren:
yaourt -S teamviewer

3) Teamviewer starten > Problem gelöst
« Letzte Änderung: 24. September 2018, 13:02:16 von Doc »

Offline Doc

  • Neuling
  • *
  • Beiträge: 10
  • Dankeschön: 1 mal
    • Praxis Dr. Ganthaler
  • Desktop: Cinnamon
  • Grafikkarte: nVidia GK107M [GeForce GT 755M Mac Edition]
  • Grafikkartentreiber: Driver: "nvidia"
  • Kernel: 4.4.19-1-MANJARO
  • Prozessor: Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
  • Skill: Durchschnitt
  • Zweig: stable
Re: Teamviewer - GUI startet nicht nach Dist-Upgrade
« Antwort #2 am: 24. September 2018, 14:41:28 »
Teamviewer nach Start:
Nicht bereit. Bitte prüfen sie ihre Internetverbindung.

Abhilfe schafft hier:
sudo systemctl stop teamviewerd.service
sudo systemctl start teamviewerd.service

Offline Matthias M.

  • Neuling
  • *
  • Beiträge: 34
  • Dankeschön: 1 mal
  • Skill: Anfänger
  • Zweig: stable
Re: Teamviewer - GUI startet nicht nach Dist-Upgrade
« Antwort #3 am: 25. September 2018, 15:58:21 »
Hallo,

Frage von mir dazu:
Wenn ich nach einem Neustart von Manjaro den Teamviewer starte, heißt es bei mir auch immer:
"Nicht bereit. Bitte prüfen sie ihre Internetverbindung."

Wenn ich dann im TeamViewer unter Extras > Optionen > Eingehende LAN Verbindungen auf "Akzeptieren" setze klappt es. Dann erscheint im TeamViewer Hauptfenster links unten der grüne Punkt und daneben steht "Nur LAN Verbindungen sind möglich".

Aber nach dem nächsten Neustart wieder das Gleiche ... Hinter "Eingehende LAN Verbindungen" steht "Deaktiviert" und ich muss es wieder auf "Akzeptieren" setzen.

Und ich muss bei bei jedem Start auch das Lizenzabkommen erneut absegnen.

Ich habe so das Gefühl, dass halt einfach keine Einstellungen gespeichert werden (können), weder, dass das Lizenzabkommen bereits akzeptiert wurde, noch dass LAN-Verbindungen akzeptiert werden.
Habe aber keinen Schimmer, woran es liegen könnte!

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1440
  • Dankeschön: 277 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Teamviewer - GUI startet nicht nach Dist-Upgrade
« Antwort #4 am: 25. September 2018, 17:21:12 »
Hallo Matthias,
probiere mal die Lösung von "joaodalvi commented on 2018-09-11 18:45"
https://aur.archlinux.org/packages/teamviewer/

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Matthias M.

Offline Matthias M.

  • Neuling
  • *
  • Beiträge: 34
  • Dankeschön: 1 mal
  • Skill: Anfänger
  • Zweig: stable
Re: Teamviewer - GUI startet nicht nach Dist-Upgrade
« Antwort #5 am: 25. September 2018, 17:39:22 »
Jo, das hat's gebracht! :)
Jetzt muss ich nicht mehr das Lizenzabkommen abnicken und wenn ich TeamViewer starte, steht da neben dem grünen Punkt direkt "Bereit zum Verbinden".

Vielen Dank!