Autor Thema: Keine Wifi-Verbindungen mehr sichtbar  (Gelesen 2290 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline HuRRiCaNe

  • Neuling
  • *
  • Beiträge: 26
  • Desktop: XFCE4
  • Kernel: x86_64 Linux 4.19.0-4-MANJARO
  • Skill: Durchschnitt
Keine Wifi-Verbindungen mehr sichtbar
« am: 27. September 2018, 17:33:20 »
Guten Tag zusammen,

ich habe folgendes Problem:

ich sitze momentan für 6 Monate in einem Studienzentrum. Ich habe mir einen WLAN-Stick gekauft, da ich mein Laptop als AccessPoint nutzen möchte.

Gesagt, getan. Mit create_ap habe ich dann versucht einen Hotspot zu erstellen. Dies gelang nur teilweise, da create_ap gemeckert hat bzgl. Realtek adapters.

Ich habe mir sodann diese Anleitung hier

https://github.com/oblique/create_ap/blob/master/howto/realtek.md

angeschaut,

pacman -S base-devel linux-headers dkms git
pacman -R hostapd

Diese beiden Commands habe ich ausgeführt.

Als nächstes sollte man folgendes machen;

With the following commands you can install a fixed version of Realtek's driver:

git clone https://github.com/pvaret/rtl8192cu-fixes.git
dkms add rtl8192cu-fixes
dkms install 8192cu/1.9
cp rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d
cp rtl8192cu-fixes/8192cu-disable-power-management.conf /etc/modprobe.d


dkms install 8192cu/1.9 --> dieser Befehl sagte allerdings:

Error! Could not find module source directory.
Directory: /usr/src/8192cu-1.9 does not exist.

Ich habe mir nichts weiter dabei gedacht und sodann den letzten Befehl ausgeführt:

yaourt -S hostapd-rtl871xdrv

Die Installation klappte auch, als ich jedoch am nächsten Tag create_ap testen wollte, konnte ich keine Wifi-Verbindungen mehr sehen. Weder über das OnBoard Wifi noch über den Wifi-Stick.

Ich bin zwar kein noob, aber was treiber angeht evtl. schon.

Wäre super, wenn mir da jemand helfen könnte. Derzeit gehe ich über LAN rein, das funktioniert soweit.


Hier noch ein paar Eckdaten zum OS:

OS: Manjaro 17.1.12 Hakoila
Kernel: x86_64 Linux 4.14.71-1-MANJARO
DE: Xfce4
CPU: Intel Celeron N3050 @ 2x 2.16GHz


Ausgabe von ifconfig:
enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.45.161  netmask 255.255.252.0  broadcast 192.168.47.255
        inet6 fe80::b08f:5227:765b:a5dd  prefixlen 64  scopeid 0x20<link>
        ether 70:5a:0f:65:5e:75  txqueuelen 1000  (Ethernet)
        RX packets 50161  bytes 51859140 (49.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 37461  bytes 4066158 (3.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 376  bytes 29464 (28.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 376  bytes 29464 (28.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
« Letzte Änderung: 27. September 2018, 17:35:51 von HuRRiCaNe »

Offline HuRRiCaNe

  • Neuling
  • *
  • Beiträge: 26
  • Desktop: XFCE4
  • Kernel: x86_64 Linux 4.19.0-4-MANJARO
  • Skill: Durchschnitt
Re: Keine Wifi-Verbindungen mehr sichtbar
« Antwort #1 am: 30. September 2018, 14:56:04 »
Schon mal vielen Dank für die Anwort.

Ich habe jetzt beides ausprobiert. Den Kernel geupdatet und den Treiber per yaourt installiert. Nichts tut sich. Weder das interne Wifi noch der Adapter schlägt an.


Offline HuRRiCaNe

  • Neuling
  • *
  • Beiträge: 26
  • Desktop: XFCE4
  • Kernel: x86_64 Linux 4.19.0-4-MANJARO
  • Skill: Durchschnitt
Re: Keine Wifi-Verbindungen mehr sichtbar
« Antwort #2 am: 08. Oktober 2018, 18:33:46 »
Ich habe eine Lösung in einem anderen Forum gefunden. Dies hat auch bei meinem Manjaro funktioniert O0

sudo echo "options rtl8723be fwlps=0">/etc/modprobe.d/rtl8723be.conf

System reboot und fertig.

Quelle:
https://ubuntuforums.org/showthread.php?t=2280428