Autor Thema: Festplatte einbinden  (Gelesen 570 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline gorzka

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 201
  • Dankeschön: 6 mal
  • meiner einer
  • Skill: Anfänger
Festplatte einbinden
« am: 07. November 2018, 19:50:52 »
Abend zusammen,

ich habe 2 Festplatten in meinem Rechner. Wenn ich auf die 2. Festplatte zugreifen möchte werde ich nach einem Passwort gefragt.

Kann ich das irgendwie abstellen?

Offline Keruskerfuerst

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 212
  • Dankeschön: 6 mal
  • Desktop: KDE
  • Grafikkarte: Nvidia GTX 970
  • Kernel: stable LTS
  • Prozessor: Intel Core I 7 5820 K
  • Skill: Anfänger
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #1 am: 08. November 2018, 16:20:42 »
Dann mal /etc/fstab posten !

Offline gorzka

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 201
  • Dankeschön: 6 mal
  • meiner einer
  • Skill: Anfänger
Re: Festplatte einbinden
« Antwort #2 am: 08. November 2018, 16:33:16 »
# /dev/sdb1
UUID=dc3613b2-95d0-44fe-b2fc-98252dcdf12a /          xfs        rw,relatime,attr2,inode64,noquota 0 0

# /dev/sdb3
UUID=4f4dfda7-abe5-4b49-b9dc-f43e03820246 /home      xfs        rw,relatime,attr2,inode64,noquota 0 0

# /dev/sdb2
UUID=c6e1e023-e589-4ac0-9b28-28f98f01817c none      swap      defaults,pri=-2 0 0

Ich schätze mal ich muss sie fest einbinden. Richtig?

Offline kisun

  • Neuling
  • *
  • Beiträge: 42
  • Dankeschön: 6 mal
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 4.20.1-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #3 am: 09. November 2018, 09:03:29 »
Hallo gorzka.

Zitat von: Gorzka
Ich schätze mal ich muss sie fest einbinden. Richtig?

Das klingt so als ob die Platte jedes mal mit "sudo mount ...." einbindest. Wenn dem so ist, ist die Platte uU für einen falschen Benutzer gemountet (meist root).
Dann mounte die Platte mit den Optionen uid=1000,gid=1000.

Also
sudo mount -o defaults,uid=1000,gid=1000   ...
Die drei Punkte noch mit deinen Mountparametern ersetzen. In der Datei /etc/passwd kannst du auch prüfen ob die 1000 wirklich deine User ID ist.

Bitte auch nochmal dein User-Profil ausfüllen, damit können die anderen die Fehler besser einschränken.

Liebe Grüße

Offline gorzka

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 201
  • Dankeschön: 6 mal
  • meiner einer
  • Skill: Anfänger
Re: Festplatte einbinden
« Antwort #4 am: 09. November 2018, 17:56:53 »
Hatte ich vergessen. Die Platte steht nicht in der fstab, es ist sda. Das ist meine Sicherungsplatte.
Die anderen sind root, swap und home.

Jedesmal wenn ich in Cinnamon auf die Platte klicke verlangt er das Passwort. Ist übrigens auch bei Arch und Antergos.

Offline kisun

  • Neuling
  • *
  • Beiträge: 42
  • Dankeschön: 6 mal
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 4.20.1-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #5 am: 13. November 2018, 20:34:02 »
Hallo gorzka,

du kannst nochmal versuchen bei der gemounteten Platte den Besitzer zu ändern. Den Befehl musst du noch ein deine Bedürfnisse anpassen!
USERNAME solltest du durch deinen Benutzernamen ersetzen und "/run/media/user/daten" durch den Pfad an dem die Platte bei dir gemountet ist.

sudo chown USERNAME:USERNAME /run/media/user/daten

Offline gorzka

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 201
  • Dankeschön: 6 mal
  • meiner einer
  • Skill: Anfänger
Re: Festplatte einbinden
« Antwort #6 am: 25. November 2018, 07:25:12 »
ich habe es leider immer noch nicht geschafft. jedesmal wenn ich die Platte einhängen will unter Cinnamon muss ich das PW eingeben. Benutzerrechte passen soweit

Das muß doch auch ohne gehen

Offline Testsieger

  • Neuling
  • *
  • Beiträge: 4
  • Desktop: gnome
  • Grafikkarte: Palit NE5105T018G1H (Nvidia 1050Ti)
  • Prozessor: AMD Phenom II X4 955
  • Skill: Durchschnitt
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #7 am: 06. Dezember 2018, 09:57:14 »
Jedesmal wenn ich in Cinnamon auf die Platte klicke verlangt er das Passwort.

Wird nach dem root Passwort gefragt oder ist die Platte etwa verschlüsselt?

Offline Keruskerfuerst

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 212
  • Dankeschön: 6 mal
  • Desktop: KDE
  • Grafikkarte: Nvidia GTX 970
  • Kernel: stable LTS
  • Prozessor: Intel Core I 7 5820 K
  • Skill: Anfänger
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #8 am: 06. Dezember 2018, 13:29:16 »
Man kann auch die Platte in fstab eintragen und dann dort die Option "noauto" eintragen.
Dann wird die Platte nicht automatisch eingehängt.
Auch entsprechende Berechtigungen als Option eintragen.

Offline herrmie

  • Neuling
  • *
  • Beiträge: 6
  • Desktop: xfce
  • Kernel: 4.19
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #9 am: 11. Dezember 2018, 22:23:36 »
Hallo,

kann es vielleicht daran liegen, dass dein User mit dem du angemeldet bist nicht in der Gruppe storage ist?
Ist nur eine Vermutung, denn ich hatte das Problem auch schonmal früher und da war es irgendwas mit den Gruppen in denen ich nicht war.

Grüße,
herrmie

Offline oldmcsam

  • Sr. Mitglied
  • ****
  • Beiträge: 436
  • Dankeschön: 16 mal
  • Desktop: XFCE, Mate
  • Grafikkarte: Ati Radeon HD 6670, Intel 3000
  • Grafikkartentreiber: free
  • Kernel: 4.14.48
  • Prozessor: Dual Core 3.0; i5 2,5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #10 am: 24. Dezember 2018, 20:23:20 »
Hallo,
wenn ich möchte, daß eine Platte (oder auch eine Partition) automatisch beim Start eingebunden werden soll, dann trage ich folg. in die fstab ein:

/dev/sda2        /mnt/sda2    ntfs       user,rw,umask=000,noatime,auto   0   0
sda2 = 2. Partition auf sda (entsprechend abändern),    ntfs (Formatierung, oder vfat) 

Speichern und beim Neustart ist die Platte oder entsprechende Partition automatisch eingebunden.
Nicht der ist dumm, der nichts weiß,
sondern der, der glaubt schon alles zu wissen.

Offline Atze

  • Neuling
  • *
  • Beiträge: 7
  • Desktop: Cinnamon 4.0.8
  • Grafikkarte: Intel HD 3000
  • Grafikkartentreiber: free
  • Kernel: 4.19.12-2-MANJARO
  • Prozessor: Intel© Core™ i3-2370M CPU @ 2.40GHz × 2
  • Skill: Anfänger
  • Zweig: stable
Re: Festplatte einbinden
« Antwort #11 am: 25. Dezember 2018, 11:40:01 »
Im Cinnamon Haupt-Menü unter der Rubrik "Zubehör" gibt es eine Anwendung "Laufwerke".

Für jedes Laufwerk können hier die Einhängeoptionen geändert werden.

Ich habe die "Vorgaben der Benutzersitzung" deaktiviert.

Die Einhängeoptionen

1. Beim Systemstart einhängen   aktiviert

2. In der Benutzerschnittstelle anzeigen    deaktiviert

3. Zusätzliche Legitimierung zum Einhängen verlangen    deaktiviert

Somit war das Problem bei meiner 2. Platte erledigt.

Offline nogaro

  • Jr. Mitglied
  • **
  • Beiträge: 66
  • Desktop: KDE-Plasma-Version: 5.14.4
  • Grafikkarte: AMD Radeon HD 6450
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-1-MANJARO
  • Prozessor: 4 × AMD Phenom(tm) II X4 945 Processor
  • Skill: Anfänger
Re: Festplatte einbinden
« Antwort #12 am: 25. Dezember 2018, 20:38:12 »
Ich wäre vorsichtig mit dem autmatischen Einhängen von HDD Platten. Sollte es dabei Probleme geben könnte dein System nicht mehr hochfahren ( hatte ich schon mal ).
Ich kann meine Platten ohne Password einhängen, allerdings habe ich auch nicht " automatisch anmelden " beim Start nicht aktiviert.
Betriebssystem: Manjaro Linux
KDE-Plasma-Version: 5.14.4
Qt-Version: 5.12.0
KDE-Frameworks-Version: 5.53.0
Kernel-Version: 4.20.0-1-MANJARO
Art des Betriebssystems: 64-bit
Prozessoren: 4 × AMD Phenom(tm) II X4 945 Processor
Speicher: 7,8 GiB Arbeitsspeicher