Autor Thema: Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)  (Gelesen 157 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline PCNerd

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Xfce
  • Skill: Durchschnitt
Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)
« am: 17. November 2018, 12:42:50 »
$ sudo pacman -Syu

[...]

:: Installation fortsetzen? [J/n]
(374/374) Prüfe Schlüssel im Schlüsselring                   [################################] 100%
(374/374) Überprüfe Paket-Integrität                         [################################] 100%
(374/374) Lade Paket-Dateien                                 [################################] 100%
(374/374) Prüfe auf Dateikonflikte                           [################################] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/Manjaro-Light2.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/Manjaro_Perspective_light.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/block-font-logo3.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/buttongreen.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/default-adapta-lockscreen.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/default-adapta.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/glassfieldManjaro_perspective_center_dark.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/illyria-adapta-dark-maia.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/illyria-default2.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/illyria-light-maia.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/light-stripe-maia.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro-adapta-maia-1.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro-cat.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro-dog.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro-maia-button.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro-maia-text.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro_grid_maia.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro_maia_abstract.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro_maia_abstract2.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/manjaro_maia_logo.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/play.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/school-project.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/wMJ_neutral_textured_warm.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/wpM_architect.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/wpM_illyria_adapta.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/wpM_orbit2_textured.jpg existiert im Dateisystem
manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/wpM_pcvp.jpg existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Wie kann ich das beheben?

Offline PCNerd

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Xfce
  • Skill: Durchschnitt
Re: Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)
« Antwort #1 am: 17. November 2018, 13:50:31 »
Ich habe eine Lösung gefunden:sudo pacman -S --overwrite *.jpg manjaro-wallpapers-18.0

Offline quantix

  • Sr. Mitglied
  • ****
  • Beiträge: 464
  • Dankeschön: 56 mal
  • Desktop: Xfce + fish
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: free / nonfree
  • Kernel: 4.20 / 4.20
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)
« Antwort #2 am: 17. November 2018, 14:31:36 »
Hallo PCNerd

manjaro-wallpapers-18.0: /usr/share/backgrounds/xfce/Manjaro-Light2.jpg existiert im DateisystemDas kommt, wenn die Mirrorlist nicht aktuell ist. Ein
sudo pacman-mirrors -f10 && sudo pacman -Syyusollte dein Problem beheben.

Statt  -f10 - hier werden die 10 schnellsten Mirrors in die Mirrorlist geschrieben - kannst du auch -c Germany nehmen oder dir mit
pacman -mirrors  --listdie Länder, in denen Mirrors existieren, anzeigen lassen. Mehrere Länder werden mit Komma und ohne Leerzeichen angegeben, z.B. Germany,Belgium,Czech...

Grüße
Josef
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Raspberry
Folgende Mitglieder bedankten sich: PCNerd

Offline PCNerd

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Xfce
  • Skill: Durchschnitt
Re: Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)
« Antwort #3 am: 18. November 2018, 10:41:49 »
Ich aktualisiere die Pakete eigentlich immer mit dem grafischem Programm "pamac". Dort ist der Fehler ebenfalls aufgetreten. Eine Aktualisierung der Mirrors über die Pamac-Einstellungen hat leider nichts bewirkt.
Aber danke für die Befehle, die kann ich sicherlich gebrauchen.
« Letzte Änderung: 18. November 2018, 10:44:45 von PCNerd »

Offline quantix

  • Sr. Mitglied
  • ****
  • Beiträge: 464
  • Dankeschön: 56 mal
  • Desktop: Xfce + fish
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: free / nonfree
  • Kernel: 4.20 / 4.20
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Pakete lassen sich nicht mehr aktualisieren (Dateikonflikt)
« Antwort #4 am: 18. November 2018, 23:35:26 »
Da ist mir leider ein Fehler passierten. Es sollte heißen
pacman-mirrors --list
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Raspberry