Autor Thema: UEFI mit Virt-Manager - kein UEFI boot von ISO  (Gelesen 83 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline ds2k5

  • Neuling
  • *
  • Beiträge: 12
  • Dankeschön: 1 mal
  • Skill: Anfänger
UEFI mit Virt-Manager - kein UEFI boot von ISO
« am: 10. Dezember 2018, 09:16:54 »
Hallo,
ich versuche mich mit dem virt-manager und UEFI.

/etc/libvirt/qemu.conf
nvram = [
        "/usr/share/ovmf/x64/OVMF_CODE.fd:/usr/share/ovmf/x64/OVMF_VARS.fd"
]

Wenn ich versuche eine VM anzulegen schliesst sich das Konfig Fenster ohne die VM anzulegen.

Manuell anlegen klappt zwar, aber will dann nicht von der ISO UEFI booten.
(editiere dann mit dem Virt-manager und lege das CD-ROM device an und hänge die ISO rein, setze die CD als erstes in der Bootreihenfolge)
virt-install --name osx --ram 4096 --disk size= --boot uefi

sehe nur die UEFI Interactive Shell
wenn ich mit exit raus gehe und versuche via Boot from File...finde ich leider keine boot files

Was mach ich falsch ?

Installierte Packete:

virt-manager 2.0.0-1
ovmf 1:r24601.6861765935-1
qemu 3.0.0-4
libvirt 4.8.0-2

« Letzte Änderung: 10. Dezember 2018, 09:22:48 von ds2k5 »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1470
  • Dankeschön: 282 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: UEFI mit Virt-Manager - kein UEFI boot von ISO
« Antwort #1 am: 10. Dezember 2018, 12:53:08 »
Hallo ds2k5,
bin noch nicht in die Verlegenheit gekommen, ein UEFI-ISO in QEMU zu benutzen, aber es könnte helfen eine Kopie von OVMF_VARS.fd anzulegen, z.B.
cp /usr/share/ovmf/x64/OVMF_VARS.fd my_uefi_vars.binund dann diese Kopie auch in die QEMU-Kommandozeile einzubeziehen:
...
-drive if=pflash,format=raw,readonly,file=/usr/share/ovmf/x64/OVMF_CODE.fd \
-drive if=pflash,format=raw,file=my_uefi_vars.bin
...
ausführlicher hier erklärt
https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface#Testing_UEFI_in_systems_without_native_support

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung