Autor Thema: Krusader auf Englisch, obwohl Sprache: Deutsch  (Gelesen 157 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 722
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Krusader auf Englisch, obwohl Sprache: Deutsch
« am: 14. Dezember 2018, 21:12:48 »
Hallo,

ich habe Manjaro mit den Oberflächen Xfce und KDE-Plasma in einer Vm installiert.

Unter Xfce wird der Krusader mit englischem Menü angezeigt, obwohl in
Help -> Switch Application  Language... -> Primary Language: Deutsch eingestellt ist.
Der Logout-Dialog unter Xfce ist auch Englisch.

Unter KDE-Plasma ist die Sprache in den Menüs dagegen Deutsch.

$ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
deutsch
en_US
en_US.iso88591
en_US.utf8
german
POSIX

$ sudo locale-gen
Generating locales...
  de_DE.UTF-8... done
  de_DE.ISO-8859-1... done
  de_DE.ISO-8859-15@euro... done
  en_US.UTF-8... done
  en_US.ISO-8859-1... done
Generation complete.

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_DE@euro
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
In
Einstellungen -> Systemeinstellungen -> Regionaleinstellungen -> Sprache: Deutsch (Default) und an zweiter Stelle American English
Wie erreiche ich, daß alle Menüs unter Xfce auch in Deutsch sind?

Gruß

Ch. Hanisch



« Letzte Änderung: 14. Dezember 2018, 21:25:25 von Hanisch »
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1470
  • Dankeschön: 282 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #1 am: 14. Dezember 2018, 23:11:59 »
Hallo Ch. Hanisch,
hast Du in xfce im Manjaro Einstellungsmanager -> Sprachumgebungseinstellungen -> Systemsprachumgebungen "Deutsch" an erster Stelle stehen?
Ansonsten bringt Kusader seine eigene Sprachdatei mit, die deutsche liegt in /usr/share/locale/de/LC_MESSAGES/krusader.mo
Bei mir erschien Krusader gleich auf deutsch (in xfce), zum Start der Einrichtungsassistent und dann auch Krusader selbst.
Wenn es Schwierigkeiten gibt kann es vielleicht auch daran liegen, daß Krusader zumindest für die optische Erscheinung QT5 benutzt und in XFCE dafür auch die qt5-styleplugins installiert sein müssen. Ist aber nur eine Vemutung von mir, weil ich nicht weiss, ob die Spracheinstellung auch unter die Zuständigkeit von qt5-styleplugins fällt. Ich glaube es eher nicht.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 722
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #2 am: 15. Dezember 2018, 11:34:09 »
Hallo,

hast Du in xfce im Manjaro Einstellungsmanager -> Sprachumgebungseinstellungen -> Systemsprachumgebungen "Deutsch" an erster Stelle stehen?
Bei mir gibt es nur den Menüpunkt: Einstellungen -> Manjaro Einstellungen -> Locale Settings und Language Packages.

Wo finde ich den "Manjaro Einstellungsmanager"?

Zitat
Ansonsten bringt Kusader seine eigene Sprachdatei mit, die deutsche liegt in /usr/share/locale/de/LC_MESSAGES/krusader.mo
Diese Datei ist bei mir vorhanden.

Zitat
Wenn es Schwierigkeiten gibt kann es vielleicht auch daran liegen, daß Krusader zumindest für die optische Erscheinung QT5 benutzt und in XFCE dafür auch die qt5-styleplugins installiert sein müssen.
$ sudo pacman -S qt5-styleplugins
warning: qt5-styleplugins-5.0.0.20170311-8 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) qt5-styleplugins-5.0.0.20170311-8

Total Installed Size:  1,20 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring                                                      [################################################] 100%
(1/1) checking package integrity                                                    [################################################] 100%
(1/1) loading package files                                                         [################################################] 100%
(1/1) checking for file conflicts                                                   [################################################] 100%
(1/1) checking available disk space                                                 [################################################] 100%
:: Processing package changes...
(1/1) reinstalling qt5-styleplugins                                                 [################################################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Es ändert sich nichts, andere Programme (Firefox, Thunderbird)  sind allerdings auf Deutsch. Aber 'dolphin' oder 'googleearth' oder 'eclipse' z.B. nicht.

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1470
  • Dankeschön: 282 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #3 am: 15. Dezember 2018, 17:16:03 »
Hallo Ch. Hanisch,
Bei mir gibt es nur den Menüpunkt: Einstellungen -> Manjaro Einstellungen -> Locale Settings und Language Packages.
Wo finde ich den "Manjaro Einstellungsmanager"?
Das ist schon die richtige Stelle, nur eben auf englisch. Trotzdem ein paar Bildchen:

 



 



 



 

"anwenden" nicht vergessen.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Hanisch

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 722
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #4 am: 15. Dezember 2018, 17:57:51 »
Hallo,

Das ist schon die richtige Stelle, nur eben auf englisch. Trotzdem ein paar Bildchen:

 

"anwenden" nicht vergessen.
Dein letztes Bild hat das Problem gelöst. Dort hatte ich noch jede Menge anderer Einstellungen drin.

Gruß
Ch.Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 380
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.19
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #5 am: 15. Dezember 2018, 22:57:33 »
Profil von Hanisch
Registriert: 16. April 2014, 13:19:05

Wo finde ich den "Manjaro Einstellungsmanager"?


Ohne Worte...
Void Linux .:. FreeBSD

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 722
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #6 am: 16. Dezember 2018, 10:33:32 »
Profil von Hanisch
Registriert: 16. April 2014, 13:19:05

Ohne Worte...
Das heißt nämlich genau
Whisker Menü -> Einstellungen -> Manjaro Einstellungenund nicht "Manjaro Einstellungsmanager". Man muß da schon ganz genauer sein (nach 4 Jahren!) - oder?

Gruß

Ch. Hanisch

Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 380
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.19
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #7 am: 16. Dezember 2018, 12:08:59 »
Naja, von Manjaro Einstellungsmanager zu Manjaro Einstellungen ist der Weg ja nun nicht so weit wenn man ersteren nicht finden kann. Nach 4 Jahren Manjaro sollte man doch in der Lage sein das zu finden wenn man sich denn halbwegs damit befasst und gewillt ist ein Mindestmaß an Eigeninitiative aufzubringen.

Und auf Englisch heisst er sehr wohl Manjaro Settings Manager.
 
« Letzte Änderung: 16. Dezember 2018, 12:11:05 von suska »
Void Linux .:. FreeBSD

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 722
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Krusader auf Englisch, obwohl Sprache: Deutsch
« Antwort #8 am: 16. Dezember 2018, 13:10:04 »
Naja, von Manjaro Einstellungsmanager zu Manjaro Einstellungen ist der Weg ja nun nicht so weit wenn man ersteren nicht finden kann. Nach 4 Jahren Manjaro sollte man doch in der Lage sein das zu finden wenn man sich denn halbwegs damit befasst und gewillt ist ein Mindestmaß an Eigeninitiative aufzubringen.

Und auf Englisch heisst er sehr wohl Manjaro Settings Manager.
Lassen wir doch die Krümelkackerei.

Das Problem ist aufgrund des Hinweises von  gosia doch gelöst.

Die Frage bleibt allerdings, wie kommen die weiteren offensichtlich überflüssigen Einträge bei mir dort hinein?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)