Autor Thema: Verschlüsselte Installation nicht möglich  (Gelesen 132 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline sanyam

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Deepin
  • Grafikkartentreiber: free
  • Prozessor: 4.14.0-1-MANJARO
  • Skill: Durchschnitt
  • Zweig: stable
Verschlüsselte Installation nicht möglich
« am: 12. Januar 2019, 11:26:11 »
Hallo Leute,

in letzter Zeit hatte ich ein vollverschlüsseltes System mit BTRFS im Einsatz, da ich aber 2x Dateisystemfehler hatte, welcher auf BTRFS zurückzuführen war und zu einer Neuinstallation führte, wollte ich wieder auf ext4 zurück.

Also den Manjaro Architect gestartet und folgendes Partitionsschema erstellt:

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         1026047   500.0 MiB   EF00  EFI System
   2         1026048       500118158   238.0 GiB   8300  Linux filesystem

eine 500MB EFI-Partition für /boot und den Rest in ext4 für LVM on LUKS.
Im Architect erstelle ich dann für die letztere Partition eine LUKS-Verschlüsselung, eine VolumeGroup und 3 LV's.

Soweit so gut, Basisinstallation inkl. Desktop läuft durch und dann kommt die Bootloader-Installation von Grub (gewählt habe ich als /boot die erste Partition mit Mountpunkt /boot/efi wie vom Installer vorgeschlagen).

grub-2.03.2-1-x86_64                                                                                                   5.7 MiB   645K/s 00:09 [#######################################################################################]  98%
 efibootmgr-16-1-x86_64                                                                                                 5.8 MiB   644K/s 00:09 [#######################################################################################]  99%
 dosfstools-4.1-2-x86_64                                                                                                5.8 MiB   643K/s 00:09 [#######################################################################################] 100%
(3/3) checking keys in keyring                                                                                                                 [#######################################################################################] 100%
(3/3) checking package integrity                                                                                                               [#######################################################################################] 100%
(3/3) loading package files                                                                                                                    [#######################################################################################] 100%
(3/3) checking for file conflicts                                                                                                              [#######################################################################################] 100%
(3/3) checking available disk space                                                                                                            [#######################################################################################] 100%
:: Processing package changes...
(1/3) installing grub                                                                                                                          [#######################################################################################] 100%
Generating grub.cfg.example config file...
This may fail on some machines running a custom kernel.

Hierbei gibt es das erste Problem, denn nach der letzten Ausgabe geschieht nichts mehr, ich muss mit STRG-C den aktuellen Befehl unterbrechen. Gewählt habe ich bei der Installation base-devel inkl. yaourt, den Kernel 4.17 und 4.20.

Unterbreche ich folgt:
^COptional dependencies for grub
    freetype2: For grub-mkfont usage [installed]
    fuse: For grub-mount usage [installed]
    dosfstools: For grub-mkrescue FAT FS and EFI support [installed]
    efibootmgr: For grub-install EFI support [installed]
    libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
    os-prober: To detect other OSes when generating grub.cfg in BIOS systems [installed]
    mtools: For grub-mkrescue FAT FS support
4+0 Datensätze ein
4+0 Datensätze aus
2048 bytes (2,0 kB, 2,0 KiB) copied, 0,00191704 s, 1,1 MB/s
Generating a keyfile
Adding the keyfile to the LUKS configuration
Geben Sie irgendeine bestehende Passphrase ein:

Also geht es ja irgendwie trotzdem weiter, Passphrase eingegeben und weiter gehts:

==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.20-x86_64-fallback.img
==> Image generation successful

Hier geschieht wieder nichts und irgendwann erhalte ich dann ein:
Zitat
Achtung: Das Programm „/usr/bin/sudo“ ist abgestürzt.
.

Wie löse ich das Problem nun?

LVM on LUKS sollte ja für Manjaro nichts so außergewöhnliches sein, sodass es nicht funktionieren sollte...

Ich hatte mal getestet anstelle von /boot/efi den Mountpunkt der Boot-Partition auf /boot zu setzen, die oben genannten Probleme habe ich dann nicht, jedoch lande ich nach der Installation dann in der grub-rescue Konsole..

Für Hinweise wäre ich sehr dankbar.

PS: Nur um im Vorfeld eine Diskussion auszuschließen, ich lege Wert auf eine Verschlüsselung meines Systems samt SWAP-Partition, also bitte ich darum keine Lösungsvorschläge wie "lass die Verschlüsselung einfach weg" zu nennen.

Gruß

Offline Keruskerfuerst

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 131
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Nvidia GTX 970
  • Kernel: stable LTS
  • Prozessor: Intel Core I 7 5820 K
  • Skill: Anfänger
  • Zweig: stable
Re: Verschlüsselte Installation nicht möglich
« Antwort #1 am: 12. Januar 2019, 15:42:56 »
Dann würde ich mal systematisch den Fehler eingrenzen:
1. LVM weglassen
2. Nur /home verschlüsseln

Und dann weitertesten.

Offline sanyam

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Deepin
  • Grafikkartentreiber: free
  • Prozessor: 4.14.0-1-MANJARO
  • Skill: Durchschnitt
  • Zweig: stable
Re: Verschlüsselte Installation nicht möglich
« Antwort #2 am: 12. Januar 2019, 18:15:39 »
Theoretisch ein sinnvolles Vorgehen, aber mein Bestreben ist ja die Installation mit LVM.

Wenn ich LVM weglasse und die Installation erfolgreich ist, gewinne ich ja keine Information darüber warum es nicht geklappt hat.

Oder was erwartest du von den zwei Tests? Eventuell denke ich da nicht weit genug.

Offline Keruskerfuerst

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 131
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Nvidia GTX 970
  • Kernel: stable LTS
  • Prozessor: Intel Core I 7 5820 K
  • Skill: Anfänger
  • Zweig: stable
Re: Verschlüsselte Installation nicht möglich
« Antwort #3 am: 13. Januar 2019, 15:41:16 »
1. Es ist gar nicht nötig, das ganze System zu verschlüsseln.
    Kostet nur viel Geschwindigkeit.
    Ich würde nur die home Partition verschlüsseln.   

2. Vielleicht liegt es an der Kombination von LVM und Verschlüsselung.
    Eines weglassen und dann mal testen.
    Eben LVM.

Offline sanyam

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: Deepin
  • Grafikkartentreiber: free
  • Prozessor: 4.14.0-1-MANJARO
  • Skill: Durchschnitt
  • Zweig: stable
Re: Verschlüsselte Installation nicht möglich
« Antwort #4 am: 13. Januar 2019, 19:08:44 »
1. Es ist gar nicht nötig, das ganze System zu verschlüsseln.
    Kostet nur viel Geschwindigkeit.
    Ich würde nur die home Partition verschlüsseln.   

Das halte ich für eine sehr pauschale und zudem noch falsche Aussage. Aber wie im Eingangspost erwähnt möchte ich keine Verschlüsselungsdiskussion starten, sondern das Problem lösen.

2. Vielleicht liegt es an der Kombination von LVM und Verschlüsselung.
    Eines weglassen und dann mal testen.
    Eben LVM.

LVM und Luks ist ein doch eher bekanntes Schema welches ich selbst auch Jahre im Einsatz hatte, daher denke ich dass das reine Zusammenspiel diesbezüglich kein Problem darstellen sollte, außer vielleicht unter Manjaro...

In meinen Tests habe ich jetzt einfach mal auf Grub verzichtet und den systemd-Bootloader getestet. Die Installation lief erfolgreich ab.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1475
  • Dankeschön: 283 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Verschlüsselte Installation nicht möglich
« Antwort #5 am: 13. Januar 2019, 22:39:21 »
Hallo sanyam,
LVM und Luks ist ein doch eher bekanntes Schema welches ich selbst auch Jahre im Einsatz hatte, daher denke ich dass das reine Zusammenspiel diesbezüglich kein Problem darstellen sollte, außer vielleicht unter Manjaro...
Das sollte auch unter Manjaro auch funktionieren. Ich habe keine direkte Antwort, aber vielleicht probiere es nochmals nach diesem Tutorial
https://forum.manjaro.org/t/installation-lvm-on-luks-with-manjaro-architect/42396

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung