Autor Thema: Error : invalid Enviroment block  (Gelesen 152 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 158
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Error : invalid Enviroment block
« am: 31. Januar 2019, 20:56:56 »
Hallo!
Ich wollte einen älteren Laptop ( Altec Lansing ) von 2 Hd´s mit Win 7 auf 1xSSD im 2.ten Einbaufach, mit Manjaro 18 umstellen.
Leider bekomme ich beim booten immer die Fehlermeldung "Error : invalid Enviroment block".

Die SSD hat nur eine Partition.

Wie bekomme ich das ganze zum laufen ?

MfG R.Lehmeier

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Error : invalid Enviroment block
« Antwort #1 am: 01. Februar 2019, 05:41:55 »
Klemm mal die alten HDD's ab und versuch es dann mit der SSD.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 158
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: Error : invalid Enviroment block
« Antwort #2 am: 01. Februar 2019, 13:52:19 »
Klemm mal die alten HDD's ab und versuch es dann mit der SSD.

Linu74

Da habe ich mich wohl mißverständlich ausgedrückt.
Es ist bereits die SSD, in das 2. HDD-Fach, eingebaut und das Manjaro aufgespielt.
Beim starten  der Live-DVD, zur Installation, mußte ich ein nolapic als Bootparameter eingeben damit es startet.

Ich hoffe das ich es bald zum laufen bekomme

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error : invalid Enviroment block
« Antwort #3 am: 01. Februar 2019, 15:15:04 »
Hallo R.Lehmeier,
lösch die fehlerhafte Datei /boot/grub/grubenv einfach. Linux sollte auch ohne sie hochfahren (ich verstehe dich doch richtig, daß Du nur noch Linux auf deinem Rechner hast? )
Wenn nicht kannst Du auch mit einem Live-System und chroot eine neue grubenv anlegen
sudo grub-editenv - createdas Leerzeichen vor und nach dem Minus - beachten!
Den Befehl kannst Du auch absetzen, wenn Du, wie von mir erwartet, ganz normal ohne grubenv booten kannst.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 158
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: Error : invalid Enviroment block
« Antwort #4 am: 02. Februar 2019, 12:53:52 »
Hallo R.Lehmeier,
lösch die fehlerhafte Datei /boot/grub/grubenv einfach. Linux sollte auch ohne sie hochfahren (ich verstehe dich doch richtig, daß Du nur noch Linux auf deinem Rechner hast? )
Wenn nicht kannst Du auch mit einem Live-System und chroot eine neue grubenv anlegen
sudo grub-editenv - createdas Leerzeichen vor und nach dem Minus - beachten!
Den Befehl kannst Du auch absetzen, wenn Du, wie von mir erwartet, ganz normal ohne grubenv booten kannst.

Ich bekomme es nicht hin.

Erst habe ich Manjaro noch einmal neuinstalliert - mit GPT.
Danach habe ich mit der Live-DVD, MC nachinstalliert und auf die SSD zugegriffen.
Mit MC habe ich die grubenv gelöscht und dann im Verzeichnis /run/media/manjaro/ wirre Zeichen /boot/grub den Befehl sudo grub-editenv - create ausgeführt. Leider ohne Ergebnis.
Es wird keine grubenv neu angelegt. Egal ob ich, nach dem löschen der grubenv den Befehl ausführe oder nicht

Es wird immer noch error: file "`/boot/gub/grubenv'   Press any key to continue..." angezeigt.
Leider passiert auch nichts wenn ich irgend eine Taste drücke. Ausser das der Lüfter lauter wird.

Alles sehr seltsam.

Offline Lehmeier

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 158
  • Desktop: KDE
  • Prozessor: 2.5 GHZ Dual Core
  • Skill: Anfänger
  • Zweig: Stable
Re: Error : invalid Enviroment block
« Antwort #5 am: 02. Februar 2019, 15:33:00 »
So ich habe weiterrecherchiert und etwas gefunden.

Zuerst habe ich sudo rm /run/media/manjaro/ wirre Zeichen /boot/grub/grubenv gemacht um die Datei zu löschen und danach sudo grub-editenv /run/media/manjaro/ wirre Zeichen /boot/grub/grubenv create um sie neu anzulegen.

Jetzt starte er zwar ohne Fehlermeldung, bleibt aber schwarz.