Autor Thema: Grub Fehlermeldung nach Vollverschlüsselung mit LUKS/dmcrypt  (Gelesen 207 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline tuxnix

  • Neuling
  • *
  • Beiträge: 1
  • Desktop: XFCE
  • Skill: Anfänger
  • Zweig: stable
Hallo liebe Manjaro-Gemeinde!

Bitte helft mir bei meinem Problem.

Ich würde gerne Manjaro vollverschlüsselt auf meinem Asus Laptop installieren, aber bekomme immer nach der Installation beim Hochfahren von Grub
eine Fehlermeldung:

GRUB loading...
Welcome to GRUB!
Attempting to decrypt master key...
Enter passphrase for hd0,msdos2 (13497b3a5bbc45dbbc042828e4b28946):
error: access denied.
error: no such cryptodisk found.
disk ´cryptouuid/13497b3a5bbc45dbbc042828e4b28946´ not found.
Entering rescue mode...
grub rescue> _

Ich habe dutzende verschiedene Anleitungen gelesen und befolgt und komme trotzdem auf den gleichen Fehler.
Einmal... ich glaube sogar beim ersten mal hatte es noch geklappt, nur ich musste die ziemlich lange Passphrase am Anfang zweimal eingeben
um das System zu entschlüsseln und da dachte ich noch "probiere es einfach nochmal, vielleicht hast du ein Fehler bei der Installation
gemacht".

Inzwischen bin ich beim 12. oder 13. Versuch... mit unterschiedlichen Anleitungen und immer die gleiche Meldung von GRUB!

Ich bin Linux-Anfänger und hatte vor ein paar Wochen beschlossen von Win zu Linux zu wechseln und habe mich durch die Distributionen gekämpft
und mich trotz aller Anfängerängste für ein Rolling-Release entschieden und weil mir der Installer von Antergos mit der Option verschlüsselt
auch eine extra /home Patition mit einem Klick anzulegen u.s.w. sehr begeistert hat, bin ich erstmal dort gelandet.
Installer ausgefürt = alles Prima, System lief verschlüsselt wie geschnitten Brot!
Das System lief jetzt auch eine ganze Zeit ohne Beanstandungen... bis auf ein Update und da Antergos nicht mehr weiterbesteht, war es
mit der Fehleranalyse nicht weit hin. Ins Arch-Forum braucht man mit Antergos-Fragen auch nicht kommen wenn man nicht erschlagen werden
will, also blieb nur die Distribution zu wechseln.

Mir gefällt Manjaro selbst auch ausgesprochen gut. "Nicht verschlüsselt" läuft die Installation und das System auf meinem älteren Laptop top!

Aber da ich den Laptop auf dem täglichen Weg zur Arbeit u.s.w. fast immer dabei habe, hätte ich gerne das System voll verschlüsselt.

Ich habe auch einige Tutorial im Netz und in diesem Forum gefunden, aber meist sind diese schon etwas älter, so dass für mich als
Manjaro-Anfänger nicht ganz klar ist wie man die Abweichungen die sich inzwischen ergeben weil es gewisse Installer nicht mehr gibt
und man bei den jetzigen z.B. die Einhängepunkte nicht in der gleichen Art und Weise angeben kann oder ich machen einen groben Fehler
der mir einfach nicht auffallen will, manchmal sieht man vor lauter Bäumen den Wald nicht.

 
Bei dieser Anleitung:
https://mywiki.bluelupo.net/wiki/Vollverschl%C3%BCsseltes_System_mit_LUKS/dmcrypt_und_LVM_unter_Manjaro_aufsetzen
...bekomme ich die Einhängepunkte nicht wie beschrieben in den aktuellen Installe, da es den Thus Installer nicht mehr gibt.

Zitat
Nun kann wie gewöhnlich die Installation über den Manjaro Installer Thus gestartet werden. Nachfolgende Partitionen mit Einhängepunkt und
FS-Typ (ext4) angeben:

    Rootpartition /dev/VGsys/LVroot
    Bootpartition /dev/sda1
    Homepartition /dev/VGsys/LVhome
    Homepartition /dev/VGsys/LVvar

(Ich bekomme es so nicht 1zu1 in den Installer eingetragen so dass er es übernimmt.)


Bei der Anleitung:
https://de.manjaro.org/index.php?topic=301.0
... sind ab Punkt "11. Konfigurationsdateien ergänzen" ... kommt bei mir Meldungen ala "schon vorhanden" oder so.

Am wenigsten Abweichungen habe ich bei folgender Anleitung gefunden:
https://www.youtube.com/watch?v=4VkYDWP9SHk

Wie gesagt einmal hat es geklappt, nur da musste die Passphrase 2x eingegeben werden bei Grub (vielleicht lag es daran, dass
noch Strukturen von Antergos vorhanden waren?

So jetzt zu meinem augenscheinlichen Problem:


Ich habe folgenden Laptop:
Intel® Pentium® Dual Core Processor T4200 : 2.0 GHz FSB 800MHz, 1M L2 Cache
Integrated Intel® GMA X4500M
Intel Graphics Media Accelerator (GMA) 4500M
Up to 320GB, 5400rpm
BIOS Booting / HDD User Password Protection
BIOS Version 218 2010/07/22

(Ich weiß ein altes Mörchen, aber für meinen Einsatz mehr als ausreichend!)

Egal nach welcher Anleitung ich installiere, während der Installation gibt es keine Fehlermeldung,
aber der Grub meckert mit folgenden Meldungen:
GRUB loading...
Welcome to GRUB!
Attempting to decrypt master key...
Enter passphrase for hd0,msdos2 (13497b3a5bbc45dbbc042828e4b28946):
error: access denied.
error: no such cryptodisk found.
disk ´cryptouuid/13497b3a5bbc45dbbc042828e4b28946´ not found.
Entering rescue mode...
grub rescue> _

So wo ist jetzt der von mir gemachte Fehler ?
Was verträgt sich da nicht, habe ich mein Bios vielleicht mit gezeigten UEFI-, MFB-, GPT-, GRUB-, SED-, LUKS-Anleitungen
falsch angepackt ?

In den Tutorials/Anleitungen die meist auf UEFI und nicht mehr auf BIOS abziehlen steht dann:
Zitat
Alle modernen Mainboards und Betriebssysteme unterstützen UEFI. Daher gibt es absolut keinen Grund
das Betriebssystem im BIOS-Modus (welcher vom Compatibility Support Module des UEFIs emuliert wird) zu installieren.

Also gibt es in der Installation einen mir nicht bekannten Unterschied... ?

Ich habe es so vorbereitet:
Partitionen anlegen -> cfdisk -> eine 512MB große Boot-Partition und eine zweite Partition, die den restlichen Festplattenplatz einnimmt,
anschließend verschlüsselt werden soll und danach mittels LVM partitioniert wird.

/dev/sda1 512MB primary boot
/dev/sda2 restl. Speicherplatz primary

Zitat
Achtung: bei alten System mit BIOS und MBR muss eine separate /boot-Partition angelegt werden,
welche nicht verschlüsselt werden darf.


Gibt es irgendwo eine aktuelle Anleitung für BIOS-Rechner, oder ist mein System mit leichten Korrekturen
am GRUB zu vervollständigen ?

Die von mir gezeigte GRUB-Fehlermeldung findet man zwar häufig über die Suche im Internet, aber der Fehler ist meist bei einer anderen
Art und Weise der Installation und auf anderen "moderneren" Rechnern ohne BIOS aufgetreten.
Diese Lösungen jetzt blind zu kopieren halte ich für falsch.

Über hilfreiche Antworten aus der Manjaro-Gemeinde würde ich mich sehr freuen, denn es muss doch möglich sein
Manjaro auch auf meinem älteren Laptop vollverschlüsselt zum laufen zu bekommen.

Dank und freundliche Grüße

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1642
  • Dankeschön: 314 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Grub Fehlermeldung nach Vollverschlüsselung mit LUKS/dmcrypt
« Antwort #1 am: 20. Juni 2019, 21:24:57 »
Hallo tuxnix,
jetzt bin ich aber doch etwas vergnatzt  >:D Ich schreibe mir da die Finger blutig ;)
https://www.manjaro-forum.de/viewtopic.php?f=11&t=2237
und sehe jetzt, es hätte gut sein können, daß hier jemand schon längst eine tolle Lösung gepostet hat.
Also bitte, wenn schon Doppelposting, dann schreibe wenigstens dazu, daß und wo Du dein Problem noch veröffentlicht hast.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: tuxnix