Autor Thema: SoundCloud via Firefox nur links Soundwiedergabe, Rest normal  (Gelesen 54 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Kevin Xyndrac

  • Neuling
  • *
  • Beiträge: 2
    • Xyndrac, Blog
  • Desktop: Xfce
  • Grafikkarte: Vega 64 (Sapphire)
  • Grafikkartentreiber: free
  • Kernel: 4.19.45-1
  • Prozessor: Ryzen 2700X
  • Skill: Anfänger
  • Zweig: stable
Moin ihr Lieben!

Habe da ein ganz ulkiges Phänomen, für das ich weder eine Ursachenforschung noch Lösung finden konnte. Wenn ich über Firefox SoundCloud öffne, höre ich Musik nur links aus der 5.1 Anlage. Selbes Problem bei Discord im Browser. Jedoch Youtube, Vimeo etc funktionieren unter Firefox wie gewünscht. Ebenso alle anderen Programme außerhalb von Firefox geben den Sound korrekt aus. Ein Versuch mit Chromium zeigt, dass das Problem dort dann nicht mehr auftaucht. Es taucht eben nur bei FF auf und das bringt mich zum grübeln, was es sein könnte.

Via PulsAudio sind auch Chromium wie auch Firefox identisch eingestellt bzgl Ausgabegerät. Achja, als Ausgabegerät dient eine Soundblaster Omni USB Station.

Ich konnte jetzt natürlich einfach auf Firefox verzichten, möchte das aber möglichst nicht. Ideen?

Beste Grüße!

P. S. Schreibe via mobil. Kann also mit antworten dauern.

Offline Kevin Xyndrac

  • Neuling
  • *
  • Beiträge: 2
    • Xyndrac, Blog
  • Desktop: Xfce
  • Grafikkarte: Vega 64 (Sapphire)
  • Grafikkartentreiber: free
  • Kernel: 4.19.45-1
  • Prozessor: Ryzen 2700X
  • Skill: Anfänger
  • Zweig: stable
Re: SoundCloud via Firefox nur links Soundwiedergabe, Rest normal
« Antwort #1 am: 14. Juni 2019, 12:19:57 »
Update:

Habe alles was ich an Reste bzgl. Firefox finden konnte, händisch gelöscht. Dies hatte keine Abhilfe gebracht. Ebenso der Umweg der Audioausgabe via PulseEffects dann weiter zum Ausgabegerät brachte keinerlei Abhilfe.

In PulseEffects ist mir jedoch zumindest aufgefallen, das Firefox sich mit 6 Kanälen zur Audioausgabe meldet, während Chrome (welches einwandfrei funktioniert unter allen Bedingungen) mit 2 Ausgabekanäle meldet - somit Stereo, was für Internetgewurschtel nicht weiter wild ist. Leider habe ich in der about:config von Firefox nichts gefunden, wo sich händisch die Ausgabe korrigieren lassen Bis auf "media.forcestereo.enabled" welches regulär "false" ist und auch mit Änderung auf "true" keinerlei Korrektur brachte.

Falls also wer irgendeine Idee hat, sei es auch nur zum Zwecke der Nachforschung, immer her damit. Ich mag einfach auf Firefox nicht verzichten, doch wenn der Browser (im Gegensatz zum System, zu Chrome, zu Spielen) bei Soundcloud und Discord nur "links-seitig" ausgibt und bei YouTube alles normal ist, ist das kein Surferlebnis. (-:

Beste Grüße!

/nachtrag: Workaround aber keine Lösung gefunden: https://bugzilla.mozilla.org/show_bug.cgi?id=1435598
« Letzte Änderung: 14. Juni 2019, 12:24:56 von Kevin Xyndrac »