Autor Thema: Manjaro startet nicht mehr nach Update und Grub Customizer Fehlermeldung  (Gelesen 130 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline TaCtiCal

  • Neuling
  • *
  • Beiträge: 2
  • Skill: Anfänger
Hallo,

habe ein Problem bei dem ich nicht weiter komme... Wenn ich im falschen Bereich gepostet habe oder die Ausgaben zu unübersichtlich dargestellt habe bitte ich um Nachsicht.

Bin Anfänger was Manjaro angeht und sehr davon angetan. Deshalb habe ich die letzten 2 Woochen damit verbracht das Betriebssystem auf meinem PC zu installieren und zu konfigurieren. (wäre schade wenn ich von vorne anfangen müsste)

Doch seit ich gestern ein Update von einigen Programmen gamacht habe denke ich das ich mir mit dem Grub Customizer den Bootloder zerschossen habe....

Muss dazu ergänzen das alles nach dem ersten Reboot noch funkionierte, und ich dann in einem Anflug von Optiemierungswahn den Grub Customizer benutzen wollte um das Bootmenü nach meinen Wünschen zu optimieren.

Es kam im Programm direkt eine Fehlermeldung, das nicht installiert bzw gespeicher werden kann.

Seitdem komme ich nicht mehr ins Bootmenü von Manjaro rein. Es ist immer ein blinkender curser zu sehen aber nichts geht weiter.

Die Konfiguration von meinem PC ist wie folgt:


NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
│                                                                     
└─vera
     vfat                                        1,7G    44% /mnt/verac
sda                                                                   
├─sda1
│    ntfs   System
│                                        71,5M    28% /run/media
├─sda2
│    ntfs   Sys
│                                       142,2G    29% /run/media
└─sda3
     ntfs   B
                                         29,6G    10% /run/media
sdb                                                                   
└─sdb1
     ntfs   D 01D25C1195B17480                      528,9G    24% /run/media
sdc                                                                   
├─sdc1
│    ext4         c7178bd2-c963    3,5G     4% /run/media
├─sdc2
│    swap         eac95809-1a8c               
├─sdc3
│    crypto       0f7c5041-acc0               
│ └─luks-0f7c5041-acc0
│    ext4         afab03fb-ad80   34,6G    22% /run/media
└─sdc4
     crypto       57a2daff-9e74               
  └─luks-57a2daff-9e74-44e5
     ext4         89a3ad1f-c86e   44,1G    13% /run/media
sdd                                                                   
├─sdd1
│                                                                     
└─sdd5
     ntfs   D
                  E21                       283G     5% /run/media
sde                                                                   
├─sde1
│    crypto       46c6ea85               
│ └─luks-46c6ea85
│    ext4         671e7874    9,2G    47% /
└─sde2
     crypto       26f3f20a8               
  └─luks-26f3f208
     swap         c0da50c9


Habe auf der ersten Festplatte Windows drauf. Zweite und Vierte sind Daten HDD's. Die Dritte ist die Festplatte mit Manjaro drauf.

sudo sudo fdisk -lu

Gerät         Anfang      Ende  Sektoren Größe Typ
/dev/sdc1       2048   8390655   8388608    4G Linux-Dateisystem
/dev/sdc2    8390656  16779263   8388608    4G Linux Swap
/dev/sdc3   16779264 119179263 102400000 48,8G Linux-Dateisystem
/dev/sdc4  119179264 234436511 115257248   55G Linux-Dateisystem

Die Root und die Home Partition sind mit luks verschlüsselt. Boot ist auf sdc1.

Mit einem Usb Stick auf dem ich auch Manjaro für unterwegs fest insalliert habe kann ich auf die Partitionen zugreifen. Aber ich bekomme es seit Stunden nicht hin Grub nochmal neu auf Sdc1 zu installieren.

Die Tips von der Seite ( https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader#For_UEFI_Systems ) habe ich mehrfach versucht....


Möchte ich Grub als Bios Variante installieren bekomme ich folgendes raus:

[manjaro@manjaro-pc ~]$ sudo grub-install /run/media/manjaro/c7178bd2-c963-4ff9-8eea-23df9269fb43
i386-pc wird für Ihre Plattform installiert.
grub-install: Fehler: »/run/media/manjaro/c7178bd2-c963-4ff9-8eea-23df9269fb43« ist nicht lesbar: Ist ein Verzeichnis

Wenn ich das ganze als UEFI System versuche kommt das dabei raus:

[manjaro@manjaro-pc ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/run/media/manjaro/c7178bd2-c963-4ff9-8eea-23df9269fb43 --bootloader-id=manjaro --recheck
[sudo] Passwort für manjaro:
x86_64-efi wird für Ihre Plattform installiert.
grub-install: Fehler: /run/media/manjaro/c7178bd2-c963-4ff9-8eea-23df9269fb43 scheint keine EFI-Partition zu sein.

Ich habe keine Ahnung was ich noch machen kann... Vielleicht weiss ja jemand im Forum was ich noch versuchen könnte...

Im worst case, wie sichere ich die ganzen Daten und Einstellungen? Habe ja wie gesagt über das Live medium zugriff...

Grüße TaCtiCal



Offline TaCtiCal

  • Neuling
  • *
  • Beiträge: 2
  • Skill: Anfänger
Hallo, kann jemand das Thema schliessen?

Habe nachdem ich jetzt tagelang alles möglich versucht habe herausgefunden das schon bei der Installation was schief gegangen ist... Hab alles neu installiert diesmal penibel darauf geachtet welche mit welchen Formaten ich die Partitonen formatiere und jetzt sollte alles funktionieren...

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2071
  • Dankeschön: 155 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Du kannst selber das Thema als gelöst markieren. Ganz unten links.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de