Autor Thema: Bildschirm sperren per STRG+ALT+Entf geht nicht mehr  (Gelesen 207 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kisun

  • Neuling
  • *
  • Beiträge: 46
  • Dankeschön: 6 mal
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 5.2.8-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Bildschirm sperren per STRG+ALT+Entf geht nicht mehr
« am: 23. August 2019, 21:55:55 »
Hallo seit dem letzten großen Update lässt sich der Rechner nicht mehr per STRG+ALT+Entf sperren.

Laut Einstellung wird  bei besagtem Tastendruck die Datei "/usr/bin/xflock4" ausgeführt. Wenn ich das Skript vom Terminal aus starte passiert auch nix. Kein sperren des Bildschirms noch irgend eine Ausgabe.

xflock4 sieht bei mir wie folgt aus: #!/bin/sh
#
#  xfce4
#
#  Copyright (C) 1999, 2003 Olivier Fourdan (fourdan@xfce.org)
#  Copyright (C) 2011       Guido Berhoerster (guido+xfce.org@berhoerster.name)
#  Copyright (C) 2011       Jarno Suni (8@iki.fi)
#
#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.
#
#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.
#
#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#

# First test for the command set in the session's xfconf channel
LOCK_CMD=$(xfconf-query -c xfce4-session -p /general/LockCommand)

# Lock by xscreensaver or gnome-screensaver, if a respective daemon is running
for lock_cmd in \
    "$LOCK_CMD" \
    "xfce4-screensaver-command --lock" \
    "xscreensaver-command -lock" \
    "gnome-screensaver-command --lock"
do
    if [ ! -z "$lock_cmd" ]; then
        $lock_cmd >/dev/null 2>&1 && exit
    fi
done

# else run another access locking utility, if installed
for lock_cmd in \
  "xlock -mode blank" \
  "slock"
  do
    set -- $lock_cmd
    if command -v -- $1 >/dev/null 2>&1; then
        $lock_cmd >/dev/null 2>&1 &
# turn off display backlight:
xset dpms force off
        exit
    fi
done

# else access locking failed
exit 1

Hat jemand das selbe verhalten oder eine Idee woran das liegen könnte?

Liebe Grüße

Kisun

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1592
  • Dankeschön: 310 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Bildschirm sperren per STRG+ALT+Entf geht nicht mehr
« Antwort #1 am: 23. August 2019, 23:18:09 »
Hallo kisun,
daß /usr/bin/xflock4 nicht viel sagt ist normal, weil ja alles mit >/dev/null 2>&1 ins digitale Nirvana geschickt wird. Es gibt aber noch den Exit-Code, deshalb kontrolliere mal direkt nach der Eingabe von /usr/bin/xflock4 den Exit-Code. Etwas klarer, mach mal das:
xflock4
echo $?
Da muss eine Null ausgegeben werden, alles andere ist ein Fehler.
Die Ausgabe von
echo $(xfconf-query -c xfce4-session -p /general/LockCommand)ist auch interessant.

viele Grüße gosia

"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline kisun

  • Neuling
  • *
  • Beiträge: 46
  • Dankeschön: 6 mal
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 5.2.8-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: Bildschirm sperren per STRG+ALT+Entf geht nicht mehr
« Antwort #2 am: 24. August 2019, 21:20:25 »
Danke für die schnelle Antwort.

Also der Exit-Code ist 1. Ergo klappt da was nicht.

Bei "echo $(xfconf-query -c xfce4-session -p /general/LockCommand)" gibt es keine Ausgabe.

xfconf-query -c xfce4-session -p /general/LockCommand
... aus dem Skript gibt auch nichts zurück wenn man es im Terminal ausführt. Kann da schon der Fehler liegen?

« Letzte Änderung: 24. August 2019, 21:27:48 von kisun »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1592
  • Dankeschön: 310 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Bildschirm sperren per STRG+ALT+Entf geht nicht mehr
« Antwort #3 am: 24. August 2019, 23:35:21 »
Hallo kisun,
Also der Exit-Code ist 1. Ergo klappt da was nicht.
Bei "echo $(xfconf-query -c xfce4-session -p /general/LockCommand)" gibt es keine Ausgabe.
Das ist schlecht. Sieh mal nach, ob wenigstens eins dieser Pakete installiert ist
xfce4-screensaver
xscreensaver
gnome-screensaver
wenn nicht, eins davon nachinstallieren, vorzugsweise xfce4-screensaver. Anschliessend mit
xfce4-screensaver-command --lockprobieren, ob es funktioniert.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: kisun

Offline kisun

  • Neuling
  • *
  • Beiträge: 46
  • Dankeschön: 6 mal
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 5.2.8-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: Bildschirm sperren per STRG+ALT+Entf geht nicht mehr
« Antwort #4 am: 25. August 2019, 13:43:32 »
Ok, das installieren von xgce4-screensaver hat geholfen. Ist bloß seltsam das es auf einmal nicht mehr ging.

Danke dir für deine Hilfe gosia.  ;)