Autor Thema: Upgrade von aur/gcc7 + aur/gcc7-libs -> Error  (Gelesen 87 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline fl1tzEr

  • Neuling
  • *
  • Beiträge: 13
  • Desktop: Gnome 3.30.1
  • Grafikkarte: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • Grafikkartentreiber: i915 v: kernel
  • Kernel: 4.19.2-1
  • Prozessor: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
  • Skill: Anfänger
  • Zweig: stable
Upgrade von aur/gcc7 + aur/gcc7-libs -> Error
« am: 17. November 2019, 00:37:49 »
Hallo u guten Abend,
bislang hatte ich keine Probleme mit Updates. - Nun das erste Mal.
Folgendes Update wird angeboten. Hängt sich aber beim Update über die Softwareverwaltung auf:

aur/gcc7      7.4.1+20181207-5 -> 7.5.0-1
aur/gcc7-libs 7.4.1+20181207-5 -> 7.5.0-1

Dann habe ich es an der Konsole versucht:

[~]$ yaourt -Syua
[sudo] Passwort für fl1tz:
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
  perl-cddb : Verwaist
  qwtplot3d : Verwaist
 Fremde Pakete:\ 39 / 39

==> Softwareaktualiserung (neue Version):
aur/gcc7      7.4.1+20181207-5 -> 7.5.0-1
aur/gcc7-libs 7.4.1+20181207-5 -> 7.5.0-1

==> Upgrade fortsetzen? [J/n]
==> [P]aketdetails anzeigen [M]anuell Pakete auswählen
==> --------------------------------------------------
==> j

==> Lade PKGBUILD von gcc7 aus dem AUR herunter...
x .SRCINFO
x PKGBUILD
x bz84080.patch
n3rv commented on <a href="#comment-710036" class="date">2019-10-01 09:41</a>

dviktor commented on <a href="#comment-712813" class="date">2019-10-21 21:41</a>

dviktor commented on <a href="#comment-716527" class="date">2019-11-16 00:53</a>

0strodamus commented on <a href="#comment-716539" class="date">2019-11-16 02:54</a>

dviktor commented on <a href="#comment-716567" class="date">2019-11-16 10:01</a>

gcc7 7.5.0-1  (2019-11-16 00:20)
(Nicht unterstütztes Paket: Potenziell gefährlich!)
==> PKGBUILD bearbeiten? [J/n] („A“ zum Abbrechen)
==> ----------------------------------------------

An der Stelle, wo es "potentiell gefährlich" wird, bin ich dann ausgestiegen.
Empfiehlt es sich, an dieser Stelle tatsächlich PKGBUILD zu bearbeiten? Müsste ich mich reinlesen.
Ich bin mir auch nicht sicher, welche Programme die neuen Pakete brauchen.
Mein System lief bislang rund.

Jede Hilfe ist willkommen!
« Letzte Änderung: 17. November 2019, 00:39:38 von fl1tzEr »
Lenovo W530

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1262
  • Dankeschön: 194 mal
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma, Deepin
  • Grafikkarte: NVIDIA [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Intel/Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 4.19.y LTS, 4.14.y LTS,
  • Prozessor: Notebook: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
  • Skill: Fortgeschritten
  • Zweig: Stable 18.n.y on PowerWorkStation, NB, HTPC, Desktop:s: Testing or Unstable only VM
Re: Upgrade von aur/gcc7 + aur/gcc7-libs -> Error
« Antwort #1 am: 17. November 2019, 09:51:09 »
Die Packages deinstallieren
aur/gcc7      7.4.1+20181207-5 -> 7.5.0-1
aur/gcc7-libs 7.4.1+20181207-5 -> 7.5.0-1

diese Packages (Manjaro) installieren (derzeit Standard)
gcc8  8.3.0-3
gcc8-libs  8.3.0-3
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme
Folgende Mitglieder bedankten sich: fl1tzEr

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2138
  • Dankeschön: 160 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Upgrade von aur/gcc7 + aur/gcc7-libs -> Error
« Antwort #2 am: 17. November 2019, 10:49:18 »
yaourt sollte auch nicht mehr genutzt werden. Lieber auf trizen oder einen  anderen AUR Helper umsteigen.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden
Folgende Mitglieder bedankten sich: fl1tzEr

Offline fl1tzEr

  • Neuling
  • *
  • Beiträge: 13
  • Desktop: Gnome 3.30.1
  • Grafikkarte: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • Grafikkartentreiber: i915 v: kernel
  • Kernel: 4.19.2-1
  • Prozessor: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Upgrade von aur/gcc7 + aur/gcc7-libs -> Error
« Antwort #3 am: 17. November 2019, 11:24:46 »
Vielen Dank für die schnellen Antworten.
@SpiritOfTux 
Die Pakete sind bei mir bereits installiert  :o:

Zitat
gcc8  8.3.0-3
gcc8-libs  8.3.0-3

Ich habe diese deinstalliert:

Zitat
gcc7 7.4.1
gcc7-libs 7.4.1

@Linu74
Den Hinweis auf yaourt habe ich aus der Manjaro Pamac Anleitung. Hab ich während meiner Fehlersuche extra installiert. Ist dann wohl nicht mehr up to date?   

« Letzte Änderung: 17. November 2019, 11:30:01 von fl1tzEr »
Lenovo W530

Offline fl1tzEr

  • Neuling
  • *
  • Beiträge: 13
  • Desktop: Gnome 3.30.1
  • Grafikkarte: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
  • Grafikkartentreiber: i915 v: kernel
  • Kernel: 4.19.2-1
  • Prozessor: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Upgrade von aur/gcc7 + aur/gcc7-libs -> Error
« Antwort #4 am: 17. November 2019, 11:52:10 »
@Linu74
Über die AUR Helper habe ich das https://forum.manjaro.org/t/yaourt-is-dead/50527/10gefunden.

Vielen Dank. Das System läuft wieder rund.  ;)
Lenovo W530