Autor Thema: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)  (Gelesen 16839 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline xotox83

  • Neuling
  • *
  • Beiträge: 12
Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« am: 05. Juli 2013, 09:30:32 »
Hallo zusammen,

ich habe mir jetzt durch mehrere Wikis gekämpft aber bislang keine Lösung gefunden. Ich habe ein Notebook im Dual-Boot mit Win7. Im BIOS wird die Uhrzeit korrekt angezeigt. In Windows ebenso. Nach der Installation von Manjaro ist diese in inux konsequent +2 Stunden. In der ntp.conf habe ich die Server schon auf de umgestellt. Date zeigt dann auch die korrekt Uhrzeit an, nachdem ich ntpd -qg asugeführt habe:[chris@chris-nb ~]$ date
Fr 5. Jul 09:16:13 CEST 2013
hwlock zeigt aber weiterhinchris@chris-nb ~]$ hwclock
Fr 05 Jul 2013 11:14:10 CEST  -0.094440 Sekunden
Wenn ich dann hwclock -w verwende, wird im Bios und in Windows die Uhrzeit -2 Stunden falsch angezeigt. In Manjaro stimmt sie dann wiederum -.-

Kann es sein, dass Manjaro nicht die korrekte Systemzeit auslesen kann bzw. hat jemand von euch eine Idee, wie man diese permanent korrigiert ohne,
dass ein zweites OS "darunter leidet"? Unter Mint, Ubuntu etc. hatte ich das Problem allerdings nicht.

Frage wäre auch, ob es eine Lösung gibt, für eine korrekte Uhrzeit ohne Synchronisation durch NTP, wenn mal keine Netzwerk-/ Inet-Verbindung besteht.


Vielen Dank vorab :)

Chris
Manjaro / XFCE / x86_64 auf MSI GT70 + Desktop PC

Offline Gumpelino

  • Jr. Mitglied
  • **
  • Beiträge: 90
  • Desktop: xfce + KDE
  • Grafikkarte: nVidia GT 640
  • Grafikkartentreiber: nvidia
  • Kernel: 3.11_64bit (XFCE_stable) 3.11_64bit (KDE_unstable)
  • Prozessor: AMD 6 core "Bulldozer"
  • Zweig: stable + unstable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #1 am: 05. Juli 2013, 10:02:20 »
Hallo,
Das Ubuntu/Mint-XFCE ist sozusagen nicht "rein" XFCE, Clem/Mint bedient sich soviel ich weiß der mate-system-tools. Wer auch in Manjaro sein "Day and Time" in den Settings möchte, kann $ yaourt -S gnome-system-tools installieren. Ich hab's getestet. Läuft.

Offline xotox83

  • Neuling
  • *
  • Beiträge: 12
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #2 am: 05. Juli 2013, 10:08:00 »
Hallo,
Das Ubuntu/Mint-XFCE ist sozusagen nicht "rein" XFCE, Clem/Mint bedient sich soviel ich weiß der mate-system-tools. Wer auch in Manjaro sein "Day and Time" in den Settings möchte, kann $ yaourt -S gnome-system-tools installieren. Ich hab's getestet. Läuft.
Moin Gumpelino,

das werde ich gleich mal testen. Vielen Dank :)
Manjaro / XFCE / x86_64 auf MSI GT70 + Desktop PC

Offline xotox83

  • Neuling
  • *
  • Beiträge: 12
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #3 am: 05. Juli 2013, 12:50:38 »
Ich kann zwar jetzt in XFCE via Tool die Uhr in der GUI einstellen, behebt aber dennoch leider nicht das Problem, dass Manjaro nicht die BIOS Uhrzeit erkennt. hwclock gibt immernoch +2 Std. aus.
Manjaro / XFCE / x86_64 auf MSI GT70 + Desktop PC

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2178
  • Dankeschön: 164 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 5.4x
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #4 am: 05. Juli 2013, 13:24:36 »
Falls du immer wieder zwischen durch Windows startest, dann klappt das auch nicht mit dem einstellen der Uhr im BIOS. Windows stellt die immer wieder um.

Eigentlich muß man die Uhr im BIOS auf UTC einstellen, dann klappt das auch unter Manjaro.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden

Offline Gumpelino

  • Jr. Mitglied
  • **
  • Beiträge: 90
  • Desktop: xfce + KDE
  • Grafikkarte: nVidia GT 640
  • Grafikkartentreiber: nvidia
  • Kernel: 3.11_64bit (XFCE_stable) 3.11_64bit (KDE_unstable)
  • Prozessor: AMD 6 core "Bulldozer"
  • Zweig: stable + unstable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #5 am: 05. Juli 2013, 14:40:20 »
Ich kann zwar jetzt in XFCE via Tool die Uhr in der GUI einstellen, behebt aber dennoch leider nicht das Problem, dass Manjaro nicht die BIOS Uhrzeit erkennt. hwclock gibt immernoch +2 Std. aus.

Seltsam. Richtige Zeitzone eingestellt? UTC ausgewählt und dann local über Zeitzone eingestellt? Windows ist übrigens das einzige BS, das an local time festhält, deshalb gibt's manchmal Probleme mit allen anderen.  Welche Zeit zeigt denn das BIOS an? Die Uhrzeit sollte Europa/Sommerzeit -2 Stunden sein. Also jetzt 12.38.

Dieser kleine Eintrag bringt Windows das 21. Jahrhundert (= UTC) bei:

reg.exe add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1 /f

Oder Linux auf local time setzen:
(in Debian bearbeitet man /etc/default/rcS). Keine Ahnung, wo das in Manjaro gemacht wird, brauchte ich hier nicht.
# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.
UTC=no

Viel Glück!

Offline xotox83

  • Neuling
  • *
  • Beiträge: 12
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #6 am: 05. Juli 2013, 14:59:21 »
Seltsam. Richtige Zeitzone eingestellt? UTC ausgewählt und dann local über Zeitzone eingestellt? Windows ist übrigens das einzige BS, das an local time festhält, deshalb gibt's manchmal Probleme mit allen anderen.  Welche Zeit zeigt denn das BIOS an? Die Uhrzeit sollte Europa/Sommerzeit -2 Stunden sein. Also jetzt 12.38.

Dieser kleine Eintrag bringt Windows das 21. Jahrhundert (= UTC) bei:

reg.exe add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1 /f

Oder Linux auf local time setzen:
(in Debian bearbeitet man /etc/default/rcS). Keine Ahnung, wo das in Manjaro gemacht wird, brauchte ich hier nicht.
# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.
UTC=no

Viel Glück!

Vielen Dank. Der Reg-Eintrag hat's gerade gezogen. Vielen Vielen Dank.
Manjaro / XFCE / x86_64 auf MSI GT70 + Desktop PC

Offline ossi38

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: xfce 4
  • Grafikkarte: ATI -HD5450
  • Grafikkartentreiber: free = radeon
  • Kernel: linux 3.18
  • Prozessor: AMD Sempron 3300+
  • Skill: Anfänger
  • Zweig: stable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #7 am: 05. Juli 2013, 19:31:04 »
Hallo 'xotox83',

ich habe auch schon mehrfach mit der Systemzeit gekämpft. - Nach meinen Erfahrungen kommen die Zeitverschiebungen in Linux-Systemen aus der > /etc/adjtime !
Ich habe selbst an WIN-XP und WIN-7 nichts verstellt, dafür aber die  /etc/adjtime entweder gelöscht oder mit folgenden Werten berichtigt:

[ossi@wd_el ~]$ cat /etc/adjtime
0.0 0 0.0
0
LOCAL

Dann dürfte es weder Im Bios noch beim WIN Zeitverschiebungen geben!



Offline xotox83

  • Neuling
  • *
  • Beiträge: 12
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #8 am: 06. Juli 2013, 06:13:41 »
Hallo 'xotox83',

ich habe auch schon mehrfach mit der Systemzeit gekämpft. - Nach meinen Erfahrungen kommen die Zeitverschiebungen in Linux-Systemen aus der > /etc/adjtime !
Ich habe selbst an WIN-XP und WIN-7 nichts verstellt, dafür aber die  /etc/adjtime entweder gelöscht oder mit folgenden Werten berichtigt:

[ossi@wd_el ~]$ cat /etc/adjtime
0.0 0 0.0
0
LOCAL

Dann dürfte es weder Im Bios noch beim WIN Zeitverschiebungen geben!

Hi ossi,

Danke für den Vorschlag. Ich habe ja noch einen Desktop PC mit Dual-Boot, bei dem ich es noch nicht korrigiert habe. Kann ich gerne mal testen :)
Manjaro / XFCE / x86_64 auf MSI GT70 + Desktop PC

Offline eskaini

  • Security Team
  • *
  • Beiträge: 499
  • Skill: Anfänger
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #9 am: 21. Juli 2013, 10:44:28 »
Hallo,
da ich das selbe Problem hatte, habe ich  eure Vorschläge hier alle ausprobiert. Gestern abend.
Hat leider nichts davon geklappt  und heute  ging die ManjaroUhr wieder zwei Stunden vor.
IM BIOS (AMI) habe ich keine Option  für UTC
Nun bin ich nach diesem Artikel aus dem WIKIvorgegangen.
Nun habe ich die korrekte Uhrzeit. Ich brauchte nicht mal die Session neu starten.

Gruß Dio

Offline Ocsej

  • Held Mitglied
  • *****
  • Beiträge: 580
  • Dankeschön: 2 mal
  • Ocsej
  • Desktop: Openbox /-Laptop Openbox
  • Grafikkarte: Desktoprechner nVidia Geforce 8500 GT / Laptop ATI Mobility RADEON HD 3470
  • Grafikkartentreiber: Desktop Rechner nVidia-free / Laptop ATI-free
  • Kernel: 4.1.6-1-ARCH /-64bit
  • Prozessor: Desktop Rechner (HP) AMD 5600 / Laptop Acer Aspire 5530G QL60 1,9GHz
  • Skill: Durchschnitt
  • Zweig: ARCH /-Stable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #10 am: 21. Juli 2013, 14:50:54 »
Ich habe es bei meinem Desktop Rechner, der hatte immer schon Probleme bei " Rollenden Betriebssystemen "gentoo/(Sabayon) " mit der automatischen Zeit Einstellung (abgleich ntp) mit  diesem Befehl hin bekommen.

Dauert zwar ein bisschen bis sich die Zeit aktualisiert  aber es geht gut, habe es beim "Deutschen Arch/wiki" gefunden.

# systemctl enable ntpd

Arch/wiki link in Deutsch da ich nicht so gut Englisch kann.

https://wiki.archlinux.de/title/Anleitung_f%C3%BCr_Einsteiger#Die_Hardware-Uhr_.C3.BCberpr.C3.BCfen

Ocsej
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

ARCH /-64bit installiert.

Ocsej

Offline Eric Zettler

  • Neuling
  • *
  • Beiträge: 23
  • Dankeschön: 1 mal
  • Desktop: XFCE
  • Grafikkarte: keine
  • Kernel: 4.19.13
  • Prozessor: Intel(R) Core(TM) i3-2370M CPU @ 2.40GHz
  • Skill: Durchschnitt
  • Zweig: Stable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #11 am: 23. Juli 2013, 22:31:33 »
Da dieses Problem bei jeder XFCE-Installation auftritt, habe ich die für mich einzig gängige Lösung hier gefunden:
http://wiki.manjaro.org/index.php/Using_Manjaro_for_Beginners

Dort etwas nach unten scrollen und den Abschnitt "Setting Your System's Time" Kommando für Kommando abarbeiten.
Die Uhrzeit ist nicht sofort korrekt, auch nicht nach Abmeldung und wieder Anmeldung.

Aber innerhalb einer halben Stunde stimmt die Uhrzeit dann.
Und vor allem, es gibt keine Nebenwirkungen auf das noch an Bord befindliche W7 oder W8.

Offline eskaini

  • Security Team
  • *
  • Beiträge: 499
  • Skill: Anfänger
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #12 am: 24. Juli 2013, 09:30:00 »
...
Die Uhrzeit ist nicht sofort korrekt, auch nicht nach Abmeldung und wieder Anmeldung.

Aber innerhalb einer halben Stunde stimmt die Uhrzeit dann.
Und vor allem, es gibt keine Nebenwirkungen auf das noch an Bord befindliche W7 oder W8.
Damit hatte ich auch Erfolg,
aber bei mir  wurde  die anzeige direkt  korrigiert, da hatte ich wohl richtig Glück,  jedenfalls kann ich den Artikel   aus dem Wiki auch  empfehlen.

Gruß Dio

Offline marcarth

  • Neuling
  • *
  • Beiträge: 21
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #13 am: 07. August 2013, 01:42:23 »
Hallo zusammen,

irgendwie hab ich jetzt beim durchlesen eurer Posts immer noch nicht verstanden, warum manjaro da jetzt die Probleme verursacht. Also ich hab die selben Probleme bei meinem manjaro (XFCE) und nachdem ich nun auch NTP aktiviert habe, ist bei meinen anderen installierten Linuxen (Mageia und Ubuntu) alles durcheinander gekommen. Notgedrungen hab ich auch da jeweils NTP aktiviert, aber irgendwie bin ich mal zwei Stunden zu früh und mal zwei Stunden zu spät dran. Als Zeitreisender Doctor würd ich meine helle Freude haben, aber ich begreife nicht, warum manjaro da alles durcheinander bringt. Bei meinem Bios gibt es nur eine Einstellmöglichkeit der Zeit, also kein UTC oder sonstwas.


Gruss
marcarth

Offline Ocsej

  • Held Mitglied
  • *****
  • Beiträge: 580
  • Dankeschön: 2 mal
  • Ocsej
  • Desktop: Openbox /-Laptop Openbox
  • Grafikkarte: Desktoprechner nVidia Geforce 8500 GT / Laptop ATI Mobility RADEON HD 3470
  • Grafikkartentreiber: Desktop Rechner nVidia-free / Laptop ATI-free
  • Kernel: 4.1.6-1-ARCH /-64bit
  • Prozessor: Desktop Rechner (HP) AMD 5600 / Laptop Acer Aspire 5530G QL60 1,9GHz
  • Skill: Durchschnitt
  • Zweig: ARCH /-Stable
Re: Systemuhrzeit wird nicht korrekt erkannt (+2 Std.)
« Antwort #14 am: 07. August 2013, 16:49:20 »
Da ist Manjaro nicht die einzige Rollende/Distribution wo ich da immer Probleme hatte.
Gentoo/Sabayone Ist auch eine Rollende/Distribution zum beispiel da war das genauso,
Da musste ich immer per Hand nacharbeiten die Uhrzeit/Datum, obwohl NTP installiert war/ist.
Was noch verblüffender ist, ich muss es nur bei meinem Desktop Rechner machen, da denke ich das die BIOS Batterie leer ist.
Aber mir dem Befehl von Arch " systemctl enable ntpd " habe ich das dann hin bekommen.
Jetzt wird die Uhrzeit/Datum immer ein paar Minuten nach dem Start aktualisiert.

Ocsej



 
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

ARCH /-64bit installiert.

Ocsej