Autor Thema: Systemaktualisierung schlägt fehl  (Gelesen 635 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline ottone

  • Neuling
  • *
  • Beiträge: 35
  • Karma: +0/-0
  • Desktop: Gnome
  • Grafikkarte: Intel on Board
  • Grafikkartentreiber: free
  • Kernel: 5.1
  • Skill: Anfänger
  • Zweig: stable
Systemaktualisierung schlägt fehl
« am: 01. Januar 2020, 18:22:53 »
Hallo, wollte gerade mit sudo pacman -Syyu eine Systemaktualisierung machen, doch diese schlägt leider fehl. Die Fehlermeldungen stellen mich leider vor ein Rätsel, ich weiß nicht, was ich tun soll. Vielleicht könnte mir einer von euch aufgrund seiner Erfahrung auf die Sprünge helfen?

So sehen die Meldungen im Terminal aus:
:: Starte vollständige Systemaktualisierung...
Warnung: fontconfig: Lokale Version (2:2.13.1+12+g5f5ec56-2) ist neuer als extra (2:2.13.1+12+g5f5ec56-1)
:: pygobject2-devel durch extra/python2-gobject2 ersetzen? [J/n] j
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
:: python-pyqt5 und pyqt5-common stehen miteinander in Konflikt. pyqt5-common entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation von protobuf (3.11.1-2) verletzt Abhängigkeit 'protobuf=3.10.0', benötigt von python2-protobuf

Danach bricht die Systemaktualisierung ab. Ich habe auch schon versucht, bei den beiden Abfragen "nein" zu wählen, doch das hilft leider auch nicht. Muss ich hier vielleicht etwas neu installieren? Ich wäre dankbar für jeden Hinweis!

Offline quantix

  • Held Mitglied
  • *****
  • Beiträge: 530
  • Dankeschön: 78 mal
  • Karma: +0/-0
  • Desktop: Xfce + fish
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: nonfree
  • Kernel: 5.6
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #1 am: 01. Januar 2020, 18:46:35 »
Versuchs bei beiden mit j.
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Acer Spin 1, Raspberry Pi 2

Offline ottone

  • Neuling
  • *
  • Beiträge: 35
  • Karma: +0/-0
  • Desktop: Gnome
  • Grafikkarte: Intel on Board
  • Grafikkartentreiber: free
  • Kernel: 5.1
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #2 am: 01. Januar 2020, 19:28:25 »
Versuchs bei beiden mit j.
Das habe ich ja - siehe Code mit entsprechender Fehlermeldung oben.

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 34
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Desktop: xfce
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.18
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #3 am: 03. Januar 2020, 05:58:14 »
Hallo Ottone,
versuch mal 'pyqt5-common' mit
sudo pacman -Rss pyqt5-commonzu deinstallieren und dann nochmal das Update zu starten.
Gruß

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 948
  • Dankeschön: 53 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #4 am: 03. Januar 2020, 21:10:38 »
Hallo Ottone,
versuch mal 'pyqt5-common' mit
sudo pacman -Rss pyqt5-commonzu deinstallieren und dann nochmal das Update zu starten.
Gruß
Hi KunSepp,

ich denke du meinst
sudo pacman -Rdd pyqt5-common
und danach nochmal ein
sudo pacman -Syu
Gruß
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 34
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Desktop: xfce
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.18
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #5 am: 04. Januar 2020, 06:24:18 »
Zitat
Hi KunSepp,

ich denke du meinst
Code: [Auswählen]

sudo pacman -Rdd pyqt5-common


und danach nochmal ein
Code: [Auswählen]

sudo pacman -Syu


Gruß
Ahnungsloser

Hallo Ahnungsloser,

ich meinte schon
sudo pacman -Rss pyqt5-common
und wenn das nicht funktioniert, dann wie du es schreibst
sudo pacman -Rdd pyqt5-common
Zitat
pacman -Rdd <Paket>    Deinstallation eines Paketes ohne Prüfung bestehender Paketabhängigkeiten. Vorsicht, hierdurch kann die Konsistenz und Funktionstüchtigkeit der  Systeminstallation beeinträchtigt werden!
pacman -Rss <Paket>    Paket mit allen benötigten Abhängigkeiten und deren Abhängigkeiten entfernen

Gruß
KunSepp

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 948
  • Dankeschön: 53 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #6 am: 04. Januar 2020, 16:59:19 »
Hallo KunSepp,

auf der Seite von Artix, also Arch Linux/Manjaro ohne systemd, wird der Fehler bzw. das Problem mit diesem Befehl behoben.

During pacman update when you hit this message:

looking for conflicting packages...
:: python-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-pyqt5 and pyqt5-common are in conflict

when updating, use:
pacman -Rdd pyqt5-common && pacman -Syu
to perform the upgrade.

https://artixlinux.org/

Wenn dein Vorschlag auch funktioniert, umso besser  :)

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline ottone

  • Neuling
  • *
  • Beiträge: 35
  • Karma: +0/-0
  • Desktop: Gnome
  • Grafikkarte: Intel on Board
  • Grafikkartentreiber: free
  • Kernel: 5.1
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #7 am: 04. Januar 2020, 22:14:13 »
Danke für eure Hilfe, aber ich glaube mein System ist gerade ziemlich im Eimer. Liegt sehr wahrscheinlich daran, dass ich händisch 0 Byte-Dateien entfernt habe, die mit pacman-mirrors zu tun hatten. Seitdem kriege ich keine Systemaktualisierung mehr richtig hin.

Aber der Reihe nach. Ich habe es versucht mit:
pacman -Rdd pyqt5-common && pacman -Syu
Der erste Teil der Befehlskette hat funktioniert, der zweite Teil scheiterte an meinen Updateproblemen, ich konnte also nicht updaten.
Trotzdem kommt es immer noch zur Fehlermeldung:

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation von protobuf (3.11.1-2) verletzt Abhängigkeit 'protobuf=3.10.0', benötigt von python2-protobuf

Also muss ich wahrscheinlich erstmal python2-protobuf inkl. Abhängigkeiten runterschmeißen, damit ich die neue Version von protobuf überhaupt installieren kann, richtig?

Mein Aktualisierungsversuch endet hiermit:

sudo pacman -Syu
:: Synchronisiere Paketdatenbanken...
Fehler: Konnte Datei 'core.db' nicht von mirrors.sjtug.sjtu.edu.cn übertragen : Connection timed out after 10001 milliseconds
 core ist aktuell
Fehler: Konnte Datei 'extra.db' nicht von mirrors.sjtug.sjtu.edu.cn übertragen : Connection timed out after 10001 milliseconds
 extra ist aktuell
Fehler: Konnte Datei 'community.db' nicht von mirrors.sjtug.sjtu.edu.cn übertragen : Connection timed out after 10001 milliseconds
 community ist aktuell
Fehler: Konnte Datei 'multilib.db' nicht von mirrors.sjtug.sjtu.edu.cn übertragen : Connection timed out after 10000 milliseconds
 multilib ist aktuell

Und pacman-mirrors gibt mir eine ganz komische Fehlermeldung aus:

pacman-mirrors
Traceback (most recent call last):
  File "/usr/bin/pacman-mirrors", line 23, in <module>
    _ = i18n.language.gettext
AttributeError: module 'pacman_mirrors.translation.i18n' has no attribute 'language'
« Letzte Änderung: 04. Januar 2020, 22:15:49 von ottone »

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 948
  • Dankeschön: 53 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #8 am: 04. Januar 2020, 22:54:14 »
Der erste Teil der Befehlskette hat funktioniert, der zweite Teil scheiterte an meinen Updateproblemen, ich konnte also nicht updaten.
Trotzdem kommt es immer noch zur Fehlermeldung:

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation von protobuf (3.11.1-2) verletzt Abhängigkeit 'protobuf=3.10.0', benötigt von python2-protobuf

Also ich würde mit

sudo pacman -Rdd protobuf
das Abhängigkeitsproblem beheben.

Dann noch mal

sudo pacman -Syu
Im neuen Forum unter dem Nick "Roberto" :)
Folgende Mitglieder bedankten sich: ottone

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 948
  • Dankeschön: 53 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #9 am: 04. Januar 2020, 23:11:18 »
Vielleicht kann dir diese Seite bei deinem pacman-mirrors Problem helfen:

https://wiki.manjaro.org/Pacman-mirrors
Im neuen Forum unter dem Nick "Roberto" :)
Folgende Mitglieder bedankten sich: ottone

Offline ottone

  • Neuling
  • *
  • Beiträge: 35
  • Karma: +0/-0
  • Desktop: Gnome
  • Grafikkarte: Intel on Board
  • Grafikkartentreiber: free
  • Kernel: 5.1
  • Skill: Anfänger
  • Zweig: stable
Re: Systemaktualisierung schlägt fehl
« Antwort #10 am: 05. Januar 2020, 21:47:28 »
Danke an alle, die mir hier geholfen haben. Ich habe mein Problem lösen und mein System updaten können. Ich habe dieses "protobuf" deinstalliert inkl. aller Abhängigkeiten. Als ich manuell einen anderen Spiegelserver eingestellt habe, konnte ich auch alle Updates installieren und die haben offenbar auch die anderen komischen Fehlermeldungen bereinigt. Ich bin echt froh. Danke noch mal, ich stelle dann hier mal auf gelöst um.  :)