Autor Thema: Icons fehlen nach Update  (Gelesen 1833 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Icons fehlen nach Update
« am: 23. März 2014, 16:20:57 »
Hallo Gemeinde,
eben zeigte mir Pamac ein größeres Update (ca. 400 MB) an, u.a. Linux-Kernel 3.10.33, diverse Softwareupdates etc.
Seitdem fehlen mir in mehreren Anwendungen (z.B. Rhythmbox, Dokumentenbetrachter) die Icons.
Sieht sehr merkwürdig aus, wie ihr auf dem Screenshot sehen könnt.

Hat jemand eine Idee, wie ich wieder an die Icons komme?

Danke!
Bankman
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Icons fehlen nach Update
« Antwort #1 am: 23. März 2014, 17:29:13 »
Hallo mozon,

Zitat
Schon mal Neustart gemacht .... wäre meine erste Reaktion
war auch meine erste Idee.
Leider ohne Erfolg.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Icons fehlen nach Update
« Antwort #2 am: 23. März 2014, 18:02:43 »
Hallo Bankman,

und wenn du einfach mal ein neues Thema wählst, damit der Dateimanager gezwungen ist, eine Veränderung vorzunehmen?

Vielleicht kannst du danach die Einstellung wieder auf dein gewohntes Erscheinungsbild zurücksetzen.

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Icons fehlen nach Update
« Antwort #3 am: 23. März 2014, 18:42:41 »
@Hubsi_Gberg: habe ich eben mal ausprobiert, leider ohne Erfolg.
Habe auch mal probiert, z.B. evince erst zu deinstallieren und dann nochmal neu zu installieren, leider auch ohne Erfolg.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Icons fehlen nach Update
« Antwort #4 am: 23. März 2014, 21:19:34 »
Wie sieht denn das Bild aus unter Einstellungen, Erscheinungsbild, Symbole?

Ist da in dem Fenster irgendwo ein ! in nem Dreieck?

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Icons fehlen nach Update
« Antwort #5 am: 24. März 2014, 07:28:51 »
@Linu74: ja, das Dreieck mit dem "!" war da, und zwar neben allen Symboltypen, außer "Gnome".
Zitat
Warnung: Dieses Symbolthema ist nichjt zwischengespeichert. Sie können die Zwischenspeicherdatei erzeugen, indem Sie gtk-update-icon-cache /usr/share/icons/Faenza-Green in einem Terminalemulator audführen.
Habe auch versucht, den Hinweis zu befolgen aber das hat auch nichts gebracht.
Weil ich neben diesem Problem auch das Problem mit den langen Bootzeiten hatte, habe ich mal schnell mein System neu aufgesetzt.
Ergebnis: alle Icons sind wieder da (auch wenn die vorgenannten Dreiecke) auch noch da sind... und das Booten geht gefühlt wieder etwas schneller, wenn auch noch nicht optimal.

Für mich ist das Problem gelöst, wenn auch nicht auf die eleganteste Weise.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline balu

  • Neuling
  • *
  • Beiträge: 28
  • Desktop: xfce
  • Grafikkarte: Intel 2nd Generation Core Processor Family
  • Grafikkartentreiber: free
  • Kernel: 4.1.15-1 MANJARO x86_64
  • Prozessor: Intel i5-2450M
  • Skill: Anfänger
  • Zweig: stable
Re: Icons fehlen nach Update
« Antwort #6 am: 24. März 2014, 09:26:13 »
@Linu74: ja, das Dreieck mit dem "!" war da, und zwar neben allen Symboltypen, außer "Gnome". Habe auch versucht, den Hinweis zu befolgen aber das hat auch nichts gebracht.
Weil ich neben diesem Problem auch das Problem mit den langen Bootzeiten hatte, habe ich mal schnell mein System neu aufgesetzt.
Ergebnis: alle Icons sind wieder da (auch wenn die vorgenannten Dreiecke) auch noch da sind... und das Booten geht gefühlt wieder etwas schneller, wenn auch noch nicht optimal.

Für mich ist das Problem gelöst, wenn auch nicht auf die eleganteste Weise.

hallo @all,

hatte das auch schon mal und habe einfach befolgt was dort im Tooltipp angegeben wird. Im Terminal zu jedem Theme wo ein solches Dreieck mit Ausrufezeichen angezeigt wird den entsprechenden Befehl eingeben.

gtk-update-icon-cache /usr/share/icons/Faenza-Green
gtk-update-icon-cache /usr/share/icons/Faenza-Dark
usw. für alle Symbole wo so per gelbem Dreieck angezeigt werden.

Aber man muss die Schreibweise genau einhalten wie im jeweiligen Tooltipp zu den Symbolen angeben: faenza-green wird bei mir als Fehler ausgewiesen!!!

seitdem gibt es keine Dreiecke mehr mit Ausrufezeichen bei mir:

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Icons fehlen nach Update
« Antwort #7 am: 24. März 2014, 21:49:27 »
Man soll einfach das Paket librsvg Reinstallieren, danach ein Reboot und die Icons dürften wieder da sein.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de