Autor Thema: Schreibzugriff auf NTFS Festplatte nicht möglich  (Gelesen 1346 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Schreibzugriff auf NTFS Festplatte nicht möglich
« am: 20. Februar 2020, 14:15:00 »
Hallo, bin ganz neu hier und auch im Umgang mit Linux. Komme aus der Windows-Welt, die mich langsam richtig nervt. Dort kenne ich mich technisch sehr gut aus. Schritt für Schritt für Schritt möchte ich gerne auf Linux Manjaro (KDE) umverlagern, nachdem ich mich nach langer langer Evaluierung für diese Distribution entschieden habe. Ein Wald, der im ersten Schritt für einen Neuling schon kaum durchdringbar ist.

Hier nun meine erste, für mich wichtige Frage:
- Habe mehrere größere Laufwerke / Partionen: eine für Windows (NTFS), eine für Linux (beide auf SSD) und eine für meine Daten (NTFS-Format, normale Festplatte). Beide sind sie in meinem Notebook integriert. Ich kann im Dateimanager auch auf die "Daten" Partition im NTFS Format zugreifen, aber ich kann NICHT darauf schreiben, z.B. einen neuen Ordner erstellen. Ich möchte nämlich alle meine persönlichen Daten, auch die von Thunderbird auf das Laufwerk Daten legen. So kann ich von Windows und von Linux auf die gleichen Daten zugreifen.

Was muss ich genau für Befehlscodes oder sonstige wo genau eingeben, um das Problem zu lösen?
Bitte als Antwort eine Idiotensichere Anleitung mit allen Befehlen / Schritten.

Ganz lieben Dank.
Rulinux


PS: Es war bereits ein hoher Aufwand, auf meinem Windows-Rechner überhaupt Linux installieren zu können. Durch die Standard-Verschlüsselung mit bitlocker unter Win 10 Pro kann man die Festplatten nicht partionieren. Ich konnte es schließlich lösen. Soll ich hierzu für Neulinge auch einen Beitrag zur Überwindung dieser Klippe aus meinen Erfahrungen schreiben? Wenn ja, wohin?

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2312
  • Dankeschön: 181 mal
  • Karma: +0/-0
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 5.6x
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #1 am: 20. Februar 2020, 14:22:04 »
Hallo und herzlich Willkommen.

Schau mal hier https://wiki.archlinux.de/title/Schreibzugriff_mit_ntfs-3g

Zu deinem PS: dies kannst du natürlich in der Kategorie Tutorials gerne schreiben.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden
Folgende Mitglieder bedankten sich: Rulinux

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #2 am: 22. Februar 2020, 12:00:04 »
Danke Dir. Habe gemäß Anleitung ntfs-3g installiert und die Daten zu fuse
"fuse
modul2
modul3"

in der modules.conf hinterlegt.
Komischerweise geht das, aber ich kann auch keinen Ordner unter /mnt anlegen, z.B. der Ordner /mnt/windows ist nicht möglich. Analog wie bei der NTFS Festplatte.

Ich kann dennoch die Partition (Daten, sda2) nicht mit Schreibrechten mounten:
Weder
mount -t ntfs-3g /dev/sda2 /mnt/windows -o locale=de_DE.utf8
noch
mount -t ntfs-3g /dev/sda2 /mnt -o locale=de_DE.utf8
funktionieren.

Ist sda2 eingehängt, so erscheint die Fehlermeldung:
Mount is denied because NTFS is already exl. opened
oder, wenn ich die Daten Festpatte vorher aushänge, dann erscheint
Unprivileged user cannot mount NTFS block device

Aber ich habe mir als User im Benutzerkonto auch Admininstrationsrechte zugewiesen. Ebenso nutze ich kein Passwort weder als User noch gleichzeitig auch als Admin.
der Befehl su zum Wechsel auf root funktioniert nicht, da angeblich Passwort falsch, obwohl ich gar keines vergeben habe. Bei der Installation von ntfs-3g wurde auch das PW abgefragt und die Installation funktionierte einwandrei.

2. Würde ich dann gerne auch die Daten Festplatte für alle User zum Schreiben freigeben, aber durch das "Linux-Latein" im weiterführenden Link steige ich nicht mehr durch.

Danke für Eure Hilfe

Rulinux

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1860
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #3 am: 22. Februar 2020, 14:20:12 »
Hallo Rulinux,
als Ergänzung der Hinweis auf diesen etwas aktuelleren Artikel
https://wiki.archlinux.org/index.php/NTFS-3G
weil z.B. die Option -t ntfs-3g schon lange nicht mehr angegeben werden muss. Kannst Du machen, ist aber überflüssig.
und damit auch User schreiben können, empfiehlt sich ein Eintrag in der /etc/fstab
/dev/NTFS-partition  /mnt/windows  ntfs-3g   uid=userid,gid=groupid,umask=0022    0       0natürlich entsprechend angepasst (/dev/NTFS-partition, userid und groupid)
https://wiki.archlinux.org/index.php/NTFS-3G#Allowing_group/user
Aber eigentlich ist das ganze Gesumse nicht notwendig (kommt natürlich drauf an, was Du vorhast). Im Prinzip reicht es aus, wenn ntfs-3g installiert ist und Du in der Gruppe fuse bist und eine entsprechende udev-Regel existiert (was IMHO automatisch der Fall ist). Dann sollte die NTFS-Partition in deinem Dateimanager auftauchen und durch Anklicken wird sie lesend und schreibend nach /run/media/USERNAME/MEDIANAME eingehangen.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #4 am: 05. Mai 2020, 00:35:46 »
Hallo Gosia,

habe Deinen Vorschlag zur Einbindung der Festplatte
Zitat
/dev/NTFS-partition  /mnt/windows  ntfs-3g   uid=userid,gid=groupid,umask=0022    0       0
wie folgt angepasst. (Nutze nach notwendiger Neuinstallation jetzt XFCE Desktop)
/dev/sda2                         /run/media/omlinux/Daten                        ntfs-3g defaults    0       1
Obwohl die Schlösser im Dateimanager jetzt weg sind, lassen sich keine Dokumente darauf erstellen. Irgendwie stimmt etwas mit den Schreibrechten nicht.

/mnt/windows nimmt er gar nicht an.

Brauche ich die Variante mit uid und gid? Wenn ja, woher bekomme ich die beiden Daten?
Auch habe ich <pass> auf 1 gesetzt. So wurde es in den Anleitungen empfohlen, die Du mir geschickt hast. Ist das ok?
Sollte ich das <file system> statt mit /dev/sda2 lieber mit einer UUID bezeichnen? Doch wie bekommt man diese heraus? Mit "blkid" ins Terminal eingegeben habe ich gar nichts gefunden.

Danke, Rulinux

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1860
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #5 am: 05. Mai 2020, 15:58:49 »
Hallo Rulinux,
/mnt/windows nimmt er gar nicht an.
Naja, das war ja auch nur ein Beispiel. Es muss schon ein existierendes Verzeichnis sein, sonst geht das nicht.
Brauche ich die Variante mit uid und gid? Wenn ja, woher bekomme ich die beiden Daten?
Ist für die Rechte schon nützlich. Gib im Terminal
idein, dann hast Du u.a. die nötigen Nummern.
Auch habe ich <pass> auf 1 gesetzt. So wurde es in den Anleitungen empfohlen, die Du mir geschickt hast.
An welcher Stelle? Hat mit den Rechten nichts zu tun, sondern gibt nur an, ob und in welcher Reihenfolge das Dateisystem geprüft werden soll. 1 solltest Du für ein NTFS nicht nehmen, meistens hat man da eine Null = nicht prüfen.
Sollte ich das <file system> statt mit /dev/sda2 lieber mit einer UUID bezeichnen? Doch wie bekommt man diese heraus? Mit "blkid" ins Terminal eingegeben habe ich gar nichts gefunden.
Naja, das wird empfohlen, wenn es mit dem mounten gar nicht funktionieren will. Kannst Du also machen, wenn Du möchtest. Sollte keinen Unterschied ergeben. blkid musst Du mit sudo aufrufen, dann liefert es dir auch die UUIDs.
sudo blkid
viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #6 am: 05. Mai 2020, 16:18:38 »
Danke Dir Gosia,

aber ich verstehe noch nicht, wo mein Fehler liegt. Vermutlich, weil ich noch zu frisch in Linux bin.
Ich habe diesen Code in fstab eingefügt
/dev/sda2                         /run/media/omlinux/Daten                        ntfs-3g defaults    0       0und anschließend sudo mount -a im Terminal laufen lassen.
Das File System und der Mount point sollten stimmen - siehe Screenshot gemäß Anlage.
Was ist denn an dieser Zeile falsch?

Danke von Rulinux.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1860
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #7 am: 05. Mai 2020, 16:36:20 »
Hallo Rulinux,
/dev/sda2                         /run/media/omlinux/Daten                        ntfs-3g defaults    0       0Was ist denn an dieser Zeile falsch?
direkt falsch ist da nichts. Nur statt default sollte da
uid=userid,gid=groupidstehen.
Also bei dir sehr wahrscheinlich
/dev/sda2   /run/media/omlinux/Daten   ntfs-3g uid=1000,gid=1000    0    0siehe
id
viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #8 am: 05. Mai 2020, 18:33:28 »
Vielen Dank, Gosia!

Warum genau so und nicht anders, ist mir manchmal schleierhaft. Aber jetzt funktioniert es endlich :)

Würde mich freuen, wenn Du bezeiten auf ein sehr ähnliches Thema von mir einen Blick wirfst: NAS-Server einbinden:
https://de.manjaro.org/index.php?topic=9777.0

Herzlichst.

Rulinux

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #9 am: 06. Mai 2020, 22:49:28 »
Hallo Gosia,

das letzte Mal hat es endlich geklappt, nachdem ich Einstellung von Dir:
/dev/sda2   /run/media/omlinux/Daten   ntfs-3g uid=1000,gid=1000    0    0gesetzt habe. Ich hatte das alternativ mit der UUID gesetzt. Und es funktionierte.

Heute habe ich Linux wieder gestartet und habe wieder keinen Zugriff mehr auf die Festplatte Daten. Es ist so wie vorher, obwohl die Daten in fstab gemäß oben stimmen. Siehe hierzu die Bilder des normalen Dateimanagers und von Dolphin. In jedem Fall hat man aber dennoch keinen Schreibzugriff auf die Festplatte. Das ist wirklich ein .....s!

Kann mir denn da keiner wirklich helfen?????

Viele Grüße, Rulinux


Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1860
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #10 am: 07. Mai 2020, 18:31:31 »
Hallo Rulinux,
keine Ahnung, was bei dir los ist. Erst funktioniert es, dann wieder nicht. Sehr seltsam. Und dann - ich hatte es ja schon mal gesagt - bei mir funktioniert das ohne irgendeinen Eintrag in der fstab. Dateimanager aufrufen, Dort die NTFS-FP anklicken, schon ist sie gemountet und kann auch beschrieben werden. Um sicherzugehen, daß ich damals, vor langer Zeit, nicht etwas eingerichtet habe, an das ich mich nicht mehr erinnere, habe ich das jetzt mal mit einem Manjaro-Live-System (Gnome) probiert. Geht genauso im Urzustand, ohne was zu basteln.
Merkwürdig ist aber auch, daß auf deinem Screenshot überall das richtige steht "Anzeige und Änderung des Inhalts möglich" und das bei allen Usern -> Eigentümer, Gruppe und Sonstige. Sollte also auch "schreiben" funktionieren.
Da dir das aber nicht weiterhilft, setze mal nach die umask-Option in deine fstab-Zeile, also so:
/dev/sda2   /run/media/omlinux/Daten   ntfs umask=000,uid=1000,gid=1000    0    0Wenn das dann nach einem Neustart immer noch nicht funktioniert, weiss ich auch nicht weiter.
Trotzdem poste dann mal die Ausgabe von
mount
ls -ld /run/media/omlinux/Daten
ls -l /run/media/omlinux/Daten
id

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #11 am: 10. Mai 2020, 15:14:21 »
Hallo Gosia,

endlich habe ich es wieder geschafft, mich um meinen Linux-Umstieg zu kümmern.

"Die Wege des Herrn sind unergründlich." Mehrmals hatte ich auch Linux zu meinem Problem gebootet. Nach dem Motto "Reboot ist immer gut". Aber alles ohne Erfolg. Genervt habe ich am nächsten Tag wieder mein altes Windows gestartet und ein anderes Mal wieder Linux. Dann war der Fehler mit den Festplatten unerklärlich weg. So etwas ähnliches hatte ich auch mit meinem KDE Desktop schon einmal. Es scheint, eine Kollision und Verwicklung mit Windows zu geben. Da hackt sich etwas mit Windows 10 Pro. Vieleicht sollte man das den Entwicklern zur Kenntnis geben.

Mir ist es wichtig, dass die Festplatte gleich beim Start gemountet ist, weil ich normal als erste auf Thunderbird zugreife und auch Dateien eher über "Suche" finde als über die Dateiverwaltung darauf zuzugreifen. Die Dateien liegen jedoch alle auf Daten bei mir.
Ich habe den Code fürs erste wie hier stehend gelassen, weil es damit funktioniert.
/dev/sda2                                        /run/media/omlinux/Daten       ntfs-3g uid=1000,gid=1000    0    0Das mit UUID (siehe oben) probiere ich nochmals bei Gelegenheit aus.
Was ist denn der Unterschied zum Type "ntfs" zu "ntfs-3g"?
Wozu braucht man denn den Befehl "gid=1000"?

Es wäre sicher eine Weitergabe an die Entwickler wert, dass man ein automatisches mounten beim Start (am besten wohl mit Autofs) deutlich vereinfacht. Sowohl für weitere Festplatten, NAS-Server (hier kämpfe ich immer noch) et cetera. Ich glaube das brauchen viele Umsteiger von Windows auf Linux und vermutlich auch so mancher Linuxianer.

In jedem Fall vielen Dank für Deine große Hilfe mal wieder sowie die Antwort auf obige Fragen. Du scheinst die Hauptstütze dieses freundlichen Forums zu sein. Für eine "gute" Linux-Edition ist es neben der technischen Reife des Systems sicher genauso wichtig, eine gute Community zu haben.

Herzliche Grüße & bis zum nächsten Thema.

Rulinux

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #12 am: 10. Mai 2020, 16:19:53 »
Zitat
Es wäre sicher eine Weitergabe an die Entwickler wert, dass man ein automatisches mounten beim Start (am besten wohl mit Autofs) deutlich vereinfacht. Sowohl für weitere Festplatten, NAS-Server (hier kämpfe ich immer noch) et cetera. Ich glaube das brauchen viele Umsteiger von Windows auf Linux und vermutlich auch so mancher Linuxianer.
Ergänzend zu meinem obigen Kommentar. So eine Einbindung / Automount von Festplatten, NAS, Devices etc. sollte einfach für den normalen User nicht nur über autofs sondern auch über fstab möglich sein, je nachdem, was besser ist. Aktuell bin ich ein Freund davon, wenn ich beim Starten, zumindest nach kurzer Zeit auf alles zugreifen kann, ohne manuelle Aktivierung. Das bedeutet vermutlich eher fstab.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1860
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #13 am: 10. Mai 2020, 22:30:12 »
Hallo Rulinux,
So eine Einbindung / Automount von Festplatten, NAS, Devices etc. sollte einfach für den normalen User nicht nur über autofs sondern auch über fstab möglich sein, je nachdem, was besser ist.
Naja, da kann ich mich nur wiederholen. Für meine externen USB-FP benutze ich weder autofs noch einen Eintrag in der fstab. Ich stöppsle die Dinger einfach ein wenn ich sie brauche, und schon sind sie da.
Was ist denn der Unterschied zum Type "ntfs" zu "ntfs-3g"?
Keiner. Du kannst auch nur ntfs schreiben. ntfs-3g stammt wohl noch aus älteren Zeiten, wahrscheinlich um zu betonen, daß man das Paket ntfs-3g braucht, um NTFS zu schreiben und zu lesen (meine Vermutung)
Wozu braucht man denn den Befehl "gid=1000"?
Sorry, da möchte ich etwas kleinlich sein, einfach weil für Anfragen die richtige Terminologie oft wichtig ist.  Das ist kein Befehl, sondern eine Option.
gid=1000bedeutet in dem Fall, daß die eingehängte Datei die Gruppen-ID 1000 erhält. Wenn Du
ideingibst, siehst Du, daß Du in der Gruppe 1000 bist (gid=1000)
Beim Schreiben merke ich, daß dir das wahrscheinlich nicht viel sagt, deshalb nur kurz:
In Linux gibt es bei den Zugriffsrechten drei Einordnungen: den Besitzer (user), die Gruppe (group) und alle anderen (other). Damit ich nicht noch ein ganzes Buch dazu schreiben muss, kannst Du dir ja das ansehen:
https://www.guru99.com/file-permissions.html
Es wäre sicher eine Weitergabe an die Entwickler wert, dass man ein automatisches mounten beim Start (am besten wohl mit Autofs) deutlich vereinfacht.
Da sage ich nur: s.o.

viele Grüße gosia

PS. Deine anderen Anfragen kommen auch noch dran, aber nicht mehr heute. Aber zum Glück gibt es ja noch viele andere User...
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Rulinux

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 96
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Schreibzugriff auf NTFS Festplatte nicht möglich
« Antwort #14 am: 11. Mai 2020, 20:02:18 »
Hallo Gosia,
heute habe ich Linux wieder gestartet. Der alte Fehler ist wieder aufgetreten.
Ich habe jetzt den Code in fstab so gesetzt, wie Du es mir zuletzt empfohlen hast.
/dev/sda2   /run/media/omlinux/Daten   ntfs umask=000,uid=1000,gid=1000    0    0und dannsudo mount -a ausgeführt.
Doch es hat nichts genützt. Die Festplatte ist wieder nicht mehr ordnungsgemäß beim normalen Dateimanager eingehängt.

Hier findest Du das Ergebnis zu
mount
ls -ld /run/media/omlinux/Daten
ls -l /run/media/omlinux/Daten
id
(gekürzt um die Verzeichnisse). Vielleicht können die Entwickler etwas damit anfangen. Viele Grüße, Rulinux
mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=12249980k,nr_inodes=3062495,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/nvme0n1p4 on / type ext4 (rw,noatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=17655)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
/dev/nvme0n1p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
/dev/sda2 on /run/media/omlinux/Daten type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=2451856k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
[USER@XXXXX-hpprobook450g5 ~]$ ls -ld /run/media/omlinux/Daten
drwxrwxrwx 1 omlinux omlinux 8192 10. Mai 14:43 /run/media/omlinux/Daten
[USER@XXXXX-hpprobook450g5 ~]$ ls -l /run/media/omlinux/Daten
insgesamt 136
drwxrwxrwx 1 USER USER     0 19. Okt 2019  '$RECYCLE.BIN'
drwxrwxrwx 1 USER USER  4096 22. Apr 18:27  Anwendungsdaten
drwxrwxrwx 1 USER USER  4096  9. Apr 16:15  Backups