Autor Thema: Installation Epson WF-2860  (Gelesen 679 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline charly700

  • Sr. Mitglied
  • ****
  • Beiträge: 289
  • Dankeschön: 5 mal
  • Desktop: XFCE
  • Grafikkarte: PC: NVIDIA GeForce 930M
  • Grafikkartentreiber: nonfree
  • Kernel: immer den Neuesten und einen LTS-Kernel
  • Prozessor: Core i5-6200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #15 am: 23. Februar 2020, 19:16:34 »
Hallo Roberto und stumax,Ich glaube, wir müssen hier eine Frage klären, die nur @stumax beantworten kann, IMHO ist die Installation per trizen auch bei stumax ohne Fehlermeldung durchgelaufen, oder?
Dann eine Bemerkung, die ich mir eigentlich aufsparen wollte, bis meine Anfragen bzgl, Cups beantwortet sind. Ganz zufällig habe ich auch einen Epson WF-2660, also ziemlich nahe am Drucker von stumax, obwohl das oft nicht viel bedeuten muss.
Aber ich habe weder epson-inkjet-printer-escpr2 noch epson-inkjet-printer-escp dafür installiert, sondern bin ganz anders vorgegangen.
Ich habe meinen Drucker von Cups suchen bzw. erkennen lassen (als Netzwerkdrucker). Da wurde er auch erkannt als "EPSON WF-2660 Series (driverless) (EPSON WF-2660 Series)". Das wichtige dabei ist das Wort "driverless". Da Cups das kann habe ich auch einfach auf "weiter" gedrückt und gut wars. Der Drucker erhielt die Verbindung " ipp://EPSON%20WF-2660%20Series._ipp._tcp.local/|EPSON WF-2660 Series" und druckt ohne Probleme. Braucht natürlich Avahi, aber das sollte per default laufen.

viele Grüße gosia

Ich habe einen anderen Epson, aber die driverless Treiber sind nicht die besten. Sie Funktionieren zwar aber haben nicht alle Einstellmöglichkeiten des Original Treibers und auch wenn man die Testseite Ausdruckt sieht man schon die Unterschiede. Und zwar bei Rahmen rund um die Testseite. Beim Originaltreiber sind diese überall ca. 5 mm und beim driverless nicht.

Zum Problem des TE kann ich leider auch nichts sagen da der Treiber sich einwandfrei nutzen lässt. Aber Cups nimmt beim automatischen Einrichten leider den driverless Treiber, obwohl der Originaltreiber installiert ist. Man muss diesen nachträglich im Druckereinstellungsprogramm ändern. Vielleicht ist das ja sein Problem.

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 944
  • Dankeschön: 51 mal
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #16 am: 23. Februar 2020, 19:29:43 »
(1/1) Arming ConditionNeedsUpdate...Warum macht das Programm das nicht selbst... Alles musste immer selber machen...  ;) Nur wie?

Ich habe mal das Netz der Netze befragt.
Diese Meldung ist keine Fehlermeldung, die behoben werden muss.

Das ist lediglich ein Marker der dafür sorgt, dass ein Update bei Bedarf ermöglicht wird.

Eine neue Bedingung ConditionNeedsUpdate= wurde hinzugefügt.
Mit diesem Mechanismus ist es möglich, die Ausführung von Diensten in Abhängigkeit davon, ob /usr neuer als /etc oder /var ist,
zu konditionieren.
Die Idee ist, dass verschiedene Dienste, die bei Upgrades in den Boot-Prozess eingefügt werden müssen, dies ausnutzen, um den
Boot-Vorgang bei normalen Starts nicht zu verzögern, sondern um die Ausführung nach Bedarf zu ermöglichen, falls /usr seit dem
letzten Start aktualisiert wurde.
Dies wird auf der Grundlage des mtime-Zeitstempels von /usr implementiert: wenn das Betriebssystem aktualisiert wurde,
sollte die  Paketierungssoftware das Verzeichnis berühren und so alle Instanzen darüber informieren, dass ein Upgrade von
/etc und /var notwendig sein könnte.

Ist also völlig normal und verlangt keine Aktion.

Gruß
Ahnungsloser
« Letzte Änderung: 23. Februar 2020, 19:32:20 von Ahnungsloser »
Im neuen Forum unter dem Nick "Roberto" :)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1756
  • Dankeschön: 343 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #17 am: 23. Februar 2020, 20:42:51 »
Hallo charly700,
haben nicht alle Einstellmöglichkeiten des Original Treibers
da werde ich neugierig. Welche Einstellmöglichkeiten fehlen mir da?

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline charly700

  • Sr. Mitglied
  • ****
  • Beiträge: 289
  • Dankeschön: 5 mal
  • Desktop: XFCE
  • Grafikkarte: PC: NVIDIA GeForce 930M
  • Grafikkartentreiber: nonfree
  • Kernel: immer den Neuesten und einen LTS-Kernel
  • Prozessor: Core i5-6200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #18 am: 23. Februar 2020, 23:21:17 »
Das kann ich dir leider nicht mehr genau sagen aber was ich sagen kann ist das der driverless Treiber nur Englisch war und der originale auf Deutsch. Und das mit den Seitenrändern wie schon oben erwähnt.

Ich glaube aber das es etwas mit meinen zwei Papierschächten zu tun hatte, was ich damals nicht einstellen konnte. Wie gesagt bin ich mir da aber nicht mehr sicher.

Offline stumax

  • Neuling
  • *
  • Beiträge: 16
  • Desktop: xfce
  • Grafikkarte: GeForce GTX 550Ti
  • Grafikkartentreiber: nonfree 390xx
  • Skill: Anfänger
Re: Installation Epson WF-2860
« Antwort #19 am: 24. Februar 2020, 01:29:51 »
Kann das sein, daß es mir die "cups.sock" zerlegt hat? Hab jetzt einiges rumprobiert, es kommt aber immer die selbe Fehlermeldung: "Beim Betrieb von CUPS trat ein Fehler auf: Failed to connect to server". system-config-printer aka. Druckereinstellungen verbindet den CUPS-Server über "/run/cups/cups.sock. Dieses Dokument ist aber exakt 0 Bytes groß.

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 944
  • Dankeschön: 51 mal
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #20 am: 24. Februar 2020, 08:29:31 »
Ich denke nicht, dass diese "0 Bytes" Datei das Problem ist.
Meine cups.sock hat ebenfalls 0 Bytes und mein Epson XP-312 druckt einwandfrei,

Probier mal folgendes:

sudo cp /etc/cups/cupsd.conf.default /etc/cups/cupsd.conf
Danach noch ein
sudo service cups restart
Gruß
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1756
  • Dankeschön: 343 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #21 am: 24. Februar 2020, 11:25:57 »
Hallo stumax,
Kann das sein, daß es mir die "cups.sock" zerlegt hat?
Definitiv nein. Diese Datei dient nur zur Markierung des Status von Cups. Etwas vereinfacht gesagt, ist sie vorhanden, dann läuft Cups, wenn nicht, dann läuft Cups nicht. Ich hoffe mal, Prinz Poettering hat da nichts dran gedreht, obwohl es ihm zuzutrauen wäre.
Diese Art der Verwendung von "Signal-Dateien" gibt es in Linux oft, wenn Du den Paketmanager startest z.B. wird eine Lockdatei der Größe Null gesetzt, um zu signalisieren, daß gerade ein Update-Prozess läuft.
Übrigens, darf ich an die Beantwortung meiner vorherigen Fragen erinnern?
Starte mal ganz neu und poste die Ausgabe von
systemctl --failed
lpstat -t
aber gleich nach dem Hochfahren, ohne vorherigen Druckversuch.
Wie ist dein Drucker verbunden, USB oder Network? Taucht der Drucker in den Druckereinstellungen auf?
Ist zwar nun schon fast zu spät, weil zuviel zwischendurch verändert wurde, aber vielleicht hilft es doch etwas weiter.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline stumax

  • Neuling
  • *
  • Beiträge: 16
  • Desktop: xfce
  • Grafikkarte: GeForce GTX 550Ti
  • Grafikkartentreiber: nonfree 390xx
  • Skill: Anfänger
Re: Installation Epson WF-2860
« Antwort #22 am: 24. Februar 2020, 17:06:50 »
Sorry, gosia, deine Frage hab ich überlesen.
Die Ausgabe von systemctl --failed und lpstat -t direkt nach einem Neustart des Rechners ist:
[stumax@stumax ~]$ systemctl --failed
0 loaded units listed.
[stumax@stumax ~]$ lpstat -t
Zeitplandienst läuft
systemvoreingestelltes Ziel: WF-2860-Series
Gerät für WF-2860-Series: usb://EPSON/WF-2860%20Series?serial=5834574D3037323779&interface=1
WF-2860-Series akzeptiert Anfragen seit Mo 24 Feb 2020 16:11:24 CET
Drucker WF-2860-Series ist im Leerlauf.  Aktiviert seit Mo 24 Feb 2020 16:11:24 CET
Schaut für mein ungeübtes Auge ja ganz gut aus, oder?
Ich hab vorhin nochmal
systemctl start org.cups.cupsd.service
in die Konsole gehämmert und siehe da, Drucker taucht in der Druckverwaltung und auf localhost:631 auf. Sachen gibbet... Selben Befehl hab ich aber gestern schon bestimmt 10 mal eingegeben, da aber ohne Erfolg.
Selbstreparierende Fehler machen mir Angst...  :o
Aber wenn das mit dem Befehl "start org.cups.cupsd.service" funktioniert, pack ich den in Autostart und gut is. Leider kann ich grad keine Testseite ausdrucken, weil Schwarz leer ist. *kopftisch*
Mein Drucker ist per USB angeschlossen.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1756
  • Dankeschön: 343 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #23 am: 24. Februar 2020, 17:48:25 »
Hallo stumax,
Schaut für mein ungeübtes Auge ja ganz gut aus, oder?
Ja, da sind keine Fehler sichtbar.
Aber wenn das mit dem Befehl "start org.cups.cupsd.service" funktioniert, pack ich den in Autostart
Nein, einmal
sudo systemctl enable --now org.cups.cupsd.servicemuss reichen.
Aber das hattest Du ja schon mal, insofern bin ich mißtrauisch, ob jetzt wirklich alles in Ordnung ist mit deinem Drucker.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline stumax

  • Neuling
  • *
  • Beiträge: 16
  • Desktop: xfce
  • Grafikkarte: GeForce GTX 550Ti
  • Grafikkartentreiber: nonfree 390xx
  • Skill: Anfänger
Re: Installation Epson WF-2860
« Antwort #24 am: 25. Februar 2020, 18:24:04 »
Hallo gosia,
nachdem meine bestellten Druckerpatronen erst morgen kommen (was dauert denn da so lange?!) hab ich mich mal um die Scannfunktion gekümmert.

Bissl gegoogelt und rausgefunden, ich brauch das Paket "Image Scan v3". Selbiges war bereits installiert, warscheinlich von dem Epson Treiber. Genauso war schon "iscan" und "skanlite" installiert.
Also mal fix "iscan" aufgerufen und nach einer kleinen Wartezeit den Fehler "Es konnte kein Befehl an den Scanner gesendet werden. Überprüfen sie den Scannerstatus." in einem Popup Fenster erhalten. Nun ja, was soll ich sagen, die Konsole war genauso gesprächig. Selber Erfolg, Popup Fenster mit gleichem Wortlaut auf, ich klick auf OK und nix wars mit irgendeiner Fehlermeldung in der Konsole.

Nächster Versuch mit "skanlite" in der Konsole. Diesmal aber mit Fehlermeldung selbiger.
[stumax@stumax ~]$ skanlite
qt5ct: using qt5ct plugin
QCommandLineParser: already having an option named "h"
QCommandLineParser: already having an option named "help-all"
QCommandLineParser: already having an option named "v"
"deviceOption value="
("image/bmp", "image/jpeg", "image/png", "image/vnd.microsoft.icon", "image/x-portable-bitmap", "image/x-portable-graymap", "image/x-portable-pixmap", "image/x-xbitmap", "image/x-xpixmap")
"utsushi:esci:usb:/sys/devices/pci0000:00/0000:00:1a.7/usb9/9-5/9-5:1.0"
"utsushi:esci:networkscan://192.168.0.2:1865"
"utsushi:sane::epkowa:usb:0x04b8:0x0848"
"utsushi:esci:usb:/sys/devices/pci0000:00/0000:00:1a.7/usb9/9-5/9-5:1.0"
"utsushi:esci:networkscan://192.168.0.2:1865"
"utsushi:sane::epkowa:usb:0x04b8:0x0848"
sane_open(" "utsushi:esci:usb:/sys/devices/pci0000:00/0000:00:1a.7/usb9/9-5/9-5:1.0" ", &handle) failed! status =  Operation not supported
Komisch ist ja, daß der Scanner nur den Namen ":" hat. Skanlite hat noch zwei weitere Scanner im Netzwerk gefunden, die aber mit der eigendlichen Bezeichnung der Geräte nichts zu tun haben. Aber das muß ja nicht wirklich was bedeuten.
Kann das sein, daß mein Scanner nicht von dem Treiber erkannt wird bzw. muß ich "imagescan" noch aktivieren? Wenn ich "imagescan" in die Konsole eingebe, kommt die Fehlermeldung "bash: imagescan: Kommando nicht gefunden."

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1756
  • Dankeschön: 343 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #25 am: 25. Februar 2020, 19:10:51 »
Hallo stumax,
hast Du auch iscan-data installiert?
Und was ist die Ausgabe von
sane-find-scanner
viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline stumax

  • Neuling
  • *
  • Beiträge: 16
  • Desktop: xfce
  • Grafikkarte: GeForce GTX 550Ti
  • Grafikkartentreiber: nonfree 390xx
  • Skill: Anfänger
Re: Installation Epson WF-2860
« Antwort #26 am: 25. Februar 2020, 20:22:30 »
Hallo gosia,
iscan-data ist installiert.
Die Ausgabe für sane-find-scanner ist:
[stumax@stumax ~]$ sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
und sudo sane-find-scanner:
[stumax@stumax ~]$ sudo sane-find-scanner
[sudo] Passwort für stumax:

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

  # No USB scanners found. If you expected something different, make sure that
  # you have loaded a kernel driver for your USB host controller and have setup
  # the USB system correctly. See man sane-usb for details.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
schaut für mich so aus, als ob der Scanner nicht erkannt wird.  :(

Will jetzt gerade das Paket "iscsi-scst 3.3.0.7403-1" installieren, das als einzig logisches unter dem Suchberiff "SCSI driver" aufgeführt ist, und werde gefragt, welchen linux-header ich installieren will.
Zur Auswahl wären:
linux316
linux414
linux419
linux44
linux49
linux53
linux54
linux55
linux419-rt
linux54-rt
Ich geh mal davon aus, daß damit mein Kernel gemeint ist, richtig? Ich habe "linux54" und "linux55" installiert. Genutzt ist gerade "linux55". Also in der Fragebox "linux55" auswählen und installieren, oder?
Danke und Gruß Max

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 944
  • Dankeschön: 51 mal
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #27 am: 25. Februar 2020, 20:43:14 »
War dein Gerät während der Befehle eingeschaltet?

If the result is different from what you expected, first make sure
your scanner is powered up and properly connected to your computer.

Gruß
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline stumax

  • Neuling
  • *
  • Beiträge: 16
  • Desktop: xfce
  • Grafikkarte: GeForce GTX 550Ti
  • Grafikkartentreiber: nonfree 390xx
  • Skill: Anfänger
Re: Installation Epson WF-2860
« Antwort #28 am: 25. Februar 2020, 21:09:29 »
Ja, war er.  ;)
Hab ich nicht dazu geschrieben, da ich das als selbstverständlich vorausgesetzt habe. Aber stimmt schon, es soll Leute geben, die sagen "funktioniert nicht" und nach Ewigkeiten erfährt man, das Teil war aus.

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 944
  • Dankeschön: 51 mal
  • Desktop: KDE Plasma 5.18.1
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.5.3-artix1-1 x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Installation Epson WF-2860
« Antwort #29 am: 25. Februar 2020, 21:12:13 »
Ich möchte einfach nur alles ausschließen ;)
Manchmal steckt der Teufel im Detail  >:D
Im neuen Forum unter dem Nick "Roberto" :)