Autor Thema: LAN in Kernel 5.6 geht nicht mehr  (Gelesen 348 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline schollsky

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Durchschnitt
  • Zweig: stable
LAN in Kernel 5.6 geht nicht mehr
« am: 09. April 2020, 12:23:54 »
Hallo zusammen,
bis Kernel 5.5x hatte ich damit bisher keine Probleme - nach Update auf Kernel 5.6 ist allerdings meine Netzwerkverbindung futsch. Hier mal die Ausgabe nach Boot von Kernel 5.5:

stefan@manjo:~$ networkctl
WARNING: systemd-networkd is not running, output will be incomplete.

IDX LINK   TYPE     OPERATIONAL SETUP   
  1 lo     loopback n/a         unmanaged
  2 enp8s0 ether    n/a         unmanaged

2 links listed.
stefan@manjo:~$ networkctl status enp8s0
WARNING: systemd-networkd is not running, output will be incomplete.

Failed to query link bit rates: Unit dbus-org.freedesktop.network1.service not found.
● 2: enp8s0                                                                                                 
             Link File: /usr/lib/systemd/network/99-default.link                                             
          Network File: n/a                                                                                 
                  Type: ether                                                                               
                 State: n/a (unmanaged)                                                                     
                  Path: pci-0000:08:00.0                                                                     
                Driver: r8168                                                                               
                Vendor: Realtek Semiconductor Co., Ltd.                                                     
                 Model: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (Motherboard (one of many))
            HW Address: 70:85:c2:5f:d7:56 (ASRock Incorporation)                                             
                   MTU: 1500 (min: 60, max: 9194)                                                           
  Queue Length (Tx/Rx): 1/1                                                                                 
      Auto negotiation: yes                                                                                 
                 Speed: 1Gbps                                                                               
                Duplex: full                                                                                 
                  Port: tp                                                                                   
               Address: 192.168.178.49                                                                       
                        2001:16b8:fd4:5900:ef5f:1f0:4463:35e5                                               
                        fe80::7a70:3753:3e1d:8dd4                                                           
               Gateway: 192.168.178.1 (AVM Audiovisuelles Marketing und Computersysteme GmbH)               
                        fe80::5e49:79ff:fe6f:283a (AVM Audiovisuelles Marketing und Computersysteme GmbH)
Das Netzwerkgerät enp8s0 taucht beim Kernel 5.6 hier gar nicht mehr auf.

Was kann ich tun?

Grüße

schollsky
« Letzte Änderung: 11. April 2020, 14:32:40 von Linu74 »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1851
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: LAN in Kernel 5.6 geht nicht mehr
« Antwort #1 am: 11. April 2020, 14:06:36 »
Hallo schollsky,
eigentlich keine Ahnung, aber vielleicht liegt es ja daran
systemd-networkd is not running
Starte mal das Ding, vielleicbt bringt es ja was
https://wiki.archlinux.org/index.php/Systemd-networkd


viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline schollsky

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Durchschnitt
  • Zweig: stable
Re: LAN in Kernel 5.6 geht nicht mehr
« Antwort #2 am: 04. Mai 2020, 21:57:31 »
Hallo gosia,

danke für Deinen Hinweis! :-)

Das Problem konnte ich zwischenzeitlich lösen durch downgraden des Systems. Beim letzten Kernel hatte mir das Treibermodulpaket gefehlt.

Beste Grüße

schollsky