Autor Thema: Kein Bootmenü  (Gelesen 206 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline ddeimeke

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Anfänger
Kein Bootmenü
« am: 24. Mai 2020, 09:57:50 »
Hallo!

Mein System zeigt beim Start kein Bootmenü, habt Ihr eine Idee, woran das liegen könnte?

Es ist ein System mit UEFI und GPT-Partitiontable.

Bin für jeden Hinweis dankbar.

Gruss

Dirk

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2309
  • Dankeschön: 181 mal
  • Karma: +0/-0
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 5.6x
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Kein Bootmenü
« Antwort #1 am: 24. Mai 2020, 10:50:21 »
Was steht denn in /etc/default/grub?

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden

Offline ddeimeke

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Anfänger
Re: Kein Bootmenü
« Antwort #2 am: 24. Mai 2020, 11:59:30 »
Was steht denn in /etc/default/grub?

$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=0912903b-9ea8-4ca3-b437-b1619586cc2f udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Gruss

Dirk

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2309
  • Dankeschön: 181 mal
  • Karma: +0/-0
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 5.6x
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Kein Bootmenü
« Antwort #3 am: 24. Mai 2020, 12:17:26 »
Die Zeile
GRUB_TIMEOUT_STYLE=hiddenhabe ich in meiner gar nicht.
Kommentiere die mal aus mit einem #

In der Zeile mit
GRUB_CMDLINE_LINUX_DEFAULTwürde ich das quiet raus nehmen und dann ein
sudo update-grub
Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden
Folgende Mitglieder bedankten sich: ddeimeke

Offline ddeimeke

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Anfänger
Re: Kein Bootmenü
« Antwort #4 am: 24. Mai 2020, 12:24:52 »
Vielen Dank!

Sehr cool, das löst auch ein anderes Problem.

https://forum.manjaro.org/t/issue-with-startup-while-inside-a-dockingstation/142303/6

Gruss

Dirk