Autor Thema: Numlock beim Start aktivieren?  (Gelesen 379 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Numlock beim Start aktivieren?
« am: 03. Juni 2020, 21:36:34 »
Hallo,

wie kann ich Numlock beim Start aktivieren?

Wenn ich hier sehe
https://wiki.archlinux.de/title/Numlock
Zitat
Xfce
Setze folgende Variabeln in ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml auf true:
<property name="Numlock" type="bool" value="true"/>
<property name="RestoreNumlock" type="bool" value="true"/>
und die Behle zu XFCE eingebe, geht auch nicht wirklich etwas.

Und woanders im Forum steht zum Beispiel,
https://de.manjaro.org/index.php?topic=3001.msg25390#msg25390
dass man unter /Einstellungen/Sitzung und Startverhalten/Automatisch die Anwendung automatisch starten kann. Doch welche Anwendung ist es genau, die ich hinzufügen muss?

Mit welchen Befehl finde ich die korrekten Anwendungsbezeichnung zur Adressierung? Vielleicht löst das das Problem?


Und ebenso
Zitat
numlockx on
führt zu nichts.


Herzlichen Dank, Rulinux

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1851
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #1 am: 03. Juni 2020, 22:38:00 »
Hallo Rulinux,
poste mal bitte die Datei
~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #2 am: 04. Juni 2020, 13:44:39 »
Hallo Gosia, hier der Inhalt zu
Zitat
~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml

<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboards" version="1.0">
  <property name="Default" type="empty">
    <property name="Numlock" type="bool" value="true"/>
    <property name="RestoreNumlock" type="bool" value="true"/>
  </property>
</channel>

Viele Grüße, Rulinux

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1851
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #3 am: 04. Juni 2020, 15:28:57 »
Hallo Rulinux,
nimm mal probehalber diese Zeile raus:
<property name="RestoreNumlock" type="bool" value="true"/>also nur
<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboards" version="1.0">
  <property name="Default" type="empty">
    <property name="Numlock" type="bool" value="true"/>
  </property>
</channel>

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #4 am: 04. Juni 2020, 17:03:54 »
Danke, Gosia,

Aber hilft leider auch nichts!

VG, Rulinux

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #5 am: 04. Juni 2020, 17:32:12 »
Tastatureinstellungen kann man über den manjaro-settings-manager ändern. Dort findet man etwas mehr Infos als unter Einstellungen/Tastatur. Aber ich habe dort auch keine Lösung gefunden.

Offline kisun

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 7 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 5.6.12-1-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #6 am: 04. Juni 2020, 17:46:38 »
"numlockx on"

Und ebenso  führt zu nichts.


Hilft mir als Aussage nicht weiter. Was passiert wenn du das im Terminal eingibst?

Steht dann dort nichts außer eine neue Eingabezeile oder "bash: numlockx: Kommando nicht gefunden."?

Bei ersterem heiß das das "numblockx" installiert ist und ohne Fehler durchläuft. Wenn das so ist probier auch mal "numlockx off" und "numlockx toggle" und beobachte die Numlock-Taste der Tastatur.

Bei zweiter Meldung heißt das das "numlockx" noch nicht installiert ist und muß erst installiert werden.

In dem Arch-Wiki was du oben verlinkt hast sind dann 3 möglichkeiten die bei dir gehen könnten. Da du das xfce-Manjaro installiert hast die xfce-Methode (die aber scheinbar bei dir nicht funktioniert), dann die LightDm-Methode da Manjaro standartmäßig "lightDm" als Displaymanager nutzt oder dann ganz unten die Autostart-Methode.

Ich hoffe das hilft dir ein wenig weiter.

Viel Erfolg.  ;)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1851
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #7 am: 04. Juni 2020, 18:55:22 »
Hallo Rulinux,
"etwas ist faul im Staate Rulinux"  :) Warum funktionieren bei dir die einfachen Sachen nicht, war schon beim mounten von NTFS so. Seltsam. Sämtliche drei Lösungen funktionieren bei mir problemlos. Und das Problem ist, da gibt es ja eigentlich kaum bis keine Fehlerquellen. Zeile eintragen oder Befehl eingeben, mehr ist nicht.
Nur zur Sicherheit: die erwähnte ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml liegt aber ordentlich in deiner mit Linux-Zeugs (ext4 o.ä.) formatierten Partition, nicht etwa auf deiner berühmten NTFS?

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #8 am: 04. Juni 2020, 22:23:22 »
ja, natürlich Gosia, es liegt auf ext4 unter dem von Dir benannte Ordner.!
Ich vermute mal mehr, es liegt an meinen HP Notebook bzw. darin integrierten Tastatur.
VG, Rulinux

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1851
  • Dankeschön: 365 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #9 am: 04. Juni 2020, 23:10:16 »
Hallo Rulinux,
Ich vermute mal mehr, es liegt an meinen HP Notebook bzw. darin integrierten Tastatur.
Vielleicht hilft es weiter, wenn Du das genaue Modell verrätst. Da findet sich eventuell jemand, der das auch hat und für sich eine Lösung gefunden hat.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Jr. Mitglied
  • **
  • Beiträge: 95
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: XFCE und KDE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: 18.1.5-191229
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #10 am: 07. Juni 2020, 18:15:50 »
Hallo Gosia,

habe die Lösung gefunden. Habe 2 Einstellungsbereiche verändert.
1. Tastatur --> Tastaturbelegung --> Tastaturbelegung: "Generische PC-Tastatur mit 105 Tasten (Intl)", hatte ich schon vorher.
und
Tastaturbelegung: "Deutsch (T3)", vorher hatte ich "Deutsch (Qwerty)"
2. Habe meinen Desktop-Manager von SDDM auf LightDM mit Greeter gewechselt.
https://wiki.manjaro.org/index.php?title=LightDM_Auto_Login

Jetzt ist zumindest nach dem Login das Numlock aktiviert. Das es schon vor dem Login aktiv ist, geht wohl nicht!?

Herzliche Grüße, Omlinux

PS: @gosia:
Zitat
"etwas ist faul im Staate Rulinux"  :) Warum funktionieren bei dir die einfachen Sachen nicht, war schon beim mounten von NTFS so.
Nochmals zur Erinnerung an die Lösung meines "NTFS" Problems. Es lag an der voreingestellten Schnellstart-Option von Windows, die den Rechner auch im heruntergefahrenen Zustand "kontrolliert". Das sind Probleme, wenn man von einem System auf ein anderes wechselt.

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 358
  • Dankeschön: 23 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 5.7
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren?
« Antwort #11 am: 13. Juni 2020, 17:46:40 »
Hallo zusammen!

Nutze auch seit Jahren LightDM.
Man muss nur die /etc/lightdm/lightdm.conf editieren und dann die Zeile greeter-setup-script=/usr/bin/numlockx on einfügen.
Ich hänge mal eine beispielhaft meine lightdm.conf an. Wichtig ist die Stelle an der die o.g. Zeile eingefügt werden muss.
Habe sie zur besseren Kenntlichkeit groß und fett gemacht ;-)

So sollte es klappen.
Viel Erfolg!
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."