Autor Thema: Error: GIMP configuration failed (aur)  (Gelesen 321 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline jolic

  • Neuling
  • *
  • Beiträge: 30
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: UHD 630
  • Grafikkartentreiber: i915
  • Kernel: 5.4.x (LTS Kernel)
  • Prozessor: I7-8700T
  • Skill: Durchschnitt
  • Zweig: stable
Error: GIMP configuration failed (aur)
« am: 11. Juni 2020, 14:35:53 »
Hi, kann jemand erklären warum ich per
pacaur -Syudas Paket python2-gimp von 2.10.18-2 auf 2.10.20-1 nicht updaten kann? Fehlermeldung:
Zitat
Error: GIMP configuration failed.

  - Error: missing dependency babl >= 0.1.78
  - Error: missing dependency gegl-0.4 >= 0.4.24

See the file 'INSTALL' for more help.
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...
:: Konnte python2-gimp-Paket(e) nicht erstellen

Die Abhängigkeiten sind nicht aktuell, evtl. werden die bald nachgeliefert? Versuche das in 2 Tagen wieder...

jolic



Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1347
  • Dankeschön: 215 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma, Deepin
  • Grafikkarte: NVIDIA [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Intel/Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y LTS, 4.19.y LTS, 4.14.y,
  • Prozessor: Notebook: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
  • Skill: Fortgeschritten
  • Zweig: Stable 18.n.y on PowerWorkStation, NB, HTPC, Desktop:s: Testing or Unstable only VM
Re: Error: GIMP configuration failed (aur)
« Antwort #1 am: 11. Juni 2020, 16:47:31 »
Zu: pacaur -Syudiese App sollte nicht mehr verwenden werden,
verwendet werden sollte "trizen", "yay", "pacman" die GUI "pamac"

Zu: 2.10.18-2 auf 2.10.20-1 gibt es einen bestimmten Grund für Version 2.10.20-1, wenn nein dann
deinstalliere das AUR-Packages und installiere Gimp aus den Manjaro Repository
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme
Folgende Mitglieder bedankten sich: m1d1

Offline charly700

  • Sr. Mitglied
  • ****
  • Beiträge: 305
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: PC: NVIDIA GeForce GTX 1060 3GB
  • Grafikkartentreiber: nonfree
  • Kernel: immer den Neuesten und einen LTS-Kernel
  • Prozessor: Intel Core i5-7300HQ
  • Skill: Durchschnitt
  • Zweig: stable
Re: Error: GIMP configuration failed (aur)
« Antwort #2 am: 11. Juni 2020, 22:29:40 »
Es geht da ja nicht um Gimp sondern um das Paket python2-gimp. Und das wird wahrscheinlich für irgendwelche Plugins gebraucht.

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1347
  • Dankeschön: 215 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma, Deepin
  • Grafikkarte: NVIDIA [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Intel/Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y LTS, 4.19.y LTS, 4.14.y,
  • Prozessor: Notebook: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
  • Skill: Fortgeschritten
  • Zweig: Stable 18.n.y on PowerWorkStation, NB, HTPC, Desktop:s: Testing or Unstable only VM
Re: Error: GIMP configuration failed (aur)
« Antwort #3 am: 12. Juni 2020, 09:11:31 »
Es geht da ja nicht um Gimp sondern um das Paket python2-gimp. Und das wird wahrscheinlich für irgendwelche Plugins gebraucht.

Dann sehe Dir das Packages von Gimp an, hier sieht man das diese Packages
  - Error: missing dependency babl >= 0.1.78
  - Error: missing dependency gegl-0.4 >= 0.4.24
in direkter Abhängigkeit zu GIMP stehen

im PKGBUILD von python2-gimp, stehen alle Info's zu: # Contributor:

Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline m1d1

  • Neuling
  • *
  • Beiträge: 1
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Skill: Anfänger
Re: Error: GIMP configuration failed (aur)
« Antwort #4 am: 14. Juni 2020, 11:13:21 »
Hi, kann jemand erklären warum ich per
pacaur -Syudas Paket python2-gimp von 2.10.18-2 auf 2.10.20-1 nicht updaten kann? Fehlermeldung:
Die Abhängigkeiten sind nicht aktuell, evtl. werden die bald nachgeliefert? Versuche das in 2 Tagen wieder...

jolic

Wenn Du die Pakete gegl-git babl-git anstatt babl gegl installierst, klappt es auch anschließend mit python2-gimp.

yay -S babl-git gegl-git
Es wird angezeigt, dass
babl-git-0.1.77.r1636.0ec7f09-1  gegl-git-0.4.23.r10019.d528f1541-1
installiert wird - tatsächlich erhälst Du

babl-git Installed: 0.1.79.r1641.e7e80bd-1
gegl-git Installed: 0.4.25.r10063.40da695ea-1

Folgende Mitglieder bedankten sich: jolic

Offline jolic

  • Neuling
  • *
  • Beiträge: 30
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: UHD 630
  • Grafikkartentreiber: i915
  • Kernel: 5.4.x (LTS Kernel)
  • Prozessor: I7-8700T
  • Skill: Durchschnitt
  • Zweig: stable
[Gelöst] Error: GIMP configuration failed (aur)
« Antwort #5 am: 14. Juni 2020, 14:28:56 »
Danke euch allen!
Ja das Paket python2-gimp wird z.B. für das Plugin gimp-plugin-registry benötigt.
Nutze nun nicht mehr pacaur sondern yay und mit babl-git gegl-git aus den AUR Repos funktioniert das Update.

jolic