Autor Thema: Langsamer Start verschiedener Anwendungen  (Gelesen 285 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline m-bostaurus

  • Sr. Mitglied
  • ****
  • Beiträge: 381
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: KDE, XFCE, LXQt, Mate
  • Grafikkarte: Desktop: GTX 1070Ti; Laptop: Nvidia
  • Grafikkartentreiber: unfree; unfree
  • Kernel: 419/420 64bit auf beiden Rechnern
  • Prozessor: i5-6500; i5
  • Skill: Durchschnitt
  • Zweig: stable
Langsamer Start verschiedener Anwendungen
« am: 01. Juli 2020, 15:15:16 »
Manjaro KDE: Seit einigen Tagen (die Vorgeschichte siehe weiter unten) starten bei meinem Rechner typische KDE-Anwendungen wie Kate, Dolphin, Krusader, aber auch PCManFM oder Thunar, sehr langsam (ca. 50 Sek.). Spaßeshalber habe ich die Anwendungen über die noch schnell startende Konsole geöffnet und erhalte Informationen, die mich allerdings ratlos lassen bleiben. Bei Kate:kate
QObject::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString)
QObject::connect: No such signal QDBusAbstractInterface::DeviceRemoved(QString)
kf5.kio.core: We got some errors while running testparm "lp_load_ex: Max protocol NT1 is less than min protocol SMB2_02.\nLoaded services file OK."
kf5.kio.core: We got some errors while running 'net usershare info'
kf5.kio.core: "lp_load_ex: Max protocol NT1 is less than min protocol SMB2_02.\nlp_load_ex: Max protocol NT1 is less than min protocol SMB2_02.\n
Bei Krusader:krusader
QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
14:46:19.118-debug default unknown@0 # System icon theme: "breeze"
14:46:19.155-warning default unknown@0 # QWidget::insertAction: Attempt to insert null action
14:46:19.156-warning default unknown@0 # QWidget::insertAction: Attempt to insert null action
14:46:19.161-warning kf5.ki18n unknown@0 # Trying to convert empty KLocalizedString to QString.
14:47:09.173-warning default unknown@0 # QObject::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString)
14:47:09.173-warning default unknown@0 # QObject::connect: No such signal QDBusAbstractInterface::DeviceRemoved(QString)
Ich habe das mal gegoogelt; von den Beiträgen, die ich dann zu lesen erhalte, bin ich allerdings überfordert. Es war auch nichts dabei nach dem Motto: Tu dieses oder jenes, und das Problem ist gelöst. Vielleicht hat aber eine Leser/In eine Idee, was ich machen könnte (außer, dass ich die endlich gestarteten Anwendungen nicht schließe, damit es wenigstens ab dann schneller geht).

Vorgeschichte: Bisher hatte ich in meinem Desktop-Rechner eine i5-CPU und ein MSI-Mainboard. Das habe ich gewechselt gegen Ryzen 9 9350x und Asus ROG STRIX x570 f Gaming. Es gab erwartete Schwierigkeiten wegen UEFI, denn jeder Mainboard-Hersteller pflegt seine eigenen Bezeichnungen. Mit Hilfe der Arch- und Manjaro-Wikis habe ich das weitestgehend hinbekommen (ein XFCE-Manjaro von drei Manjaros startet noch nicht, lässt sich aber über chroot ansprechen); LXQt-Manjaro steht blendend da, KDE-Manjaro hat die oben genannten Schwierigkeiten und Windows 10 erkannte geänderte Hardware und aktivierte sich selbst nach der von mir angeklickten Bestätigung, dass es das selbe Betriebssystem bei geänderten Bauteilen ist.
Diese Anfrage veröffentliche ich auf https://de.manjaro.org/, http://www.manjaro-forum.de/ und https://forum.manjaro.org/

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 152
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Langsamer Start verschiedener Anwendungen
« Antwort #1 am: 06. Juli 2020, 09:05:09 »
Hi, Du kennst vermutlich selbst sehr gut aus.

Aber wenn Du Deine Hardware geändert hast, würde ich auf alle Fälle alles neu installieren. Ggf. halt das HOME Verzeichnis sichern und (z.T.) wieder verwenden.

Hier habe ich eine hervorragende Anleitung zur Installation von KDE gefunden. Und zwar mit Profi Feintuning Informationen, also kein ABC. Sehr gut!!
https://www.frumble.de/blog/2017/03/01/manjaro-linux-und-kde-plasma-5-das-frumble-kompendium-2017/

Aber unbedingt Deinen Daten vorher sichern.

Viele Erfolg, Rulinux
« Letzte Änderung: 06. Juli 2020, 09:08:10 von Rulinux »
Folgende Mitglieder bedankten sich: m-bostaurus

Offline m-bostaurus

  • Sr. Mitglied
  • ****
  • Beiträge: 381
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: KDE, XFCE, LXQt, Mate
  • Grafikkarte: Desktop: GTX 1070Ti; Laptop: Nvidia
  • Grafikkartentreiber: unfree; unfree
  • Kernel: 419/420 64bit auf beiden Rechnern
  • Prozessor: i5-6500; i5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Langsamer Start verschiedener Anwendungen
« Antwort #2 am: 06. Juli 2020, 09:47:43 »
Ich fürchte, es läuft auf eine Neuinstallation hinaus. Ich habe alles gesichert und bin gerade dabei, vorsichtshalber auch die fehlerhafte Version nochmals zu sichern. Ich warte immer noch auf das Update von Manjaro stable, weil ich ein wenig hoffe, dass das nochmals hilft, aber leider kommt es nicht ...

Offline m-bostaurus

  • Sr. Mitglied
  • ****
  • Beiträge: 381
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: KDE, XFCE, LXQt, Mate
  • Grafikkarte: Desktop: GTX 1070Ti; Laptop: Nvidia
  • Grafikkartentreiber: unfree; unfree
  • Kernel: 419/420 64bit auf beiden Rechnern
  • Prozessor: i5-6500; i5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Langsamer Start verschiedener Anwendungen
« Antwort #3 am: 12. Juli 2020, 16:02:38 »
Ich habe das Problem nicht lösen können, aber eine Lösung für das Problem gefunden. Ich habe Manjaro KDE neu auf einer anderen Partition mit denselben Anmeldedaten und Usern installiert. Auch die Liste der installierten Pakete aus den offiziellen Quellen und dem AUR habe ich übernommen. Dabei war sinngemäß folgender Link hilfreich: https://wiki.archlinux.org/index.php/Pacman/Tips_and_tricks#Recreate_a_package_from_the_file_system. Das System lief fehlerfrei und angenehm flott. Dann habe ich für home die alte, ursprüngliche Partition in fstab eingetragen. Sekunden nach dem Neustart war klar, dass das die richtige Maßnahme war.
Vorausetzung dieses Weges waren getrennte Partitionen für root und home. Meine Grundidee war, den Bereich der Ursachen einzugrenzen. In diesem Falle: Liegt die Ursache der Probleme in meinen persönlichen (Home-) Einstellungen oder auf der administrativen Ebene. Nachdem ich mich zu diesem Weg entschlossen hatte, hatte ich innerhalb einer dreiviertel Stunde wieder ein gut funktionierendes System.
Nebenbemerkung: Am längsten hat die Vorbereitung der Installation von Manjaro KDE gedauert, weil der erste Schritt der Installation darin besteht, dass die Installationsanwendung Calamares ein Skript von wo auch immer herunterlädt, was erst im dritten Anlauf gelang. Dieses seltsame Verhalten habe ich schon einige Male beobachtet. Es ist eine wirksame Abschreckungsmaßnahme. Wer nicht wie ich auf Teufel komm heraus KDE installieren will, gibt auf.

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 152
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Langsamer Start verschiedener Anwendungen
« Antwort #4 am: 13. Juli 2020, 09:02:38 »
Wenn das ein Fehler oder ein Veränderungswunsch ist, dann gib das doch mal unter
https://bugs.kde.org/
auf. Dort kann man nicht nur Bugs, sondern auch Wünsche schreiben.

Beste Grüße, Rulinux