Autor Thema: eclipse aktualisieren mit yaourt geht nicht  (Gelesen 220 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 787
  • Dankeschön: 2 mal
  • Karma: +0/-0
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
eclipse aktualisieren mit yaourt geht nicht
« am: 04. Juli 2020, 11:26:27 »
Hallo,
die angebotene Aktualisierung von 'eclipse' aus dem AUR mit yaourt endet bei mir mit 'zu wenig Speicherplatz auf dem Gerät'.
Ich habe in root 24,42 GB und davon 7,34 GB frei.
yaourt -Syua
...
==> Softwareaktualiserung (neue Version):
aur/eclipse-common 4.15-1 -> 4.16-6
aur/eclipse-java   4.15-1 -> 4.16-6

==> Upgrade fortsetzen? [J/n]
==> [P]aketdetails anzeigen [M]anuell Pakete auswählen
==> --------------------------------------------------
==>
==> Lade PKGBUILD von eclipse-common aus dem AUR herunter...
x .SRCINFO
x .gitignore
x PKGBUILD
x commonify
FabioLolix commented on <a href="#comment-751269" class="date">2020-06-15 12:15</a>                     

AllirionX commented on <a href="#comment-752526" class="date">2020-06-23 00:20</a>                       

issue_no1 commented on <a href="#comment-754054" class="date">2020-07-01 20:42</a>                       

ArthurBorsboom commented on <a href="#comment-754343" class="date">2020-07-03 13:29</a>                 

ArthurBorsboom commented on <a href="#comment-754403" class="date">2020-07-03 20:08</a>                 

eclipse-common 4.16-6  (2020-07-03 17:13)
(Nicht unterstütztes Paket: Potenziell gefährlich!)
==> PKGBUILD bearbeiten? [J/n] („A“ zum Abbrechen)
==> ----------------------------------------------
==> n

==> WARNUNG:Dieses PKGBUILD beschreibt ein geteiltes Paket.
==> Spezifische Paketoptionen sind unbekannt
==> Von eclipse benötigt:
 - python3 (bereits installiert) [makedepend]


==> Mit dem Erstellen von eclipse-common fortfahren?[J/n]
==> -----------------------------------------------------
==>
==> Erstelle und installiere Paket
==> Erstelle Paket: eclipse 4.16-6 (Fr 03 Jul 2020 22:13:29 CEST)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> commonify gefunden
  -> Lade eclipse-java-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  204M  100  204M    0     0  1437k      0  0:02:25  0:02:25 --:--:-- 7197k
  -> Lade eclipse-jee-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  380M  100  380M    0     0  3366k      0  0:01:55  0:01:55 --:--:-- 7210k
  -> Lade eclipse-cpp-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  240M  100  240M    0     0  7046k      0  0:00:34  0:00:34 --:--:-- 7212k
  -> Lade eclipse-php-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  231M  100  231M    0     0  6977k      0  0:00:33  0:00:33 --:--:-- 7206k
  -> Lade eclipse-javascript-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  186M  100  186M    0     0  7004k      0  0:00:27  0:00:27 --:--:-- 7183k
  -> Lade eclipse-rust-2020-06-R-linux-gtk-x86_64.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  164M  100  164M    0     0  6981k      0  0:00:24  0:00:24 --:--:-- 7211k
==> Überprüfe source Dateien mit sha256sums...
    commonify ... Durchgelaufen
==> Überprüfe source_x86_64 Dateien mit sha256sums...
    eclipse-java-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
    eclipse-jee-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
    eclipse-cpp-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
    eclipse-php-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
    eclipse-javascript-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
    eclipse-rust-2020-06-R-linux-gtk-x86_64.tar.gz ... Durchgelaufen
==> Entpacke Quellen...
==> Beginne prepare()...
==> Beginne build()...
commonify: Found 1620 files in 'eclipse-cpp'
commonify: Found 1234 files in 'eclipse-java'
commonify: Found 1002 files in 'eclipse-rust'
commonify: Found 15115 files in 'eclipse-jee'
commonify: Found 13461 files in 'eclipse-javascript'
commonify: Found 13932 files in 'eclipse-php'
commonify: Divergent file 'configuration/org.eclipse.update/platform.xml'
commonify: Divergent file 'configuration/config.ini'
commonify: Divergent file 'configuration/org.eclipse.equinox.simpleconfigurator/bundles.info'
commonify: Divergent file 'eclipse.ini'
commonify: Divergent file 'notice.html'
commonify: Divergent file 'artifacts.xml'
commonify: Divergent file 'p2/org.eclipse.equinox.p2.core/cache/artifacts.xml'
commonify: Divergent file 'p2/org.eclipse.equinox.p2.engine/.settings/org.eclipse.equinox.p2.artifact.repository.prefs'
commonify: Divergent file 'p2/org.eclipse.equinox.p2.engine/.settings/org.eclipse.equinox.p2.metadata.repository.prefs'
commonify: 846 identical files in 'eclipse-common'
==> Betrete fakeroot Umgebung...
==> Beginne package_eclipse-common()...
==> Säubere Installation...
  -> Entferne libtool Dateien...
  -> Bereinige ungewollte Dateien...
  -> Entferne statische Bibliotheken...
  -> Entferne unnötige Symbole aus Binär-Dateien und Bibliotheken...
  -> Komprimiere Man-Pages und Info-Seiten...
==> Checking for packaging issues...
==> Erstelle Paket "eclipse-common"...
  -> Erstelle .PKGINFO Datei...
  -> Erstelle .BUILDINFO Datei...
  -> Erstelle .MTREE-Datei...
  -> Komprimiere Paket...
==> Beginne package_eclipse-java()...
==> Säubere Installation...
  -> Entferne libtool Dateien...
  -> Bereinige ungewollte Dateien...
  -> Entferne statische Bibliotheken...
  -> Entferne unnötige Symbole aus Binär-Dateien und Bibliotheken...
  -> Komprimiere Man-Pages und Info-Seiten...
==> Checking for packaging issues...
==> Erstelle Paket "eclipse-java"...
  -> Erstelle .PKGINFO Datei...
  -> Erstelle .BUILDINFO Datei...
  -> Erstelle .MTREE-Datei...
  -> Komprimiere Paket...
==> Beginne package_eclipse-jee()...
==> Säubere Installation...
  -> Entferne libtool Dateien...
  -> Bereinige ungewollte Dateien...
  -> Entferne statische Bibliotheken...
  -> Entferne unnötige Symbole aus Binär-Dateien und Bibliotheken...
  -> Komprimiere Man-Pages und Info-Seiten...
==> Checking for packaging issues...
==> Erstelle Paket "eclipse-jee"...
  -> Erstelle .PKGINFO Datei...
  -> Erstelle .BUILDINFO Datei...
  -> Erstelle .MTREE-Datei...
  -> Komprimiere Paket...
==> Beginne package_eclipse-cpp()...
==> Säubere Installation...
  -> Entferne libtool Dateien...
  -> Bereinige ungewollte Dateien...
  -> Entferne statische Bibliotheken...
  -> Entferne unnötige Symbole aus Binär-Dateien und Bibliotheken...
  -> Komprimiere Man-Pages und Info-Seiten...
==> Checking for packaging issues...
==> Erstelle Paket "eclipse-cpp"...
  -> Erstelle .PKGINFO Datei...
  -> Erstelle .BUILDINFO Datei...
  -> Erstelle .MTREE-Datei...
  -> Komprimiere Paket...
xz: (stdout): Schreibfehler: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
bsdtar: Write error
==> FEHLER: Konnte Paket-Datei nicht erstellen.
==> FEHLER:Makepkg konnte eclipse nicht erstellen.
Wie kann man das Problem lösen?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Online Linu74

  • Administrator
  • ******
  • Beiträge: 2348
  • Dankeschön: 184 mal
  • Karma: +0/-0
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 5.7x
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: eclipse aktualisieren mit yaourt geht nicht
« Antwort #1 am: 04. Juli 2020, 11:33:52 »
Du bist glaube ich nun lange genug dabei und solltest Wissen, daß yaourt nicht mehr genutzt werden sollte. Ersetze yaourt bitte mit trizen, yay oder einem anderen AUR Helper.

Die Fehlermeldung sagt eigentlich alles: Du hast nicht mehr genug Speicherplatz. Öffne ein Terminal:

sudo pacman -Sc
Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-deAusgaben im Code Block [^code]hier text einfügen[^/code] die ^ müßen entfernt werden
Folgende Mitglieder bedankten sich: Hanisch

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 787
  • Dankeschön: 2 mal
  • Karma: +0/-0
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: eclipse aktualisieren mit yaourt geht nicht
« Antwort #2 am: 04. Juli 2020, 12:56:01 »
Ersetze yaourt bitte mit trizen, yay oder einem anderen AUR Helper.
$ sudo pacman -S yay
$ sudo pacman -Sc
$ yay -Syua
Das hat funktioniert! - Danke!

Habe jetzt überall 'yaourt' durch 'yay' ersetzt.

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)