Autor Thema: Drucker erscheint im Druckdialog, aber weder in der Druckereinrichtung noch Cups  (Gelesen 490 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 152
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Hallo Gosia,

habe Dir mal ein paar Screenshots einer Auswahl vom meinen Brother-Einstellungen beigefügt. Ich finde aber nichts, was genau dem von Dir gewünschten entspricht:
Zitat
muss es ja eine Hauptseite geben, wo man die ganzen Netzwerkverbindungen (Cloud-Print, Air-Print, DNS-Proxy-Einstellungen usw.) auswählen und einstellen kann (unte dem Tab "Drucker" wahrscheinlich, oder "allgemein")

Meine Probleme sind, auch nach Neuinstallation, dass
1. Im Printdialog 1 Drucker zuviel ist, der irgendwie beim erstmaligen Einrichten (nach Neuinstallation) entstanden ist.
2. Warum ich 3 Drucker unter localhost zur Auswahl habe bei "Drucker hinzufügen".
3. Es finden sich aber nur jeweils 1 Drucker unter localhost und den KDE Druckeinstellungen. Sie haben auch den gleichen Namen (jetzt mit Version 7).
Dennoch ist es komisch, dass man die Einstellungen getrennt vornehmen kann. Sie werden NICHT gegenseitig übernommen.
4.Das Hauptproblem ist. Ich stelle unter localhost und unter den KDE Druckereinstellungen doppelseitigen Druck ein. Wenn ich mit localhost eine Testseite drucke, dann kommt nur 1 1-seitige heraus. Drucke ich mit KDE "Drucker einrichten" eine Testseite, so kommt eine Doppelseite heraus - wie gewünscht. Drucke ich mit Firefox 2 Seiten, so kommen 2-mal 1-seitige Seiten heraus.
Kurz der doppelseitige Druck funktioniert nicht.
Dafür hatte ich sogar eine Neuinstallation in Kauf genommen. Das hat es aber auch nicht gelöst. Einen Drucker-Reset, ohne Reset der Netzwerkeinstellungen hat auch nichts genützt. Ich könnte höchstens noch auf Werkseinstellungen zurücksetzen.

Danke, Rulinux


Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1901
  • Dankeschön: 370 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Hallo Rulinux,
leider wirfst Du mehr Fragen auf als Du beantwortest :( Ich versuche mal eine Zusammenfassung:
Ich sehe bei dir drei Drucker:
* Brother MFC-LC5750DW
* Kyocera FS1118MFP
* Canon ip7200
Der Canon taucht plötzlich nicht mehr auf und der Brother macht dir Probleme. Canon und Kyocera lassen wir jetzt mal beiseite, Konzentration auf den Brother.
Also nochmals meine Nachfragen, Du redest beim Brother immer von einem "Geisterdrucker", oder
1 Drucker zuviel
aber der Brother existiert doch und hängt ja wohl auch physikalisch am Rechner? Wieso "zuviel"? Und warum wählst Du ihn in Cups nicht einfach aus (wie vorgeschlagen am besten die "driverless"-Variante) und richtest ihn ein? Beziehungsweise, was passiert genau, wenn Du das probierst?
2. Warum ich 3 Drucker unter localhost zur Auswahl habe bei "Drucker hinzufügen".
Das sind ja nicht drei Drucker, sondern einer, der eben auf drei verschiedene Arten konfiguriert werden kann, Driverless, IPP, http und sicher noch mehr, wenn ich so die Treibermöglichkeiten von deinem Screenshot ansehe. Das ist nicht so besonders merkwürdig, mein Epson erschien vor der Konfiguration auch zweimal.
3. Es finden sich aber nur jeweils 1 Drucker unter localhost und den KDE Druckeinstellungen. Sie haben auch den gleichen Namen (jetzt mit Version 7).
Ich sehe zwei, Brother und Kyocera. Wobei ich aber nicht genau weiss, welche Stelle Du mit "unter localhost" meinst. Klar, bei "localhost" meinst Du CUPS, aber dort muss man zwischen Druckern unterscheiden, die überhaupt gefunden werden und denen, die dann tatsächlich installiert und konfiguriert sind ("Drucker hinzufügen" und "Drucker verwalten")
Zu KDE Druckereinstellungen kann ich nichts sagen.
4.Das Hauptproblem ist. Ich stelle unter localhost und unter den KDE Druckereinstellungen doppelseitigen Druck ein. Wenn ich mit localhost eine Testseite drucke, dann kommt nur 1 1-seitige heraus. Drucke ich mit KDE "Drucker einrichten" eine Testseite, so kommt eine Doppelseite heraus - wie gewünscht. Drucke ich mit Firefox 2 Seiten, so kommen 2-mal 1-seitige Seiten heraus.
Kurz der doppelseitige Druck funktioniert nicht.
Du redest jetzt vom Kyocera? Aber egal, keine Ahnung. Das klingt nach Treiberproblem, da müsste sich aber jemand dazu äußern, der den gleichen Drucker hat.
Dafür hatte ich sogar eine Neuinstallation in Kauf genommen. Das hat es aber auch nicht gelöst.
Neuinstallationen sind äußerst selten eine Lösung.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 152
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Re: Brother-Drucker MFC-L5750DW druckt nur 1-seitig bzw. nicht 2-seitig
« Antwort #17 am: 26. Juli 2020, 07:14:49 »
Hallo Gosia,

danke für die Klärungen. Es geht bei mir immer nur um meinen Brother MFC-L5750DW Drucker.

Zuvor ist im Printdialog der Brother-Drucker 2-mal aufgetaucht, also 1-mal zuviel. Und dass, obwohl er unter localhost:631, also cups, nur einmal tatsächlich installiert war, ebenso unter KDE Drucker einrichten. Dieser Ghost-Drucker ist (offenbar aktuell) verschwunden. Vermutlich, indem ich unter Eingabe der IP-Adresse des Druckers im Browser in den Druckereinstellungen selbst einen Reset durchgeführt habe, ohne die Netzwerkeinstellungen zu ändern.

Jetzt bleibt das letzte Problem, dass der Brother-Drucker MFC-L5750DW, den ich als driverless installiert habe, nur 1-seitig druckt bzw. nicht 2-seitig druckt trotz korrekter Einstellungen. Vermulich ein Treiberproblem?

Wer kann da noch helfen?

Danke, Rulinux

Offline Markjaro

  • Neuling
  • *
  • Beiträge: 41
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
Hallo Rulinux,
Hast Du denn in Cups einerseits und im beschriebenen Drucker-Config-Bereich andererseits unter "Drucken" =>2-Seitig den 2-Seitigen Modus aktiviert?
Unter Cups heißt diese Einstellung Duplex und findet sich unter "Standardeinstellungen festlegen" im Bereich General.
Beim Drucken selber muss natürlich auch der Duplexdruck aktiviert sein.
Unter Libre-Office heißt diese Option "Blattseiten" (Doppelseitig anwählen)



Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 152
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Hallo Markjaro,

Zitat
Hast Du denn in Cups einerseits und im beschriebenen Drucker-Config-Bereich andererseits unter "Drucken" =>2-Seitig den 2-Seitigen Modus aktiviert?
Unter Cups heißt diese Einstellung Duplex und findet sich unter "Standardeinstellungen festlegen" im Bereich General.
habe sowohl unter Cups als auch unter "Drucker einrichten", "2-sided-printing: On(Portrait)" eingeschaltet. Wobei es für mich komisch ist, dass die Einstellungen nicht gegenseitig übernommen werden, obwohl eine Einrichtung des Drucker unter Cups sich dann automatisch auch unter "Drucker einrichten" findet.

Zitat
Beim Drucken selber muss natürlich auch der Duplexdruck aktiviert sein.
Unter Libre-Office heißt diese Option "Blattseiten" (Doppelseitig anwählen)
Du hast recht, wenn ich es nochmals im Programm selbst einstelle, dann kann ich doppelseitig Drucken. Doch das ist so nicht korrekt. Wenn ich in den Grundeinstellungen doppelseitig und DINA4 einstelle, so muss dies als Standard in alle Programme übernommen werden.

@Gosia:
Zitat
Zuvor ist im Printdialog der Brother-Drucker 2-mal aufgetaucht, also 1-mal zuviel. Und dass, obwohl er unter localhost:631, also cups, nur einmal tatsächlich installiert war, ebenso unter KDE Drucker einrichten. Dieser Ghost-Drucker ist (offenbar aktuell) verschwunden. Vermutlich, indem ich unter Eingabe der IP-Adresse des Druckers im Browser in den Druckereinstellungen selbst einen Reset durchgeführt habe, ohne die Netzwerkeinstellungen zu ändern.
Übrigens, warum auch immer, jetzt ist der 2. Ghost-Drucker im Printer-Dialog wieder aufgetaucht, obwohl er weder unter Cups noch unter "KDE Drucker einrichten" auftaucht.

Viele Grüße, Rulinux

Offline Markjaro

  • Neuling
  • *
  • Beiträge: 41
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
Nachtrag: Ich habe gerade auf einem älteren Lenovo-Laptop meinen MFC-2700 Brother-Drucker installiert und genau das gleiche Problem. Es erscheinen 2 Brother-Drucker, obwohl ich (gerade noch mal nachgezählt) nur einen habe. Ich vermute das Problem liegt an dem AUR-Script das den Druckertreiber installiert. Leider ist das nicht reproduzierbar und auf einem anderen Laptop erscheint der Drucker auch nur 1x.  ???

Das ist zwar keine Lösung aber ein Hinweis, dass Rulinux mit dem Problem nicht alleine ist.  :)
« Letzte Änderung: 26. Juli 2020, 23:38:59 von Markjaro »