Autor Thema: LAN mit RTL8125  (Gelesen 582 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline nonni

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
LAN mit RTL8125
« am: 30. Juni 2020, 21:54:26 »
Hi zusammen,

ich habe ein Problem mit meiner NIC auf einem MSI P100x (Z490 Chipsatz). Laut Spezifikation hat der einen RTL8125. inxi spuckt mir das auch aus:

Network:   Device-1: Intel driver: iwlwifi
           Device-2: Realtek RTL8125 2.5GbE driver: N/A

Allerdings erkennt der Kernel 5.6.16-1 diesen nicht. Fallback auf r8168 oder r8169 funktioniert auch nicht.

Es gibt einen RT8125  Treiber im Arch, aber da funktioniert der Build nicht. Offensichtlich stimmt der build-Pfad nicht... hat den r8125 schon mal jemand probiert?

==> Beginne build()...
/var/tmp/pamac-build-myuser/r8125/PKGBUILD: Zeile 21: /usr/src/linux/version: Datei oder Verzeichnis nicht gefunden
make: *** /lib/modules//build: Datei oder Verzeichnis nicht gefunden.

Hat hier jemand eine Idee?

VG
« Letzte Änderung: 30. Juni 2020, 22:08:43 von nonni »

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1454
  • Dankeschön: 225 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma
  • Grafikkarte: NVIDIA [GeForce RTX 2070] [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y; 4.19.y; 4.14.y,
  • Prozessor: Notebook: Tuxedo Computers XA1510 AMD Ryzen 9 3900X; WorkStation Intel Xeon
  • Skill: Fortgeschritten
  • Zweig: Stable Version: on PowerWorkStation, NB, HTPC, Desktop:s: Testing/Unstable only VM
Re: LAN mit RTL8125
« Antwort #1 am: 01. Juli 2020, 09:05:49 »
Moin @nonni

ohne Hardware - Information von dem System ist es schwierig,

führe folgenden Befehl in der Konsole/Terminal aus
inxi -Fzxxxxo
poste diese Info's im Menü unter " # "

Sehr wichtig sind die Informationen " chip ID: "

Wichtig sind auch bessere Informationen zu dem Packages, welches installiert werden sollte
https://aur.archlinux.org/packages.php?O=0&K=realtek&do_Search=Go

Gibt es Probleme mit einem AUR-Packages ist general der Betreuer anzusprechen,

Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline nonni

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: LAN mit RTL8125
« Antwort #2 am: 01. Juli 2020, 11:14:25 »
Hi,

hier der Output von inxi -Fzxxxxo:

System:    Host: migo-pc Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Budgie 10.5.1
           info: budgie-panel, plank wm: budgie-wm dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:   Type: Desktop System: Micro-Star product: Creator Z490 P100X (MS-B929) v: 1.2 serial: <filter>
           Mobo: Micro-Star model: MEG Z490I UNIFY (MS-7C77) v: 1.2 serial: <filter> UEFI: American Megatrends v: A.10
           date: 05/05/2020
Battery:   Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter> charge: 55% (should be ignored) rechargeable: yes
           status: Discharging
CPU:       Topology: 10-Core model: Intel Core i9-10900K bits: 64 type: MT MCP arch: N/A L2 cache: 20.0 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 148040
           Speed: 5002 MHz min/max: 800/5300 MHz Core speeds (MHz): 1: 5002 2: 4998 3: 4999 4: 4933 5: 4976 6: 4925 7: 4940
           8: 4934 9: 4932 10: 4944 11: 4938 12: 4999 13: 4995 14: 4949 15: 4993 16: 4936 17: 4998 18: 4935 19: 4999 20: 4998
Graphics:  Device-1: Intel vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bc5
           Device-2: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0
           chip ID: 10de:1e07
           Display: x11 server: X.org 1.20.8 driver: nvidia compositor: budgie-wm resolution: <xdpyinfo missing>
           OpenGL: renderer: GeForce RTX 2080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes
Audio:     Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:06c8
           Device-2: NVIDIA TU102 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:10f7
           Sound Server: ALSA v: k5.6.16-1-MANJARO
Network:   Device-1: Intel driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:06f0
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: N/A port: 3000 bus ID: 3b:00.0 chip ID: 10ec:8125
Drives:    Local Storage: total: 2.98 TiB used: 117.70 GiB (3.9%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBPNTY-1T00-1032 size: 953.87 GiB speed: 31.6 Gb/s
           lanes: 4 serial: <filter> rev: 11110000 scheme: GPT
           ID-2: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB speed: 6.0 Gb/s serial: <filter> rev: BB6Q
           scheme: GPT
           ID-3: /dev/sdb vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB speed: 6.0 Gb/s rotation: 5400 rpm
           serial: <filter> rev: 0001 scheme: GPT
Partition: ID-1: / size: 47.81 GiB used: 8.91 GiB (18.6%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 179.90 GiB used: 108.73 GiB (60.4%) fs: ext4 dev: /dev/sda2
Unmounted: ID-1: /dev/nvme0n1p2 size: 128.0 MiB fs: <root required> label: N/A uuid: N/A
           ID-2: /dev/nvme0n1p3 size: 952.86 GiB fs: ntfs label: Windows uuid: F4FA6F4EFA6F0C64
           ID-3: /dev/nvme0n1p4 size: 800.0 MiB fs: ntfs label: WINRE uuid: C49E6FCA9E6FB398
           ID-4: /dev/sdb1 size: 1.80 TiB fs: ntfs label: Data uuid: 32A87482A874467F
           ID-5: /dev/sdb2 size: 21.12 GiB fs: ntfs label: BIOS_RVY uuid: 269C77079C76D133
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A gpu: nvidia temp: 30 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 22%
Info:      Processes: 412 Uptime: 1m Memory: 62.65 GiB used: 1.26 GiB (2.0%) Init: systemd v: 245 Compilers: gcc: 10.1.0
           Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.37

Das oben erwähnte Paket aus dem AUR war das r8125-dkms.

Viele Grüße



Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1454
  • Dankeschön: 225 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma
  • Grafikkarte: NVIDIA [GeForce RTX 2070] [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y; 4.19.y; 4.14.y,
  • Prozessor: Notebook: Tuxedo Computers XA1510 AMD Ryzen 9 3900X; WorkStation Intel Xeon
  • Skill: Fortgeschritten
  • Zweig: Stable Version: on PowerWorkStation, NB, HTPC, Desktop:s: Testing/Unstable only VM
Re: LAN mit RTL8125
« Antwort #3 am: 01. Juli 2020, 13:39:07 »
Zitat
Allerdings erkennt der Kernel 5.6.16-1 diesen nicht. Fallback auf r8168 oder r8169 funktioniert auch nicht.

wurde zu diesem Kernel die " linux56-headers " installiert ?, habe vergessen nach zu fragen, Sorry.
Weitere Info's zu Kernel 5.6 dieser Kernel hat bei Version " stable:   5.6.19 [EOL] erreicht,
wird also nicht mehr weiter gepflegt, somit werden dann auch auf kurz o. lang die Packages entfernt.
https://www.kernel.org/

Nach dieser Information - Quelle https://cateee.net/lkddb/web-lkddb/R8169.html
werden die Kernel " Linux kernels: 5.4–5.7, 5.8-rc+HEAD "
unterstützt,

Andere Info's hier zu:
https://forum.manjaro.org/t/r8168-kernel-5-6-3-driver-broken/135325/8

Würde vorschlagen den LTS Kernel " linux54 incl. linux54-headers linux54-r8168 " zu installieren,
linuxXX-headers sollten general mit installiert werden.

Bei den LTS - Kernel verpasst man nicht's, jede " relevante Änderung/Neuerug " fliessen hier ein,
Je nach Projekt von Kernel.org können diese Dinge über mehrere Mainlaine - Kernel gehen,
also immer Vorsicht walten lassen, der neuste Kernel muss für den/einen/anderen nicht immer von Vorteil sein.

« Letzte Änderung: 01. Juli 2020, 13:43:53 von SpiritOfTux »
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline nonni

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: LAN mit RTL8125
« Antwort #4 am: 02. Juli 2020, 13:01:13 »
Hi,

ja den Thread:
https://forum.manjaro.org/t/r8168-kernel-5-6-3-driver-broken/135325/8
hatte ich auch schon gesehen. Soweit ich das sehe scheint das ein Kernel Problem zu sein.

Aber offensichtlich erkennt der 5.4er LTS Kernel jetzt auch das Gerät, aber das Verhalten ist trotzdem seltsam.

lspci -v meldet das Modul r8169 als geladen (so verstehe ich das), aber es wird kein Treiber installiert (und infolgedessen auch kein Device).
3b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8125 2.5GbE Controller
Flags: fast devsel, IRQ 16
I/O ports at 3000 [size=256]
Memory at a4200000 (64-bit, non-prefetchable) [size=64K]
Memory at a4210000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=32 Masked-
Capabilities: [d0] Vital Product Data
Capabilities: [100] Advanced Error Reporting
Capabilities: [148] Virtual Channel
Capabilities: [168] Device Serial Number 01-00-00-00-68-4c-e0-00
Capabilities: [178] Transaction Processing Hints
Capabilities: [204] Latency Tolerance Reporting
Capabilities: [20c] L1 PM Substates
Capabilities: [21c] Vendor Specific Information: ID=0002 Rev=4 Len=100 <?>
Kernel modules: r8169

Seltsamerweise kommt diese Meldung immer, obwohl eigentlich der r8169 blacklisted ist und der r8168 geladen ist:
[migo@migo-pc ~]$ cat /proc/modules | grep r81
r8168 573440 0 - Live 0x0000000000000000 (OE)

Und kein Device:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 40:ec:99:0f:e8:bc brd ff:ff:ff:ff:ff:ff

Nur den r8169 habe ich auch probiert, aber auch hier der gleiche Effekt, kein Treiber/kein Device, obwohl das Kernelmodul geladen wird.



Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1454
  • Dankeschön: 225 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma
  • Grafikkarte: NVIDIA [GeForce RTX 2070] [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y; 4.19.y; 4.14.y,
  • Prozessor: Notebook: Tuxedo Computers XA1510 AMD Ryzen 9 3900X; WorkStation Intel Xeon
  • Skill: Fortgeschritten
  • Zweig: Stable Version: on PowerWorkStation, NB, HTPC, Desktop:s: Testing/Unstable only VM
Re: LAN mit RTL8125
« Antwort #5 am: 02. Juli 2020, 23:36:16 »
Zitat
Seltsamerweise kommt diese Meldung immer, obwohl eigentlich der r8169 blacklisted ist und der r8168 geladen ist:

Siehe Dir diesen Artikel an
https://forum.manjaro.org/t/solved-need-a-working-solution-for-realtek-network-drivers-for-manjaro-mate-17-1-7/48200/8
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline nonni

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: LAN mit RTL8125
« Antwort #6 am: 10. Juli 2020, 16:48:05 »
Hi,

im verlinkten Thread war ein ähnliches Symptom beschrieben, aber das Grundproblem war bei mir daß er schon den Driver überhaupt nicht laden konnte.
Im Log tauchte dann die hilfreiche Info aus dem Kernel Module auf:
r8169 0000: 02:00:00.0: unknown chip XID 641

Offensichtlich erkannte der r8169 schlichtweg den (zu neuen) Chipsatz nicht.
Durchprobieren verschiedenster Treiber, u.a. der oben schon erwähnte r8125 aus dem AUR, scheiterten immer teilweise schon am Build wegen nicht vorhandener Verzeichnisse etc.

Auf der Realtek Seite findet sich allerdings ein aktueller Referenz-Treiber (r8125-9.003.05) für die r8125:
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software

In einigen Foren wurde zwar geraten die Dist-eigenen Treiber zu verwenden und nicht den generischen Treiber, aber schlußendlich hat dieser funktioniert.
Archiv runterladen, entsprechend den Anweisungen im README entpacken und kompilieren... läuft!
(r8168 und r8169 noch blacklisten)

Manchmal kann es so einfach sein.  ;D

Auf jeden Fall vielen Dank für die schnelle und ausdauernde Unterstützung!

« Letzte Änderung: 10. Juli 2020, 16:53:39 von nonni »