Autor Thema: Kann Paketdatei nicht öffnen (Unrecognized Archive)  (Gelesen 137 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Daedrafuerst1745

  • Neuling
  • *
  • Beiträge: 2
  • Karma: +0/-0
  • Skill: Anfänger
Kann Paketdatei nicht öffnen (Unrecognized Archive)
« am: 10. August 2020, 18:23:17 »
Hallo, ich bin der Pascal und habe mir gerade frisch Manjaro installiert, und bin noch ein ziemlicher newbie, deshalb wende ich mich hiermit mal direkt an euch :)

Ich wollte zuallererst natürlich die ganzen Updates installieren, bei diesen kommt jedoch die Fehlermeldung: "Kann Paketdatei nicht öffnen".

Danach bin ich dann auf Details gegangen und dort zeigt er mir folgendes an:

"Synchronisiere Paketdatenbanken...
Starte komplettes System-Upgrade...

Vorbereitung...
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...
Überprüfe Schlüsselring...
Integrität wird überprüft...
Paketdateien werden geladen...
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/archlinux-keyring-20200622-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-system-20200427-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format

Vorgang konnte nicht abgeschlossen werden:
Kann Paketdatei nicht öffnen"

Ich hoffe einer von euch kann mir da weiter helfen.

Liebe Grüße
Pascal

Offline jolic

  • Neuling
  • *
  • Beiträge: 43
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: UHD 630
  • Grafikkartentreiber: i915
  • Kernel: 5.4.x (LTS Kernel)
  • Prozessor: I7-8700T
  • Skill: Durchschnitt
  • Zweig: stable
Re: Kann Paketdatei nicht öffnen (Unrecognized Archive)
« Antwort #1 am: 10. August 2020, 19:41:00 »
Hallo Pascal, versuch das mal per Konsole.

Alle Pakete im Cache vollständig entfernen (Pacman Cache):
sudo pacman -Scc(beide Fragen mit "j" bestätigen)

dann:
sudo pacman-mirrors --fasttrack
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh
sudo pacman -Syyu

Der Tipp ist von SpiritOfTux:  Pakete fehlerhaft

jolic

Offline Daedrafuerst1745

  • Neuling
  • *
  • Beiträge: 2
  • Karma: +0/-0
  • Skill: Anfänger
Re: Kann Paketdatei nicht öffnen (Unrecognized Archive)
« Antwort #2 am: 11. August 2020, 00:18:27 »
Hey, danke erstmal für die Hilfe. Hat mir auch erstmal ein Stück geholfen, denn der hat nun einige Updates gemacht, nachdem ich die Befehle der Reihenfolge nach eingegeben habe. Jedoch hat sich mein eigentliches Problem noch nicht gelöst. Denn beim 2. Schritt mit dem Code:
"sudo pacman -S archlinux-keyring manjaro-keyring"
Kamen wieder die gleichen Fehlermeldungen. Das sah dann wie folgt aus:

:: Installation fortsetzen? [J/n] j
(2/2) Prüfe Schlüssel im Schlüsselring             [######################] 100%
(2/2) Überprüfe Paket-Integrität                   [######################] 100%
(2/2) Lade Paket-Dateien                           [######################] 100%
Fehler: Konnte Datei /var/cache/pacman/pkg/archlinux-keyring-20200622-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/cache/pacman/pkg/manjaro-keyring-20200603-1-any.pkg.tar.zst nicht öffnen: Unrecognized archive format
Fehler: Konnte den Vorgang nicht durchführen (Kann Paketdatei nicht öffnen)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Offline virtual-dev

  • Sr. Mitglied
  • ****
  • Beiträge: 306
  • Dankeschön: 720 mal
  • Karma: +0/-0
  • Desktop: Xfce4
  • Grafikkarte: Intel HD Graphics 630
  • Grafikkartentreiber: free
  • Kernel: 5.4 LTS
  • Prozessor: i7-7700HQ
  • Skill: Fortgeschritten
  • Zweig: *
Re: Kann Paketdatei nicht öffnen (Unrecognized Archive)
« Antwort #3 am: 11. August 2020, 05:00:59 »
Hallo

Zitat
Upstream notice
Arch updated their default compression to zstd. We adopted to the same standard.
More and more packages will have the zst extension from now on. If you get for
what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Im originalen Archlinux wurde das Packformat für die Pakete geändert
und nun werden immer mehr Pakete mit dem neuen Packformat gepackt.
Deshalb mußt du bei Problemen den obigen Befehl ausführen.

mfg
Folgende Mitglieder bedankten sich: snowie