Autor Thema: Mounten MicroSDcard funktioniert nicht, Karte wird erst gar nicht erkannt  (Gelesen 200 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Meine Micro-SDCard (SDKarte), die ich von meinen Smartphone habe, findet sich nicht unter /mtn/...

Auch wird sie mit dem Befehl gar nicht aufgeführt.
sudo fdisk -lso, dass ich sie nicht gemäß dieser Anleitung überhaupt erst mounten kann.
sudo mount -o uid=1000,gid=1000 /dev/sdd1 /mntwobei hier natürlich /dev/sdd1 durch meinen Einhängepunkt zu ersetzen wäre, wenn ich den denn wüsste. Ich beziehe mich dabei auf die Ausführungen unter:
https://www.linuxmintusers.de/index.php?PHPSESSID=11b8f7e7cb27a63d21c135860084ea5b&topic=5127.msg42663#msg42663

Weiß da jemand weiter? Danke, Rulinux
« Letzte Änderung: 17. August 2020, 00:27:20 von Rulinux »

Offline Markjaro

  • Jr. Mitglied
  • **
  • Beiträge: 57
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
gib mal ein:
lsblk

PS: Eine Micro SD-Card wird idR mit mmcblk0 und nicht mit /dev/sdd1 eingebunden. Ich vermute da liegt der Hund begraben.

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Wenn ich lsblk eingebe erhalte ich am ehesten passend für eine 256GB SDCard
mmcblk0     179:0    0 238,5G  0 disk
└─mmcblk0p1 179:1    0 238,5G  0 part
dann sollte der mount code wohl der sein?
sudo mount -o uid=1000,gid=1000 /mmcblk0/mmcblk0p1 /mnt
Und es funktioniert (trotz Fehlermeldung in der Konsole)!!

Wird das jetzt für immer gemountet, wenn ich die Karte einstecke oder muss in fstab etwas eingeben, "wenn die SDKarte eingesteckt wird, dann mounten?" Als Grundlage für fstab
/mmcblk0/mmcblk0p1       /run/media/omlinux/SD256GB/       exfat   automount,uid=1000,gid=1000 /mmcblk0/mmcblk0p1  0    0 mit der Bitte um Korrektur.

Danke, Markjaro.


« Letzte Änderung: 17. August 2020, 10:47:00 von Rulinux »

Offline Markjaro

  • Jr. Mitglied
  • **
  • Beiträge: 57
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
Nicht ganz.
Probiere mal
sudo mount -o uid=1000,gid=1000 /dev/mmcblk0p1 /mnt

 :)

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Mit
sudo mount -o uid=1000,gid=1000 /dev/mmcblk0p1 /mntkommt die Meldung
FUSE exfat 1.3.0
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
Was heißt das?

Offline Markjaro

  • Jr. Mitglied
  • **
  • Beiträge: 57
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
ist schon etwas in /mnt eingebunden?
Dann erstelle einen anderen Order wie /run/media/rulinux/sd-card und mounte die SD-Karte da hin.

sudo mkdir /run/media/rulinux/sd-card
sudo chown rulinux:wheel /run/media/rulinux/sd-card
sudo mount  /dev/mmcblk0p1 /run/media/rulinux/sd-card

oder so ähnlich.  :P
« Letzte Änderung: 17. August 2020, 10:55:58 von Markjaro »

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Danke Dir Markjaro!

Gilt das jetzt für jede SDCard, die ich einstecke?

Muss ich noch etwas in fstab eingeben, damit die SDCard automatisch beim Einstecken gemountet wird?

Offline Markjaro

  • Jr. Mitglied
  • **
  • Beiträge: 57
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
Ich würde den Beitrag Deiner fstab um folgenden Beitrag bereichern:

/dev/mmcblk0p1 /run/media/rulinux/sd-card auto defaults,nofail


Das gilt für jedes Laufwerk, das Du anschließst oder einsteckst:
mit lsblk das Laufwerk ausfindig machen und mit sudo mount {Pfad des Laufwerks} {Verzeichnis wohin das Laufwerk gemountet werden soll}.
Achte dabei darauf, dass das Verzeichnis auch für den Ottonormaluser beschreibbar ist, mit sudo chown user:wheel {Pfad des Verzeichnisses}
« Letzte Änderung: 17. August 2020, 13:08:31 von Markjaro »

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Ist so der komplette Eintrag für fstab richtig, das sie sich anmeldet, wenn sie eingesteckt wird?
/dev/mmcblk0p1       /run/media/rulinux/SD256GB/       exfat   auto defaults,nofail  0    0 Doch er meldet mit
sudo mount -aeinen Einlesefehler. Vermutlich ist da noch ein kleiner Wurm drin?

Offline Markjaro

  • Jr. Mitglied
  • **
  • Beiträge: 57
  • Dankeschön: 6 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: intel
  • Kernel: Den aktuellsten
  • Prozessor: i5-2520M
  • Skill: Durchschnitt
  • Zweig: stable
Ändere mal das exfat in auto und lasse das andere auto weg.

/dev/mmcblk0p1       /run/media/rulinux/SD256GB/       auto defaults,nofail  0    0

Offline Rulinux

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 165
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Im Einfachen findet sich das Vollkommene.
  • Desktop: KDE, zwischendurch mal XFCE
  • Grafikkarte: Intel UHD Graphics 620 + Nvidia GeForce 930MX
  • Grafikkartentreiber: 26.20.100.7263 + 23.21.13.8873
  • Kernel: neuesten, vollwertigen Kernel
  • Prozessor: Intel Core i5-8250U
  • Skill: Anfänger
  • Zweig: stable
Jetzt scheint alles geklappt zu haben. Danke Dir, Markjaro.

Herzliche Grüße, Rulinux